summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-02-09 18:02:55 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-02-09 18:02:55 +0000
commit763fc0b3a047ab59c0906a4ab2dab7c0c99bcd03 (patch)
tree9c8024d5fd94aa6a45de780a8a6e27c83ed77c0a /media-gfx/wally
parentStable on alpha, bug #242270 (diff)
downloadgentoo-2-763fc0b3a047ab59c0906a4ab2dab7c0c99bcd03.tar.gz
gentoo-2-763fc0b3a047ab59c0906a4ab2dab7c0c99bcd03.tar.bz2
gentoo-2-763fc0b3a047ab59c0906a4ab2dab7c0c99bcd03.zip
Version bump to 2.0.0 . See bug #257899
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/wally')
-rw-r--r--media-gfx/wally/ChangeLog9
-rw-r--r--media-gfx/wally/wally-2.0.0.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/media-gfx/wally/ChangeLog b/media-gfx/wally/ChangeLog
index 5829815af3d7..9348082b9d62 100644
--- a/media-gfx/wally/ChangeLog
+++ b/media-gfx/wally/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/wally
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.3 2008/10/20 21:05:29 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.4 2009/02/09 18:02:55 hwoarang Exp $
+
+*wally-2.0.0 (09 Feb 2009)
+
+ 09 Feb 2009; Markos Chandras <hwoarang@gentoo.org> +wally-2.0.0.ebuild:
+ Version bump to 2.0.0 ( see bug #257899 )
*wally-1.3.2 (20 Oct 2008)
diff --git a/media-gfx/wally/wally-2.0.0.ebuild b/media-gfx/wally/wally-2.0.0.ebuild
new file mode 100644
index 000000000000..9d8ce0f0b840
--- /dev/null
+++ b/media-gfx/wally/wally-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/wally-2.0.0.ebuild,v 1.1 2009/02/09 18:02:55 hwoarang Exp $
+
+EAPI="2"
+inherit eutils qt4
+
+DESCRIPTION="A Qt4 wallpaper changer"
+HOMEPAGE="http://wally.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libexif
+ x11-libs/qt-gui:4 "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # fix pre-stripped files
+ sed -i "s/warn_on/warn_on nostrip/" ${PN}.pro
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ newicon res/images/idle.png wally.png
+ make_desktop_entry wally Wally wally "Graphics;Qt"
+}