summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-01-27 19:20:25 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-01-27 19:20:25 +0000
commitb8d8049a6ed42ec5b2c9cebea3a5ff8841fc9a4d (patch)
tree2d90e45a073822b9be1a8305d951009337c85e3d /media-gfx/iscan
parentVersion bump, bug 499342 (diff)
downloadgentoo-2-b8d8049a6ed42ec5b2c9cebea3a5ff8841fc9a4d.tar.gz
gentoo-2-b8d8049a6ed42ec5b2c9cebea3a5ff8841fc9a4d.tar.bz2
gentoo-2-b8d8049a6ed42ec5b2c9cebea3a5ff8841fc9a4d.zip
fixed build failures against libpng-1.6, bug 486382
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'media-gfx/iscan')
-rw-r--r--media-gfx/iscan/ChangeLog9
-rw-r--r--media-gfx/iscan/files/iscan-2.26.2-png-libs.patch37
-rw-r--r--media-gfx/iscan/files/iscan-2.29.1-png-libs.patch37
-rw-r--r--media-gfx/iscan/iscan-2.26.2.ebuild5
-rw-r--r--media-gfx/iscan/iscan-2.29.1.5.ebuild5
5 files changed, 87 insertions, 6 deletions
diff --git a/media-gfx/iscan/ChangeLog b/media-gfx/iscan/ChangeLog
index f65d34593e11..892ea03cbef2 100644
--- a/media-gfx/iscan/ChangeLog
+++ b/media-gfx/iscan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/iscan
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/ChangeLog,v 1.55 2013/07/21 08:55:59 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/ChangeLog,v 1.56 2014/01/27 19:20:25 axs Exp $
+
+ 27 Jan 2014; Ian Stakenvicius <axs@gentoo.org>
+ +files/iscan-2.26.2-png-libs.patch, +files/iscan-2.29.1-png-libs.patch,
+ iscan-2.26.2.ebuild, iscan-2.29.1.5.ebuild:
+ fixed build failures against libpng-1.6, bug 486382
21 Jul 2013; Pacho Ramos <pacho@gentoo.org> -iscan-2.28.1.3.ebuild,
metadata.xml:
diff --git a/media-gfx/iscan/files/iscan-2.26.2-png-libs.patch b/media-gfx/iscan/files/iscan-2.26.2-png-libs.patch
new file mode 100644
index 000000000000..0866e604915a
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-2.26.2-png-libs.patch
@@ -0,0 +1,37 @@
+diff -ur iscan-2.26.2/configure.ac iscan-2.26.2.new/configure.ac
+--- iscan-2.26.2/configure.ac 2014-01-27 13:37:26.782024452 -0500
++++ iscan-2.26.2.new/configure.ac 2014-01-27 13:36:47.738024120 -0500
+@@ -274,6 +274,9 @@
+ AC_HELP_STRING([--enable-$1],
+ [ensure support for the $3 file format]),
+ [if test "x$enable_$1" != xno; then
++ if test "x$4" != xno; then
++ PKG_CHECK_MODULES($3,[$4])
++ fi
+ iff_header="`echo $2 | $as_tr_sh`"
+ AC_CHECK_HEADERS([$2])
+ if test `eval echo '$ac_cv_header_'$iff_header` \
+@@ -284,9 +287,9 @@
+ [AC_CHECK_HEADERS([$2])])
+ ])
+
+-ISCAN_FILE_FORMAT(jpeg,jpeglib.h,JPEG)
+-ISCAN_FILE_FORMAT(png,png.h,PNG)
+-ISCAN_FILE_FORMAT(tiff,tiffio.h,TIFF)
++ISCAN_FILE_FORMAT(jpeg,jpeglib.h,JPEG,no)
++ISCAN_FILE_FORMAT(png,png.h,PNG,libpng)
++ISCAN_FILE_FORMAT(tiff,tiffio.h,TIFF,no)
+
+
+ dnl Support for performance measurements.
+diff -ur iscan-2.26.2/frontend/Makefile.am iscan-2.26.2.new/frontend/Makefile.am
+--- iscan-2.26.2/frontend/Makefile.am 2014-01-27 13:31:09.488021241 -0500
++++ iscan-2.26.2.new/frontend/Makefile.am 2014-01-27 13:37:50.065024650 -0500
+@@ -37,6 +37,7 @@
+ -lltdl \
+ @GTK_LIBS@ \
+ @GDK_IMLIB_LIBS@ \
++ @PNG_LIBS@ \
+ $(top_builddir)/non-free/libesmod.so
+ iscan_SOURCES = \
+ $(iscan_source_files)
diff --git a/media-gfx/iscan/files/iscan-2.29.1-png-libs.patch b/media-gfx/iscan/files/iscan-2.29.1-png-libs.patch
new file mode 100644
index 000000000000..32de60a83899
--- /dev/null
+++ b/media-gfx/iscan/files/iscan-2.29.1-png-libs.patch
@@ -0,0 +1,37 @@
+diff -ur iscan-2.29.1/configure.ac iscan-2.29.1.new/configure.ac
+--- iscan-2.29.1/configure.ac 2014-01-27 14:15:28.139043864 -0500
++++ iscan-2.29.1.new/configure.ac 2014-01-27 14:17:10.608044736 -0500
+@@ -279,6 +279,9 @@
+ AC_HELP_STRING([--enable-$1],
+ [ensure support for the $3 file format]),
+ [if test "x$enable_$1" != xno; then
++ if test "x$4" != xno; then
++ PKG_CHECK_MODULES($3,[$4])
++ fi
+ iff_header="`echo $2 | $as_tr_sh`"
+ AC_CHECK_HEADERS([$2])
+ if test `eval echo '$ac_cv_header_'$iff_header` \
+@@ -289,9 +292,9 @@
+ [AC_CHECK_HEADERS([$2])])
+ ])
+
+-ISCAN_FILE_FORMAT(jpeg,jpeglib.h,JPEG)
+-ISCAN_FILE_FORMAT(png,png.h,PNG)
+-ISCAN_FILE_FORMAT(tiff,tiffio.h,TIFF)
++ISCAN_FILE_FORMAT(jpeg,jpeglib.h,JPEG,no)
++ISCAN_FILE_FORMAT(png,png.h,PNG,libpng)
++ISCAN_FILE_FORMAT(tiff,tiffio.h,TIFF,no)
+
+
+ dnl Support for performance measurements.
+diff -ur iscan-2.29.1/frontend/Makefile.am iscan-2.29.1.new/frontend/Makefile.am
+--- iscan-2.29.1/frontend/Makefile.am 2014-01-27 14:15:28.123043864 -0500
++++ iscan-2.29.1.new/frontend/Makefile.am 2014-01-27 14:17:43.628045017 -0500
+@@ -37,6 +37,7 @@
+ -lltdl \
+ @GTK_LIBS@ \
+ @GDK_IMLIB_LIBS@ \
++ @PNG_LIBS@ \
+ $(top_builddir)/non-free/libesmod.so
+ iscan_SOURCES = \
+ $(iscan_source_files)
diff --git a/media-gfx/iscan/iscan-2.26.2.ebuild b/media-gfx/iscan/iscan-2.26.2.ebuild
index 126af8066a34..ce58134390ca 100644
--- a/media-gfx/iscan/iscan-2.26.2.ebuild
+++ b/media-gfx/iscan/iscan-2.26.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.26.2.ebuild,v 1.9 2012/12/11 03:42:44 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.26.2.ebuild,v 1.10 2014/01/27 19:20:25 axs Exp $
EAPI="2"
@@ -82,6 +82,7 @@ src_prepare() {
epatch "${FILESDIR}"/iscan-2.25.0-drop-ltdl.patch
epatch "${FILESDIR}"/iscan-2.25.0-fix-g++-test.patch
epatch "${FILESDIR}"/iscan-2.26.2-libpng15.patch
+ epatch "${FILESDIR}"/iscan-2.26.2-png-libs.patch
eautoreconf
}
diff --git a/media-gfx/iscan/iscan-2.29.1.5.ebuild b/media-gfx/iscan/iscan-2.29.1.5.ebuild
index 5ecf6959647d..2d0ad26f1c6c 100644
--- a/media-gfx/iscan/iscan-2.29.1.5.ebuild
+++ b/media-gfx/iscan/iscan-2.29.1.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.29.1.5.ebuild,v 1.2 2013/02/20 19:35:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.29.1.5.ebuild,v 1.3 2014/01/27 19:20:25 axs Exp $
EAPI="4"
@@ -88,6 +88,7 @@ src_prepare() {
epatch "${FILESDIR}"/iscan-2.29.1-drop-ltdl.patch
epatch "${FILESDIR}"/iscan-2.25.0-fix-g++-test.patch
epatch "${FILESDIR}"/iscan-2.28.1.3+libpng-1.5.patch
+ epatch "${FILESDIR}"/iscan-2.29.1-png-libs.patch
eautoreconf
}