summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-06-11 12:43:29 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-06-11 12:43:29 +0000
commitfe704cf9f610af7c05bb2727e9c4886c3917b995 (patch)
tree26683f7af6c0e1ab4055be761748118292360fb4 /media-gfx/exiv2
parentApply upstream patch for plasmaboard. Requested by mail. (diff)
downloadgentoo-2-fe704cf9f610af7c05bb2727e9c4886c3917b995.tar.gz
gentoo-2-fe704cf9f610af7c05bb2727e9c4886c3917b995.tar.bz2
gentoo-2-fe704cf9f610af7c05bb2727e9c4886c3917b995.zip
Revision bump for stripping out the new boost dep, so package can be fast-stabled. Per bug #273577.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/ChangeLog9
-rw-r--r--media-gfx/exiv2/exiv2-0.18.1-r1.ebuild111
-rw-r--r--media-gfx/exiv2/exiv2-0.18.1.ebuild26
3 files changed, 122 insertions, 24 deletions
diff --git a/media-gfx/exiv2/ChangeLog b/media-gfx/exiv2/ChangeLog
index 29ec2c803f16..68e338160b57 100644
--- a/media-gfx/exiv2/ChangeLog
+++ b/media-gfx/exiv2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/exiv2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.69 2009/05/26 05:17:49 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.70 2009/06/11 12:43:29 scarabeus Exp $
+
+*exiv2-0.18.1-r1 (11 Jun 2009)
+
+ 11 Jun 2009; Tomáš Chvátal <scarabeus@gentoo.org> exiv2-0.18.1.ebuild,
+ +exiv2-0.18.1-r1.ebuild:
+ Revision bump for stripping out the new boost dep, so package can be
+ fast-stabled. Per bug #273577.
26 May 2009; Gordon Malm <gengor@gentoo.org> exiv2-0.18.ebuild,
exiv2-0.18.1.ebuild:
diff --git a/media-gfx/exiv2/exiv2-0.18.1-r1.ebuild b/media-gfx/exiv2/exiv2-0.18.1-r1.ebuild
new file mode 100644
index 000000000000..7ad2fb82319f
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.18.1-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.18.1-r1.ebuild,v 1.1 2009/06/11 12:43:29 scarabeus Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+SRC_URI="http://www.exiv2.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="contrib doc examples nls unicode xmp zlib"
+IUSE_LINGUAS="de es fi fr pl ru sk"
+for LNG in ${IUSE_LINGUAS}; do
+ IUSE="${IUSE} linguas_${LNG}"
+done
+
+RDEPEND="
+ virtual/libiconv
+ nls? ( virtual/libintl )
+ xmp? ( dev-libs/expat )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ contrib? ( >=dev-libs/boost-1.37 )
+ doc? (
+ dev-lang/python
+ app-doc/doxygen
+ dev-libs/libxslt
+ dev-util/pkgconfig
+ media-gfx/graphviz
+ )
+ nls? ( sys-devel/gettext )
+"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use unicode; then
+ for i in doc/cmd.txt; do
+ echo ">>> Converting "${i}" to UTF-8"
+ iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+
+ if use doc; then
+ echo ">>> Updating doxygen config"
+ doxygen 2>&1 >/dev/null -u config/Doxyfile
+ fi
+
+ if use contrib; then
+ # create build environment for contrib
+ ln -snf ../../src contrib/organize/exiv2
+ sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
+ -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
+ contrib/organize/boost.mk
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable nls) $(use_enable xmp)"
+ use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
+
+ # Bug #78720. amd64/gcc-3.4/-fvisibility* fail.
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ use amd64 && myconf="${myconf} --disable-visibility"
+ fi
+
+ econf ${myconf}
+ emake || die "emake failed"
+
+ if use contrib; then
+ emake -C contrib/organize \
+ LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
+ || die "emake organize failed"
+ fi
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use contrib; then
+ emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
+ fi
+
+ dodoc README doc/{ChangeLog,cmd.txt}
+ use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
+ use doc && dohtml -r doc/html/.
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins samples/*.cpp
+ fi
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "PLEASE PLEASE take note of this:"
+ ewarn "Please make *sure* to run revdep-rebuild now"
+ ewarn "Certain things on your system may have linked against a"
+ ewarn "different version of exiv2 -- those things need to be"
+ ewarn "recompiled. Sorry for the inconvenience!"
+ ewarn
+}
diff --git a/media-gfx/exiv2/exiv2-0.18.1.ebuild b/media-gfx/exiv2/exiv2-0.18.1.ebuild
index 00fe7934f53b..4565b426a932 100644
--- a/media-gfx/exiv2/exiv2-0.18.1.ebuild
+++ b/media-gfx/exiv2/exiv2-0.18.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.18.1.ebuild,v 1.2 2009/05/26 05:17:49 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.18.1.ebuild,v 1.3 2009/06/11 12:43:29 scarabeus Exp $
inherit eutils multilib toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="http://www.exiv2.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc nls zlib xmp examples unicode contrib"
+IUSE="doc nls zlib xmp examples unicode"
IUSE_LINGUAS="de es fi fr pl ru sk"
IUSE="${IUSE} $(printf 'linguas_%s ' ${IUSE_LINGUAS})"
@@ -27,8 +27,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
media-gfx/graphviz
)
- nls? ( sys-devel/gettext )
- contrib? ( >=dev-libs/boost-1.37 )"
+ nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
@@ -45,14 +44,6 @@ src_unpack() {
echo ">>> Updating doxygen config"
doxygen 2>&1 >/dev/null -u config/Doxyfile
fi
-
- if use contrib; then
- # create build environment for contrib
- ln -snf ../../src contrib/organize/exiv2
- sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
- -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
- contrib/organize/boost.mk
- fi
}
src_compile() {
@@ -67,13 +58,6 @@ src_compile() {
econf ${myconf} || die "econf failed"
emake || die "emake failed"
- if use contrib; then
- emake -C contrib/organize \
- LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
- || die "emake organize failed"
- fi
-
if use doc; then
emake doc || die "emake doc failed"
fi
@@ -82,10 +66,6 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- if use contrib; then
- emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
- fi
-
dodoc README doc/{ChangeLog,cmd.txt}
use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
use doc && dohtml -r doc/html/.