summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-09-18 23:17:26 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-09-18 23:17:26 +0000
commitea092ec0e9ed6a1793312bf59ca12707c30b4c23 (patch)
treebac91bfa7a9328c53f3ac23cd5cb7bfccbad2bbc /media-gfx/autotrace
parentamd64 stable, bug #284997 (diff)
downloadgentoo-2-ea092ec0e9ed6a1793312bf59ca12707c30b4c23.tar.gz
gentoo-2-ea092ec0e9ed6a1793312bf59ca12707c30b4c23.tar.bz2
gentoo-2-ea092ec0e9ed6a1793312bf59ca12707c30b4c23.zip
Fix broken pkgconfig file, bug #283534 by Dominique Michel. Patch from
Alexandre Rostovtsev. (Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/autotrace')
-rw-r--r--media-gfx/autotrace/ChangeLog9
-rw-r--r--media-gfx/autotrace/autotrace-0.31.1-r4.ebuild51
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch13
3 files changed, 72 insertions, 1 deletions
diff --git a/media-gfx/autotrace/ChangeLog b/media-gfx/autotrace/ChangeLog
index 18d7d8587308..4cff1c5d9f5d 100644
--- a/media-gfx/autotrace/ChangeLog
+++ b/media-gfx/autotrace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/autotrace
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/autotrace/ChangeLog,v 1.32 2009/09/06 23:47:16 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/autotrace/ChangeLog,v 1.33 2009/09/18 23:17:26 dirtyepic Exp $
+
+*autotrace-0.31.1-r4 (18 Sep 2009)
+
+ 18 Sep 2009; Ryan Hill <dirtyepic@gentoo.org> +autotrace-0.31.1-r4.ebuild,
+ +files/autotrace-0.31.1-pkgconfig.patch:
+ Fix broken pkgconfig file, bug #283534 by Dominique Michel. Patch from
+ Alexandre Rostovtsev.
06 Sep 2009; Brent Baude <ranger@gentoo.org> autotrace-0.31.1-r3.ebuild:
Marking autotrace-0.31.1-r3 ~ppc64 for bug 281573
diff --git a/media-gfx/autotrace/autotrace-0.31.1-r4.ebuild b/media-gfx/autotrace/autotrace-0.31.1-r4.ebuild
new file mode 100644
index 000000000000..d480f01bc52e
--- /dev/null
+++ b/media-gfx/autotrace/autotrace-0.31.1-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/autotrace/autotrace-0.31.1-r4.ebuild,v 1.1 2009/09/18 23:17:26 dirtyepic Exp $
+
+EAPI=1
+
+inherit eutils autotools
+
+DESCRIPTION="Converts Bitmaps to vector-graphics"
+SRC_URI="mirror://sourceforge/autotrace/${P}.tar.gz
+ mirror://debian/pool/main/a/autotrace/autotrace_0.31.1-13.diff.gz"
+
+HOMEPAGE="http://autotrace.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+imagemagick +pdf"
+
+RDEPEND="media-libs/libexif
+ >=media-libs/libpng-1.2.5-r4
+ >=media-libs/ming-0.3.0
+ pdf? ( >=media-gfx/pstoedit-3.45-r1 )
+ imagemagick? ( >=media-gfx/imagemagick-5.5.6-r1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/autotrace_0.31.1-13.diff
+ epatch "${FILESDIR}"/${P}-swf-output.patch
+ epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch # bug 283534
+ eautoreconf
+}
+
+src_compile() {
+ # Autotrace will autolink to ming if present. Forcing on.
+ econf \
+ --disable-dependency-tracking \
+ --with-ming \
+ $(use_with imagemagick magick) \
+ $(use_with pdf pstoedit) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch b/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch
new file mode 100644
index 000000000000..49619082253d
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.in b/configure.in
+index 564b32f..b396b26 100644
+--- a/configure.in
++++ b/configure.in
+@@ -223,7 +223,7 @@ if test "${swf_header_found}" = yes ; then
+ AC_CHECK_LIB(ming, Ming_init,
+ HAVE_LIBSWF=yes,,-lm)
+ if test "$HAVE_LIBSWF" = "yes" ; then
+- PKGCONFIG_REQS="$PKGCONFIG_REQS, ming"
++ PKGCONFIG_REQS="$PKGCONFIG_REQS, libming"
+ LIBSWF_LDFLAGS="-lming -lm"
+ AC_SUBST(LIBSWF_LDFLAGS)
+ AC_DEFINE(HAVE_LIBSWF)