summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-21 04:30:17 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-21 04:30:17 +0000
commitc41a95432f61c0d326e97d9137de4bdebfd8112d (patch)
tree934316861cb372a730d8d5a06850fb56bd41ed1c /mail-filter
parentadded prefix keywords (diff)
downloadgentoo-2-c41a95432f61c0d326e97d9137de4bdebfd8112d.tar.gz
gentoo-2-c41a95432f61c0d326e97d9137de4bdebfd8112d.tar.bz2
gentoo-2-c41a95432f61c0d326e97d9137de4bdebfd8112d.zip
added prefix keywords
(Portage version: 2.2.0_alpha121/cvs/Linux i686)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamassassin/ChangeLog7
-rw-r--r--mail-filter/spamassassin/spamassassin-3.3.2-r1.ebuild24
2 files changed, 17 insertions, 14 deletions
diff --git a/mail-filter/spamassassin/ChangeLog b/mail-filter/spamassassin/ChangeLog
index 2e6836a5cfc0..9ea98d135331 100644
--- a/mail-filter/spamassassin/ChangeLog
+++ b/mail-filter/spamassassin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-filter/spamassassin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/ChangeLog,v 1.213 2012/06/17 15:22:20 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/ChangeLog,v 1.214 2012/08/21 04:30:17 ottxor Exp $
+
+ 21 Aug 2012; Christoph Junghans <ottxor@gentoo.org>
+ spamassassin-3.3.2-r1.ebuild:
+ added prefix keywords
17 Jun 2012; Torsten Veller <tove@gentoo.org>
-files/spamassassin-3.3.1-PERL-5-12.patch,
@@ -1196,4 +1200,3 @@
24 Feb 2002; Bruce A. Locke <blocke@shivan.org> spamassassin-2.01.ebuild :
Ebuild contributed by Marc Soda <marc@aspre.net>
-
diff --git a/mail-filter/spamassassin/spamassassin-3.3.2-r1.ebuild b/mail-filter/spamassassin/spamassassin-3.3.2-r1.ebuild
index 03d4f3406628..8b087a3d9750 100644
--- a/mail-filter/spamassassin/spamassassin-3.3.2-r1.ebuild
+++ b/mail-filter/spamassassin/spamassassin-3.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/spamassassin-3.3.2-r1.ebuild,v 1.9 2012/06/17 14:46:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/spamassassin-3.3.2-r1.ebuild,v 1.10 2012/08/21 04:30:17 ottxor Exp $
EAPI=4
@@ -14,7 +14,7 @@ SRC_URI="mirror://apache/spamassassin/source/${MY_P}.tar.bz2"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
# need keyword request for Mail-SPF ppc ppc64
IUSE="berkdb qmail ssl doc ldap mysql postgres sqlite ipv6"
@@ -77,7 +77,7 @@ src_prepare() {
src_configure() {
# - Set SYSCONFDIR explicitly so we can't get bitten by bug 48205 again
# (just to be sure, nobody knows how it could happen in the first place).
- myconf="SYSCONFDIR=/etc DATADIR=/usr/share/spamassassin"
+ myconf="SYSCONFDIR=${EPREFIX}/etc DATADIR=${EPREFIX}/usr/share/spamassassin"
# If ssl is enabled, spamc can be built with ssl support
if use ssl; then
@@ -90,7 +90,7 @@ src_configure() {
# create the initial sharpbang line in the scripts and might cause
# a versioned app name end in there, see
# <http://bugs.gentoo.org/show_bug.cgi?id=62276>
- myconf+=" PERL_BIN=/usr/bin/perl"
+ myconf+=" PERL_BIN=${EPREFIX}/usr/bin/perl"
# Add Gentoo tag to make it easy for the upstream devs to spot
# possible modifications or patches.
@@ -127,35 +127,35 @@ src_install () {
# Move spamd to sbin where it belongs.
dodir /usr/sbin
- mv "${D}"/usr/bin/spamd "${D}"/usr/sbin/spamd || die "move spamd failed"
+ mv "${ED}"/usr/bin/spamd "${ED}"/usr/sbin/spamd || die "move spamd failed"
if use qmail; then
dobin spamc/qmail-spamc
fi
- ln -s mail/spamassassin "${D}"/etc/spamassassin || die
+ ln -s mail/spamassassin "${ED}"/etc/spamassassin || die
# Disable plugin by default
- sed -i -e 's/^loadplugin/\#loadplugin/g' "${D}"/etc/mail/spamassassin/init.pre || die
+ sed -i -e 's/^loadplugin/\#loadplugin/g' "${ED}"/etc/mail/spamassassin/init.pre || die
# Add the init and config scripts.
newinitd "${FILESDIR}"/3.3.1-spamd.init spamd
newconfd "${FILESDIR}"/3.0.0-spamd.conf spamd
if use postgres; then
- sed -i -e 's:@USEPOSTGRES@::' "${D}/etc/init.d/spamd"
+ sed -i -e 's:@USEPOSTGRES@::' "${ED}/etc/init.d/spamd"
dodoc sql/*_pg.sql
else
- sed -i -e '/@USEPOSTGRES@/d' "${D}/etc/init.d/spamd"
+ sed -i -e '/@USEPOSTGRES@/d' "${ED}/etc/init.d/spamd"
fi
if use mysql; then
- sed -i -e 's:@USEMYSQL@::' "${D}/etc/init.d/spamd"
+ sed -i -e 's:@USEMYSQL@::' "${ED}/etc/init.d/spamd"
dodoc sql/*_mysql.sql
else
- sed -i -e '/@USEMYSQL@/d' "${D}/etc/init.d/spamd"
+ sed -i -e '/@USEMYSQL@/d' "${ED}/etc/init.d/spamd"
fi
dodoc NOTICE TRADEMARK CREDITS INSTALL.VMS UPGRADE USAGE \
@@ -172,7 +172,7 @@ src_install () {
dodoc spamc/README.qmail
fi
- cp "${FILESDIR}"/secrets.cf "${D}"/etc/mail/spamassassin/secrets.cf.example || die
+ cp "${FILESDIR}"/secrets.cf "${ED}"/etc/mail/spamassassin/secrets.cf.example || die
fperms 0400 /etc/mail/spamassassin/secrets.cf.example
cat <<-EOF > "${T}/local.cf.example"