summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-07-06 01:46:06 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-07-06 01:46:06 +0000
commitf214bc2a0843132abcc794c06771640405476816 (patch)
tree97ccd1e5800c608afc0c4b5ba808660cb9f204b9 /mail-client
parentThe ghc-bin ebuild will not be continued. Its function has been merged into t... (diff)
downloadgentoo-2-f214bc2a0843132abcc794c06771640405476816.tar.gz
gentoo-2-f214bc2a0843132abcc794c06771640405476816.tar.bz2
gentoo-2-f214bc2a0843132abcc794c06771640405476816.zip
Fix timezone offsets on fbsd. bug #183708
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/evolution/ChangeLog6
-rw-r--r--mail-client/evolution/evolution-2.10.2.ebuild5
-rw-r--r--mail-client/evolution/files/evolution-2.10.2-fbsd.patch35
3 files changed, 44 insertions, 2 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index e6a55f905408..392fec51ed11 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/evolution
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.181 2007/06/27 07:36:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.182 2007/07/06 01:46:06 dang Exp $
+
+ 06 Jul 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/evolution-2.10.2-fbsd.patch, evolution-2.10.2.ebuild:
+ Fix timezone offsets on fbsd. bug #183708
*evolution-2.10.2 (27 Jun 2007)
diff --git a/mail-client/evolution/evolution-2.10.2.ebuild b/mail-client/evolution/evolution-2.10.2.ebuild
index 0770a36bc9d4..6690cc3f3952 100644
--- a/mail-client/evolution/evolution-2.10.2.ebuild
+++ b/mail-client/evolution/evolution-2.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.10.2.ebuild,v 1.1 2007/06/27 07:36:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.10.2.ebuild,v 1.2 2007/07/06 01:46:06 dang Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="1.9"
@@ -170,6 +170,9 @@ src_unpack() {
# certificate filtering for clueless users (and even for those who know)
epatch ${FILESDIR}/${PN}-2.8.2.1-certificate-manager-filtering.patch
+ # Fix timezone offsets on fbsd. bug #183708
+ epatch "${FILESDIR}"/${P}-fbsd.patch
+
eautoreconf
}
diff --git a/mail-client/evolution/files/evolution-2.10.2-fbsd.patch b/mail-client/evolution/files/evolution-2.10.2-fbsd.patch
new file mode 100644
index 000000000000..c7a35e57eb1b
--- /dev/null
+++ b/mail-client/evolution/files/evolution-2.10.2-fbsd.patch
@@ -0,0 +1,35 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN evolution-2.10.2.orig/widgets/e-timezone-dialog/e-timezone-dialog.c evolution-2.10.2/widgets/e-timezone-dialog/e-timezone-dialog.c
+--- evolution-2.10.2.orig/widgets/e-timezone-dialog/e-timezone-dialog.c 2007-04-09 09:10:21.000000000 -0400
++++ evolution-2.10.2/widgets/e-timezone-dialog/e-timezone-dialog.c 2007-07-05 21:24:05.000000000 -0400
+@@ -80,7 +80,9 @@ struct _ETimezoneDialogPrivate {
+
+ #ifndef G_OS_WIN32 /* Declared properly in time.h already */
+ extern char *tzname[2];
++#ifndef __BSD_VISIBLE
+ extern long timezone;
++#endif
+ extern int daylight;
+ #endif
+
+@@ -322,9 +324,20 @@ static const icaltimezone*
+ get_local_timezone()
+ {
+ icaltimezone *zone;
++ long offset;
++#ifdef __BSD_VISIBLE
++ time_t tt;
++ struct tm tm;
++#endif
+
+ tzset();
+- zone = icaltimezone_get_builtin_timezone_from_offset (-timezone, tzname[0]);
++#ifdef __BSD_VISIBLE
++ localtime_r (&tt, &tm);
++ offset = tm.tm_gmtoff;
++#else
++ offset = -timezone;
++#endif
++ zone = icaltimezone_get_builtin_timezone_from_offset (offset, tzname[0]);
+
+ return zone;
+ }