summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-07-26 18:19:49 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-07-26 18:19:49 +0000
commitc93c0bfb96b03a82c83b3686d4cdf9c0ade2eb47 (patch)
tree56875da9d6df942198d4fa38ad75ff8414263bab /mail-client
parentThree months into the stabilization process and after attempting to get the m... (diff)
downloadgentoo-2-c93c0bfb96b03a82c83b3686d4cdf9c0ade2eb47.tar.gz
gentoo-2-c93c0bfb96b03a82c83b3686d4cdf9c0ade2eb47.tar.bz2
gentoo-2-c93c0bfb96b03a82c83b3686d4cdf9c0ade2eb47.zip
Version bump and EAPI bump. Because of configobj it can be installed only
with python2_7 target. (Portage version: 2.1.13/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/ChangeLog9
-rw-r--r--mail-client/alot/alot-0.3.5.ebuild89
-rw-r--r--mail-client/alot/files/0.3.5-0001-Use-Unicode-strings-when-dealing-with-.patch78
3 files changed, 175 insertions, 1 deletions
diff --git a/mail-client/alot/ChangeLog b/mail-client/alot/ChangeLog
index 53d2ea26ebeb..1975a0de35fe 100644
--- a/mail-client/alot/ChangeLog
+++ b/mail-client/alot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/alot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.16 2013/04/18 13:15:13 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/ChangeLog,v 1.17 2013/07/26 18:19:49 aidecoe Exp $
+
+*alot-0.3.5 (26 Jul 2013)
+
+ 26 Jul 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> +alot-0.3.5.ebuild,
+ +files/0.3.5-0001-Use-Unicode-strings-when-dealing-with-.patch:
+ Version bump and EAPI bump. Because of configobj it can be installed only
+ with python2_7 target.
*alot-0.3.4 (18 Apr 2013)
diff --git a/mail-client/alot/alot-0.3.5.ebuild b/mail-client/alot/alot-0.3.5.ebuild
new file mode 100644
index 000000000000..18b4618aa99b
--- /dev/null
+++ b/mail-client/alot/alot-0.3.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/alot/alot-0.3.5.ebuild,v 1.1 2013/07/26 18:19:49 aidecoe Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils vcs-snapshot
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="${HOMEPAGE}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ >=dev-python/configobj-4.6.0[${PYTHON_USEDEP}]
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ >=dev-python/twisted-10.2.0
+ >=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ >=net-mail/notmuch-0.13[crypt,python]
+ sys-apps/file[python]
+ "
+
+ALOT_UPDATE=""
+
+pkg_setup() {
+ python-r1_pkg_setup
+
+ if has_version "<${CATEGORY}/${PN}-0.3.2"; then
+ ALOT_UPDATE="yes"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-0001-Use-Unicode-strings-when-dealing-with-.patch"
+
+ find "${S}" -name '*.py' -print0 | xargs -0 -- sed \
+ -e '1i# -*- coding: utf-8 -*-' -i || die
+
+ distutils-r1_src_prepare
+
+ local md
+ for md in *.md; do
+ mv "${md}" "${md%.md}"
+ done
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc; then
+ pushd docs || die
+ emake html
+ popd || die
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ dodir /usr/share/alot
+ insinto /usr/share/alot
+ doins -r extra
+
+ if use doc; then
+ dohtml -r docs/build/html/*
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ALOT_UPDATE} = yes ]]; then
+ ewarn "The syntax of theme-files and custom tags-sections of the config"
+ ewarn "has been changed. You have to revise your config. There are"
+ ewarn "converter scripts in /usr/share/alot/extra to help you out with"
+ ewarn "this:"
+ ewarn ""
+ ewarn " * tagsections_convert.py for your ~/.config/alot/config"
+ ewarn " * theme_convert.py to update your custom theme files"
+ fi
+}
diff --git a/mail-client/alot/files/0.3.5-0001-Use-Unicode-strings-when-dealing-with-.patch b/mail-client/alot/files/0.3.5-0001-Use-Unicode-strings-when-dealing-with-.patch
new file mode 100644
index 000000000000..c7809fa82615
--- /dev/null
+++ b/mail-client/alot/files/0.3.5-0001-Use-Unicode-strings-when-dealing-with-.patch
@@ -0,0 +1,78 @@
+From 119e15cae5367d86e3754a337558eb98a420f46a Mon Sep 17 00:00:00 2001
+From: Simon Chopin <chopin.simon@gmail.com>
+Date: Wed, 24 Jul 2013 15:13:20 +0200
+Subject: [PATCH] Use Unicode strings when dealing with GPG
+
+This delays the encoding of special chars, if any, to the actual display
+which is supposed to know into what it should be encoded.
+---
+ alot/db/utils.py | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/alot/db/utils.py b/alot/db/utils.py
+index ba6d466..7fb2deb 100644
+--- a/alot/db/utils.py
++++ b/alot/db/utils.py
+@@ -51,9 +51,9 @@ def add_signature_headers(mail, sigs, error_msg):
+ )
+ mail.add_header(
+ X_SIGNATURE_MESSAGE_HEADER,
+- 'Invalid: {0}'.format(error_msg)
++ u'Invalid: {0}'.format(error_msg)
+ if error_msg else
+- 'Valid: {0}'.format(sig_from),
++ u'Valid: {0}'.format(sig_from),
+ )
+
+
+@@ -104,19 +104,19 @@ def message_from_file(handle):
+
+ malformed = False
+ if len(m.get_payload()) != 2:
+- malformed = 'expected exactly two messages, got {0}'.format(
++ malformed = u'expected exactly two messages, got {0}'.format(
+ len(m.get_payload()))
+
+ ct = m.get_payload(1).get_content_type()
+ if ct != app_pgp_sig:
+- malformed = 'expected Content-Type: {0}, got: {1}'.format(
++ malformed = u'expected Content-Type: {0}, got: {1}'.format(
+ app_pgp_sig, ct)
+
+ # TODO: RFC 3156 says the alg has to be lower case, but I've
+ # seen a message with 'PGP-'. maybe we should be more
+ # permissive here, or maybe not, this is crypto stuff...
+ if not p.get('micalg', 'nothing').startswith('pgp-'):
+- malformed = 'expected micalg=pgp-..., got: {0}'.format(
++ malformed = u'expected micalg=pgp-..., got: {0}'.format(
+ p.get('micalg', 'nothing'))
+
+ sigs = []
+@@ -144,13 +144,13 @@ def message_from_file(handle):
+
+ ct = m.get_payload(0).get_content_type()
+ if ct != app_pgp_enc:
+- malformed = 'expected Content-Type: {0}, got: {1}'.format(
++ malformed = u'expected Content-Type: {0}, got: {1}'.format(
+ app_pgp_enc, ct)
+
+ want = 'application/octet-stream'
+ ct = m.get_payload(1).get_content_type()
+ if ct != want:
+- malformed = 'expected Content-Type: {0}, got: {1}'.format(want, ct)
++ malformed = u'expected Content-Type: {0}, got: {1}'.format(want, ct)
+
+ if not malformed:
+ try:
+@@ -199,7 +199,7 @@ def message_from_file(handle):
+ add_signature_headers(m, sigs, '')
+
+ if malformed:
+- msg = 'Malformed OpenPGP message: {0}'.format(malformed)
++ msg = u'Malformed OpenPGP message: {0}'.format(malformed)
+ m.attach(email.message_from_string(msg))
+
+ return m
+--
+1.8.3.2
+