summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2005-08-13 03:23:05 +0000
committerMarius Mauch <genone@gentoo.org>2005-08-13 03:23:05 +0000
commit0c01cfacdcef5dd41854132f0bc976446918d995 (patch)
treef095a11e924cb33febde85921b19ffcf36d207c2 /mail-client
parentkeyworded ~amd64 (diff)
downloadgentoo-2-0c01cfacdcef5dd41854132f0bc976446918d995.tar.gz
gentoo-2-0c01cfacdcef5dd41854132f0bc976446918d995.tar.bz2
gentoo-2-0c01cfacdcef5dd41854132f0bc976446918d995.zip
new gtk2 version, candidate for unmasking
(Portage version: 1.589-cvs)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed-claws/ChangeLog11
-rw-r--r--mail-client/sylpheed-claws/files/digest-sylpheed-claws-1.9.131
-rw-r--r--mail-client/sylpheed-claws/sylpheed-claws-1.9.13.ebuild135
3 files changed, 146 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws/ChangeLog b/mail-client/sylpheed-claws/ChangeLog
index 95d86e7ea4f0..e3399cc4623e 100644
--- a/mail-client/sylpheed-claws/ChangeLog
+++ b/mail-client/sylpheed-claws/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-client/sylpheed-claws
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/ChangeLog,v 1.54 2005/07/31 16:31:27 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/ChangeLog,v 1.55 2005/08/13 03:23:05 genone Exp $
+
+*sylpheed-claws-1.9.13 (13 Aug 2005)
+
+ 13 Aug 2005; Marius Mauch <genone@gentoo.org>
+ +sylpheed-claws-1.9.13.ebuild:
+ New gtk2 version, now uses libetpan for imap, gpgme-0.4 or higher for gpg
+ support and optionally uses gnomeprint. Also the spamassassin plugin is now
+ optional and the pgpinline plugin is included now (and therefore this
+ version blocks the pgpinline package). This is a candidate for unmasking.
31 Jul 2005; Tobias Scherbaum <dertobi123@gentoo.org>
sylpheed-claws-1.0.4a.ebuild:
diff --git a/mail-client/sylpheed-claws/files/digest-sylpheed-claws-1.9.13 b/mail-client/sylpheed-claws/files/digest-sylpheed-claws-1.9.13
new file mode 100644
index 000000000000..fb38af93ab91
--- /dev/null
+++ b/mail-client/sylpheed-claws/files/digest-sylpheed-claws-1.9.13
@@ -0,0 +1 @@
+MD5 afd3b82ca210520f0ad241b77c5e673a sylpheed-claws-1.9.13.tar.bz2 3432284
diff --git a/mail-client/sylpheed-claws/sylpheed-claws-1.9.13.ebuild b/mail-client/sylpheed-claws/sylpheed-claws-1.9.13.ebuild
new file mode 100644
index 000000000000..0a138c7f16b0
--- /dev/null
+++ b/mail-client/sylpheed-claws/sylpheed-claws-1.9.13.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/sylpheed-claws-1.9.13.ebuild,v 1.1 2005/08/13 03:23:05 genone Exp $
+
+IUSE="nls gnome dillo crypt spell imlib ssl ldap ipv6 pda clamav xface kde imap spamassassin"
+
+inherit eutils
+
+DESCRIPTION="Bleeding edge version of Sylpheed"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+
+if [ -n "${P/*_rc*/}" ]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+else
+ MY_P="${P/_/-}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="http://claws.sylpheed.org/snapshots/${MY_P}.tar.bz2"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.4
+ pda? ( >=app-pda/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.7 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.4 )
+ dillo? ( www-client/dillo )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( virtual/aspell-dict )
+ nls? ( >=sys-devel/gettext-0.12 )
+ kde? ( kde-base/kdelibs )
+ imap? ( >=net-libs/libetpan-0.38 )
+ gnome? ( >=gnome-base/libgnomeprintui-2.2 )
+ x11-libs/startup-notification
+ !mail-client/sylpheed-claws-pgpinline" # included in the main package now
+
+DEPEND="${COMMONDEPEND}
+ >=media-libs/compface-1.4
+ >=sys-apps/sed-4"
+
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ net-mail/metamail
+ x11-misc/shared-mime-info"
+
+PROVIDE="virtual/sylpheed"
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} `use_enable gnome gdk-pixbuf`"
+ myconf="${myconf} `use_enable imlib`"
+ myconf="${myconf} `use_enable spell aspell`"
+ myconf="${myconf} `use_enable ldap`"
+ myconf="${myconf} `use_enable ssl openssl`"
+ myconf="${myconf} `use_enable crypt gpgme`"
+ myconf="${myconf} `use_enable ipv6`"
+ myconf="${myconf} `use_enable pda jpilot`"
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+ myconf="${myconf} `use_enable clamav clamav-plugin`"
+ myconf="${myconf} `use_enable crypt pgpmime-plugin`"
+ myconf="${myconf} `use_enable crypt pgpmime-inline`"
+ myconf="${myconf} `use_enable xface compface`"
+ myconf="${myconf} `use_enable imap libetpan`"
+ myconf="${myconf} `use_enable gnome gnomeprint`"
+ myconf="${myconf} `use_enable spamassassin spamassassin-plugin`"
+
+ econf \
+ --program-suffix=-claws \
+ --with-config-dir=.sylpheed-claws \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+
+ # build the extra tools
+ cd ${S}/tools
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ local menuentry="/usr/share/applications/sylpheed-claws.desktop"
+ insinto /usr/share/applications
+ newins ${S}/sylpheed.desktop sylpheed-claws.desktop
+ dosed "s/Sylpheed/Sylpheed Claws/" ${menuentry}
+ dosed "s/sylpheed/sylpheed-claws/" ${menuentry}
+ rm -rf ${D}/usr/share/gnome
+
+ insinto /usr/share/pixmaps
+ newins ${S}/sylpheed.png sylpheed-claws.png
+ rm -f ${D}/usr/share/pixmaps/sylpheed.png
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+ docinto tools
+ dodoc tools/README*
+
+ # install the extra tools
+ cd ${S}/tools
+ exeinto /usr/lib/${PN}/tools
+ doexe *.pl *.py *.rc *.conf *.sh
+ doexe tb2sylpheed update-po uudec gpg-sign-syl
+
+ if use kde; then
+ local kdeprefix="$(kde-config --prefix)"
+ local servicescript="sylpheed-kdeservicemenu.pl"
+ cd ${S}/tools/kdeservicemenu
+ for f in sylpheed-attach-files.desktop sylpheed-compress-attach.desktop; do
+ sed -e "s:SCRIPT_PATH:${kdeprefix}/bin/${servicescript}:g" template_$f > $f
+ install -m 0644 $f ${D}/${kdeprefix}/share/apps/konqueror/servicemenus/$f
+ done
+ insinto ${kdeprefix}/bin
+ doexe ${servicescript}
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "External plugins need specially adjusted versions, see the "
+ ewarn "relevant package.mask entry for the available gtk2 versions."
+ ewarn "Some plugins may not have a gtk2 version available."
+ echo
+ einfo "For safety reasons this version will use the alternate configuration"
+ einfo "directory ~/.sylpheed-claws instead of ~/.sylpheed, so you have to"
+ einfo "copy your configuration manually or create a new one."
+ ewarn
+ ewarn "You have to re-emerge or update all external plugins"
+ ewarn
+ epause 5
+ ebeep 3
+}