summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-14 12:06:04 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-14 12:06:04 +0000
commitee8bcf7c0c323336eddb303b69e108007ee0e11a (patch)
treefc56f97986e7819403cbb1ced30456d3a33e169c /mail-client/balsa
parentFix the name of the package, it's sys-libs/db not dev-libs/db, the error mess... (diff)
downloadgentoo-2-ee8bcf7c0c323336eddb303b69e108007ee0e11a.tar.gz
gentoo-2-ee8bcf7c0c323336eddb303b69e108007ee0e11a.tar.bz2
gentoo-2-ee8bcf7c0c323336eddb303b69e108007ee0e11a.zip
bump to 2.3.25. Gtksourceview 2 support, better IMAP support, GMail compatibility, lots of bug fixes. Fixes bug #230614.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'mail-client/balsa')
-rw-r--r--mail-client/balsa/ChangeLog8
-rw-r--r--mail-client/balsa/balsa-2.3.25.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/mail-client/balsa/ChangeLog b/mail-client/balsa/ChangeLog
index 3b726d6076e2..d90b30feec50 100644
--- a/mail-client/balsa/ChangeLog
+++ b/mail-client/balsa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/balsa
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.64 2008/05/24 11:26:39 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.65 2008/07/14 12:06:04 eva Exp $
+
+*balsa-2.3.25 (14 Jul 2008)
+
+ 14 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org> +balsa-2.3.25.ebuild:
+ bump to 2.3.25. Gtksourceview 2 support, better IMAP support, GMail
+ compatibility, lots of bug fixes. Fixes bug #230614.
24 May 2008; Gilles Dartiguelongue <eva@gentoo.org> -balsa-2.3.20.ebuild:
remove old revisions, bug #221619.
diff --git a/mail-client/balsa/balsa-2.3.25.ebuild b/mail-client/balsa/balsa-2.3.25.ebuild
new file mode 100644
index 000000000000..f4d7e4560a58
--- /dev/null
+++ b/mail-client/balsa/balsa-2.3.25.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.3.25.ebuild,v 1.1 2008/07/14 12:06:04 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="Email client for GNOME"
+HOMEPAGE="http://balsa.gnome.org"
+SRC_URI="http://balsa.gnome.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+# Doesn't currently build with -gnome
+IUSE="crypt doc gtkhtml gtkspell kerberos ldap libnotify rubrica sqlite ssl xface"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/gmime-2.1.9
+ >=net-libs/libesmtp-1.0.3
+ >=gnome-base/orbit-2
+ >=gnome-base/libbonobo-2.0
+ x11-themes/hicolor-icon-theme
+ net-mail/mailbase
+ crypt? ( >=app-crypt/gpgme-1.0 )
+ >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/gnome-vfs-2.0
+ >=x11-libs/gtksourceview-2
+ gtkhtml? ( >=gnome-extra/gtkhtml-3.14 )
+ sqlite? ( >=dev-db/sqlite-2.8 )
+ libnotify? ( x11-libs/libnotify )
+ gtkspell? ( =app-text/gtkspell-2* )
+ !gtkspell? ( virtual/aspell-dict )
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ rubrica? ( dev-libs/libxml2 )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.5.1 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=app-text/scrollkeeper-0.1.4
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO docs/*"
+
+pkg_setup() {
+ # threads are currently broken with gpgme
+ G2CONF="${G2CONF} --disable-threads"
+
+ if use crypt ; then
+ G2CONF="${G2CONF} --with-gpgme=gpgme-config"
+ else
+ G2CONF="${G2CONF} --without-gpgme"
+ fi
+
+# if use gnome ; then
+ G2CONF="${G2CONF} --with-gtksourceview"
+# else
+# G2CONF="${G2CONF} --without-gtksourceview"
+# fi
+
+ if use gtkhtml ; then
+ G2CONF="${G2CONF} --with-gtkhtml=3"
+ else
+ G2CONF="${G2CONF} --without-gtkhtml"
+ fi
+
+ G2CONF="${G2CONF}
+ --disable-pcre
+ --enable-gregex
+ --enable-threads
+ $(use_with gtkspell)
+ $(use_with kerberos gss)
+ $(use_with ldap)
+ $(use_with libnotify)
+ $(use_with rubrica)
+ $(use_with sqlite)
+ $(use_with ssl)
+ $(use_with xface compface)"
+}