summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-03-29 01:18:21 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-03-29 01:18:21 +0000
commit839bb28d7531efa1e80b106be8d2a6aca22562f1 (patch)
tree9bed4f83532464a4a15ea244726360b4142c7489 /kde-misc
parentLICENSE for kolourpaint4 is BSD and LGPL-2. (diff)
downloadgentoo-2-839bb28d7531efa1e80b106be8d2a6aca22562f1.tar.gz
gentoo-2-839bb28d7531efa1e80b106be8d2a6aca22562f1.tar.bz2
gentoo-2-839bb28d7531efa1e80b106be8d2a6aca22562f1.zip
Version bump to 0.27 as per bug 213311.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tork/ChangeLog8
-rw-r--r--kde-misc/tork/files/tork-0.27-ext_tsocks.patch24
-rw-r--r--kde-misc/tork/tork-0.27.ebuild48
3 files changed, 79 insertions, 1 deletions
diff --git a/kde-misc/tork/ChangeLog b/kde-misc/tork/ChangeLog
index 208843d1fe0a..e6b407ee0ea7 100644
--- a/kde-misc/tork/ChangeLog
+++ b/kde-misc/tork/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/tork
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.27 2008/02/18 22:56:39 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.28 2008/03/29 01:18:20 philantrop Exp $
+
+*tork-0.27 (29 Mar 2008)
+
+ 29 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/tork-0.27-ext_tsocks.patch, +tork-0.27.ebuild:
+ Version bump to 0.27 as per bug 213311.
18 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> tork-0.23.ebuild,
tork-0.26.ebuild:
diff --git a/kde-misc/tork/files/tork-0.27-ext_tsocks.patch b/kde-misc/tork/files/tork-0.27-ext_tsocks.patch
new file mode 100644
index 000000000000..b36a910c2b3e
--- /dev/null
+++ b/kde-misc/tork/files/tork-0.27-ext_tsocks.patch
@@ -0,0 +1,24 @@
+diff -Naur tork-0.27.orig/src/Makefile.am tork-0.27/src/Makefile.am
+--- tork-0.27.orig/src/Makefile.am 2008-02-12 22:16:15.000000000 +0100
++++ tork-0.27/src/Makefile.am 2008-03-29 01:45:24.000000000 +0100
+@@ -12,9 +12,9 @@
+ geoipdir=GeoIP-1.4.0
+ endif
+
+-tsocks=tsocks
++tsocks=-ltsocks
+
+-SUBDIRS=icons arkollon $(geoipdir) $(tsocks) privoxytemplates \
++SUBDIRS=icons arkollon $(geoipdir) privoxytemplates \
+ torkapplet konqplugin tor_ioslave menu upnp .
+
+ DISTCLEANFILES=dcoptork.kidl
+@@ -30,7 +30,7 @@
+
+ # the libraries to link against.
+ tork_LDADD = $(LIB_KIO) $(LIB_KFILE) $(LIB_KHTML) $(geoiplib) \
+- upnp/libktupnp.la $(LIBGNUTLS_LIBS)
++ $(tsocks) upnp/libktupnp.la $(LIBGNUTLS_LIBS)
+
+ # which sources should be compiled for tork
+ tork_SOURCES = upnpmanager.cpp trayicon.cpp trayhoverpopup.cpp chart.cpp configdialog.cpp \
diff --git a/kde-misc/tork/tork-0.27.ebuild b/kde-misc/tork/tork-0.27.ebuild
new file mode 100644
index 000000000000..a20bfdbbaa24
--- /dev/null
+++ b/kde-misc/tork/tork-0.27.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/tork-0.27.ebuild,v 1.1 2008/03/29 01:18:20 philantrop Exp $
+
+inherit kde multilib
+
+DESCRIPTION="A Tor controller for the KDE desktop"
+HOMEPAGE="http://tork.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gnutls"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/geoip-1.4.0
+ gnutls? ( >=net-libs/gnutls-2.2.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9.8g )
+ || ( =kde-base/kdebase-3.5* =kde-base/libkonq-3.5* )"
+
+RDEPEND="${DEPEND}
+ >=net-misc/tor-0.1.2.14
+ >=net-proxy/privoxy-3.0.3-r5
+ >=net-proxy/tsocks-1.8_beta5-r2"
+
+need-kde 3.5
+
+PATCHES="${FILESDIR}/${P}-ext_tsocks.patch"
+
+src_compile() {
+ # Fix desktop file
+ sed -i -e "s:^\(Categories=.*\):\1;:" "${S}/src/tork.desktop"
+
+ local myconf="--with-external-geoip --with-conf=/etc/socks/tsocks.conf"
+ use gnutls && myconf="${myconf} --enable-gnutls"
+
+ kde_src_compile
+}
+
+pkg_postinst() {
+ if ! built_with_use --missing false net-proxy/tsocks tordns; then
+ ewarn "WARNING: you have net-proxy/tsocks installed without"
+ ewarn "the patch to avoid DNS leaking while using Tor."
+ ewarn "For better privacy, please emerge again net-proxy/tsocks"
+ ewarn "with the USE flag 'tordns' enabled."
+ fi
+}