summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-14 12:27:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-14 12:27:10 +0000
commit00b26dc8118f332193c06b50182b2f5007827aae (patch)
treec0f6b06a3604da6adf1c9a6cf4f8dc40cb7150a2 /kde-misc/tork
parentTypo, see bug #154504 (diff)
downloadgentoo-2-00b26dc8118f332193c06b50182b2f5007827aae.tar.gz
gentoo-2-00b26dc8118f332193c06b50182b2f5007827aae.tar.bz2
gentoo-2-00b26dc8118f332193c06b50182b2f5007827aae.zip
Version bump, add dependency over tsocks (that upstream ships and builds inline), and remove old versions.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'kde-misc/tork')
-rw-r--r--kde-misc/tork/ChangeLog11
-rw-r--r--kde-misc/tork/files/digest-tork-0.113
-rw-r--r--kde-misc/tork/files/tork-0.11-external-tsocks.patch40
-rw-r--r--kde-misc/tork/tork-0.11.ebuild38
4 files changed, 91 insertions, 1 deletions
diff --git a/kde-misc/tork/ChangeLog b/kde-misc/tork/ChangeLog
index 9283fa40c826..1fae80906687 100644
--- a/kde-misc/tork/ChangeLog
+++ b/kde-misc/tork/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for kde-misc/tork
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.10 2006/10/24 19:57:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.11 2006/11/14 12:27:10 flameeyes Exp $
+
+*tork-0.11 (14 Nov 2006)
+
+ 14 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/tork-0.08-crash.patch, -files/tork-0.08-geoip.patch,
+ +files/tork-0.11-external-tsocks.patch, -tork-0.08.ebuild,
+ -tork-0.09.ebuild, +tork-0.11.ebuild:
+ Version bump, add dependency over tsocks (that upstream ships and builds
+ inline), and remove old versions.
*tork-0.10 (24 Oct 2006)
diff --git a/kde-misc/tork/files/digest-tork-0.11 b/kde-misc/tork/files/digest-tork-0.11
new file mode 100644
index 000000000000..ebfa00863866
--- /dev/null
+++ b/kde-misc/tork/files/digest-tork-0.11
@@ -0,0 +1,3 @@
+MD5 21d1a3a3b18734211fce46991b24a882 tork-0.11.tar.bz2 1970291
+RMD160 991c50023826e2b0dd780a8806b9f02b8c5de3d0 tork-0.11.tar.bz2 1970291
+SHA256 7325494586577492a4b66eca01a646bfa70c86844ed9d04486abf4e84107086c tork-0.11.tar.bz2 1970291
diff --git a/kde-misc/tork/files/tork-0.11-external-tsocks.patch b/kde-misc/tork/files/tork-0.11-external-tsocks.patch
new file mode 100644
index 000000000000..30e60eec8553
--- /dev/null
+++ b/kde-misc/tork/files/tork-0.11-external-tsocks.patch
@@ -0,0 +1,40 @@
+Index: tork-0.11/configure.in.in
+===================================================================
+--- tork-0.11.orig/configure.in.in
++++ tork-0.11/configure.in.in
+@@ -251,7 +251,11 @@ AM_CONDITIONAL([EXTERNAL_GEOIP], [test "
+
+
+
++AC_ARG_WITH(external-tsocks,
++ AC_HELP_STRING([--with-external-tsocks], [Don't build the internal copy of TSocks]))
++AM_CONDITIONAL([EXTERNAL_TSOCKS], [test "x$with_external_tsocks" = "xyes"])
+
++if test "x$with_external_tsocks" != "xyes"; then
+
+ dnl Process this file with autoconf to produce a configure script.
+
+@@ -624,3 +628,5 @@ SPECIALLIBS=${LIBS}
+ AC_SUBST(SPECIALLIBS)
+ LIBS=${SIMPLELIBS}
+
++fi
++
+Index: tork-0.11/src/Makefile.am
+===================================================================
+--- tork-0.11.orig/src/Makefile.am
++++ tork-0.11/src/Makefile.am
+@@ -11,7 +11,12 @@ geoiplib=GeoIP-1.4.0/libGeoIP/libGeoIP.l
+ geoipdir=GeoIP-1.4.0
+ endif
+
+-SUBDIRS=icons about arkollon $(geoipdir) tsocks .
++if EXTERNAL_TSOCKS
++else
++tsocks=tsocks
++endif
++
++SUBDIRS=icons about arkollon $(geoipdir) $(tsocks) .
+
+ # set the include path for X, qt and KDE
+ INCLUDES = $(all_includes)
diff --git a/kde-misc/tork/tork-0.11.ebuild b/kde-misc/tork/tork-0.11.ebuild
new file mode 100644
index 000000000000..23cf4e800ec8
--- /dev/null
+++ b/kde-misc/tork/tork-0.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/tork-0.11.ebuild,v 1.1 2006/11/14 12:27:10 flameeyes Exp $
+
+inherit kde
+
+DESCRIPTION="A Tor controller for the KDE desktop"
+HOMEPAGE="http://tork.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/geoip-1.4.0"
+
+RDEPEND="net-misc/tor
+ >=net-proxy/privoxy-3.0.3-r5
+ net-proxy/tsocks
+ ${DEPEND}"
+
+need-kde 3.5
+
+PATCHES="${FILESDIR}/${P}-external-tsocks.patch"
+
+src_compile() {
+ rm -f "${S}/configure"
+
+ local myconf="--with-external-geoip --with-external-tsocks"
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ rm -rf "${D}/usr/share/applnk"
+}