summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:26:58 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:26:58 +0000
commitdbb512200578b7c90b8a7e74c0ab48389aa44928 (patch)
tree10164a38507500d540c7446da0488e35bf2ad504 /kde-misc/magneto-kde
parentversion bump (diff)
downloadgentoo-2-dbb512200578b7c90b8a7e74c0ab48389aa44928.tar.gz
gentoo-2-dbb512200578b7c90b8a7e74c0ab48389aa44928.tar.bz2
gentoo-2-dbb512200578b7c90b8a7e74c0ab48389aa44928.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'kde-misc/magneto-kde')
-rw-r--r--kde-misc/magneto-kde/ChangeLog9
-rw-r--r--kde-misc/magneto-kde/magneto-kde-183.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/kde-misc/magneto-kde/ChangeLog b/kde-misc/magneto-kde/ChangeLog
index 5f33642f399f..aa5b56888b41 100644
--- a/kde-misc/magneto-kde/ChangeLog
+++ b/kde-misc/magneto-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/magneto-kde
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.31 2012/09/27 11:04:36 lxnay Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.32 2013/03/14 18:26:58 lxnay Exp $
+
+*magneto-kde-183 (14 Mar 2013)
+
+ 14 Mar 2013; Fabio Erculiani <lxnay@gentoo.org> +magneto-kde-183.ebuild:
+ version bump
*magneto-kde-144 (27 Sep 2012)
diff --git a/kde-misc/magneto-kde/magneto-kde-183.ebuild b/kde-misc/magneto-kde/magneto-kde-183.ebuild
new file mode 100644
index 000000000000..edf8d8fb74bf
--- /dev/null
+++ b/kde-misc/magneto-kde/magneto-kde-183.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/magneto-kde-183.ebuild,v 1.1 2013/03/14 18:26:58 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager notification applet KDE frontend"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+RDEPEND="~app-misc/magneto-loader-${PV}
+ kde-base/pykde4
+ dev-python/PyQt4[dbus]"
+DEPEND=""
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-kde-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/magneto/magneto/kde"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/magneto/magneto/kde"
+}