summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-10-24 15:36:07 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-10-24 15:36:07 +0000
commit56fb7f6428e53f4984704d2cf9da07c1a107e8b6 (patch)
treec1d5d4c5f92e47cc5b638f5a48e1470a5c626f79 /kde-misc/kio-locate
parentStable on sparc (diff)
downloadgentoo-2-56fb7f6428e53f4984704d2cf9da07c1a107e8b6.tar.gz
gentoo-2-56fb7f6428e53f4984704d2cf9da07c1a107e8b6.tar.bz2
gentoo-2-56fb7f6428e53f4984704d2cf9da07c1a107e8b6.zip
version bump
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'kde-misc/kio-locate')
-rw-r--r--kde-misc/kio-locate/ChangeLog7
-rw-r--r--kde-misc/kio-locate/Manifest4
-rw-r--r--kde-misc/kio-locate/files/digest-kio-locate-0.4.41
-rw-r--r--kde-misc/kio-locate/kio-locate-0.4.4.ebuild36
4 files changed, 46 insertions, 2 deletions
diff --git a/kde-misc/kio-locate/ChangeLog b/kde-misc/kio-locate/ChangeLog
index 664bca04e790..b6231ffe812f 100644
--- a/kde-misc/kio-locate/ChangeLog
+++ b/kde-misc/kio-locate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/kio-locate
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-locate/ChangeLog,v 1.17 2005/10/17 23:02:19 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-locate/ChangeLog,v 1.18 2005/10/24 15:36:07 carlo Exp $
+
+*kio-locate-0.4.4 (24 Oct 2005)
+
+ 24 Oct 2005; Carsten Lohrke <carlo@gentoo.org> +kio-locate-0.4.4.ebuild:
+ version bump
17 Oct 2005; Carsten Lohrke <carlo@gentoo.org> kio-locate-0.4.3.ebuild:
accidentally dropped scons dependency
diff --git a/kde-misc/kio-locate/Manifest b/kde-misc/kio-locate/Manifest
index 8595db25a046..8b34fca614e8 100644
--- a/kde-misc/kio-locate/Manifest
+++ b/kde-misc/kio-locate/Manifest
@@ -1,7 +1,9 @@
MD5 9236f23e7ccb7fe8cec20c2c5ca5e9ec kio-locate-0.3.4.ebuild 538
+MD5 419867aad51b1712a0e10d63fff8c3e4 kio-locate-0.4.4.ebuild 949
MD5 2efa12b98b3032c685f76b471f206bc1 kio-locate-0.4.3.ebuild 1053
-MD5 21254598ab22f292046879d790911ff6 ChangeLog 2106
+MD5 888bd58aed006d222d688f688ebe1259 ChangeLog 2230
MD5 02039d51ca4a42817775fd436dfaa956 metadata.xml 157
MD5 b4f99851d93b23a06933e2cc883efcdb files/kde.py-bksys-1.5.1.diff 504
MD5 149ef0ef857ecaa5596a4efc341027a9 files/digest-kio-locate-0.3.4 68
MD5 5bd3f548f1edfa37dd7bb8ec16792269 files/digest-kio-locate-0.4.3 68
+MD5 303a3e274ff1ef17146ee7e057475c89 files/digest-kio-locate-0.4.4 68
diff --git a/kde-misc/kio-locate/files/digest-kio-locate-0.4.4 b/kde-misc/kio-locate/files/digest-kio-locate-0.4.4
new file mode 100644
index 000000000000..a444319fc7f5
--- /dev/null
+++ b/kde-misc/kio-locate/files/digest-kio-locate-0.4.4
@@ -0,0 +1 @@
+MD5 180b7ae9e2023a52311aa4f6730d8c7e kio-locate_0.4.4.tar.gz 155628
diff --git a/kde-misc/kio-locate/kio-locate-0.4.4.ebuild b/kde-misc/kio-locate/kio-locate-0.4.4.ebuild
new file mode 100644
index 000000000000..abbfb8c6852f
--- /dev/null
+++ b/kde-misc/kio-locate/kio-locate-0.4.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-locate/kio-locate-0.4.4.ebuild,v 1.1 2005/10/24 15:36:07 carlo Exp $
+
+inherit kde
+
+DESCRIPTION="kio slave to search files with locate"
+HOMEPAGE="http://arminstraub.de/browse.php?page=programs_kiolocate"
+SRC_URI="http://www.arminstraub.de/downloads/kio-locate/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-util/scons-0.96.1"
+RDEPEND="|| ( sys-apps/slocate sys-apps/rlocate )"
+need-kde 3.1
+
+PATCHES="${FILESDIR}/kde.py-bksys-1.5.1.diff"
+
+src_compile() {
+ [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
+ addpredict "$QTDIR/etc/settings"
+
+ local myconf="kdeincludes=$(kde-config --prefix)/include prefix=/usr "
+ use amd64 && myconf="${myconf} libsuffix=64"
+
+ scons configure ${myconf} || die "configure failed"
+ scons ${MAKEOPTS} || die "scons failed"
+}
+
+src_install() {
+ DESTDIR="${D}" scons install
+ dodoc AUTHORS ChangeLog
+}