summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-20 06:23:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-20 06:23:29 +0000
commitf485fff0a51509ba1a0b1ff776e2da773fad57d5 (patch)
treeb1f05c0b06d068dbd783188f1e4a9744151cb64d /kde-base
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-f485fff0a51509ba1a0b1ff776e2da773fad57d5.tar.gz
gentoo-2-f485fff0a51509ba1a0b1ff776e2da773fad57d5.tar.bz2
gentoo-2-f485fff0a51509ba1a0b1ff776e2da773fad57d5.zip
Cleanup econf call, fix missing quotes, add lua useflag (and patch to disable lua altogether) to fix bug #120388.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/ChangeLog7
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5-lua.patch32
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.4-r2.ebuild40
3 files changed, 53 insertions, 26 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index afeb9e147cdd..e114a4d336a8 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.361 2006/09/19 22:27:35 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.362 2006/09/20 06:23:29 flameeyes Exp $
+
+ 20 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kdelibs-3.5-lua.patch, kdelibs-3.5.4-r2.ebuild:
+ Cleanup econf call, fix missing quotes, add lua useflag (and patch to
+ disable lua altogether) to fix bug #120388.
*kdelibs-3.5.4-r2 (19 Sep 2006)
diff --git a/kde-base/kdelibs/files/kdelibs-3.5-lua.patch b/kde-base/kdelibs/files/kdelibs-3.5-lua.patch
new file mode 100644
index 000000000000..72e25434ce08
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.5-lua.patch
@@ -0,0 +1,32 @@
+Index: kate/part/configure.in.in
+===================================================================
+--- kate/part/configure.in.in (revision 586622)
++++ kate/part/configure.in.in (working copy)
+@@ -4,6 +4,9 @@
+
+ HAVE_LUA=""
+
++ AC_ARG_WITH([lua],
++ AC_HELP_STRING([--without-lua], [Build without Lua libraries (default: check)]))
++
+ AC_ARG_WITH(lua-dir,
+ AC_HELP_STRING([--with-lua-dir=DIR],[where the root of Lua 5.x is installed]),
+ [
+@@ -21,6 +24,9 @@
+ LUA_LIBS="-L$withval" ])
+
+
++ if test "x$with_lua" = "xno"; then
++ AC_MSG_RESULT([Not using Lua])
++ else
+ if ! test "x$LUA" = "x"; then
+ AC_MSG_RESULT(using Lua from $LUA)
+ fi
+@@ -76,6 +82,7 @@
+ AC_SUBST(LUA)
+ AC_SUBST(LUA_INCLUDES)
+ AC_SUBST(LUA_LIBS)
++ fi
+
+ ])
+
diff --git a/kde-base/kdelibs/kdelibs-3.5.4-r2.ebuild b/kde-base/kdelibs/kdelibs-3.5.4-r2.ebuild
index 15071c16b377..ed44d738e1ca 100644
--- a/kde-base/kdelibs/kdelibs-3.5.4-r2.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.5.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.4-r2.ebuild,v 1.1 2006/09/19 22:27:36 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.4-r2.ebuild,v 1.2 2006/09/20 06:23:29 flameeyes Exp $
inherit kde flag-o-matic eutils multilib
set-kdedir 3.5
@@ -14,7 +14,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="3.5"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl noutempter openexr spell ssl tiff
-zeroconf kernel_linux fam"
+zeroconf kernel_linux fam lua"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
# so we recreate the entire DEPEND from scratch.
@@ -42,7 +42,8 @@ RDEPEND="$(qt_min_version 3.3.3)
fam? ( virtual/fam )
virtual/ghostscript
!noutempter? ( sys-libs/libutempter )
- !kde-base/kde-env"
+ !kde-base/kde-env
+ lua? ( dev-lang/lua )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
@@ -73,7 +74,7 @@ src_unpack() {
kde_src_unpack
if use legacyssl ; then
# This patch won't be included upstream, see bug #128922
- epatch ${WORKDIR}/patches/kdelibs_3.5.4-kssl-3des.patch || die "Patch did not apply."
+ epatch "${WORKDIR}/patches/kdelibs_3.5.4-kssl-3des.patch" || die "Patch did not apply."
fi
if use cups && has_version '>=net-print/cups-1.2_pre'; then
@@ -86,19 +87,21 @@ src_unpack() {
epatch "${WORKDIR}/kdeprint-3.5.2-cups-1.2-patches/"
fi
+ epatch "${FILESDIR}/${PN}-3.5-lua.patch"
+
# TODO - fix broken tests
- sed -i -e "s:client tests:client:" ${S}/dcop/Makefile.am
- sed -i -e "s:SUBDIRS = . ui tests:SUBDIRS = . ui:" ${S}/kspell2/Makefile.am
+ sed -i -e "s:client tests:client:" "${S}/dcop/Makefile.am"
+ sed -i -e "s:SUBDIRS = . ui tests:SUBDIRS = . ui:" "${S}/kspell2/Makefile.am"
# TODO - kspell2 Xspell plugins are automagically detected.
- # As nothing uses kspell2, don't install them.
- sed -i -e "s:plugins::" ${S}/kspell2/Makefile.am || die "sed failed"
+ # As nothing uses kspell2, don't install them.
+ sed -i -e "s:plugins::" "${S}/kspell2/Makefile.am" || die "sed failed"
}
src_compile() {
rm -f ${S}/configure
- myconf="--with-distribution=Gentoo
+ myconf="--with-distribution=Gentoo --disable-fast-malloc
$(use_enable fam libfam) $(use_enable kernel_linux dnotify)
--with-libart --with-libidn
$(use_with acl) $(use_with ssl)
@@ -106,26 +109,13 @@ src_compile() {
$(use_with kerberos gssapi) $(use_with tiff)
$(use_with jpeg2k jasper) $(use_with openexr)
$(use_enable cups) $(use_enable zeroconf dnssd)
- --without-hspell
- --without-aspell"
- if use noutempter ; then
- myconf="${myconf} --without-utempter"
- else
- myconf="${myconf} --with-utempter"
- fi
-
- if use spell && has_version app-text/aspell; then
- myconf="${myconf} --with-aspell"
- else
- myconf="${myconf} --without-aspell"
- fi
+ $(use_with !noutempter utempter) $(use_with lua)
+ --without-hspell --without-aspell"
if has_version x11-apps/rgb; then
myconf="${myconf} --with-rgbfile=/usr/share/X11/rgb.txt"
fi
- myconf="${myconf} --disable-fast-malloc"
-
# fix bug 58179, bug 85593
# kdelibs-3.4.0 needed -fno-gcse; 3.4.1 needs -mminimal-toc; this needs a
# closer look... - corsair
@@ -163,7 +153,7 @@ src_install() {
libdirs="${libdirs}:${PREFIX}/${libdir}"
done
- cat <<EOF > ${D}/etc/env.d/45kdepaths-${SLOT} # number goes down with version upgrade
+ cat <<EOF > "${D}"/etc/env.d/45kdepaths-${SLOT} # number goes down with version upgrade
PATH=${PREFIX}/bin
ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
LDPATH=${libdirs:1}