summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-10-29 08:47:43 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-10-29 08:47:43 +0000
commit9560201639aa94398dd092ed046ebaf6bf25d7f7 (patch)
tree50eb154d1239f4ba95a3bc7495a37e112c48072c /kde-base
parentVersion bump (diff)
downloadgentoo-2-9560201639aa94398dd092ed046ebaf6bf25d7f7.tar.gz
gentoo-2-9560201639aa94398dd092ed046ebaf6bf25d7f7.tar.bz2
gentoo-2-9560201639aa94398dd092ed046ebaf6bf25d7f7.zip
Revbump to back-port bug fix for kde bug 286481, now really
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdepim-common-libs/ChangeLog9
-rw-r--r--kde-base/kdepim-common-libs/files/kdepim-common-libs-4.11.2-gnupgattach.patch57
-rw-r--r--kde-base/kdepim-common-libs/kdepim-common-libs-4.11.2-r1.ebuild73
3 files changed, 138 insertions, 1 deletions
diff --git a/kde-base/kdepim-common-libs/ChangeLog b/kde-base/kdepim-common-libs/ChangeLog
index cee806af1939..c1f652a66c3d 100644
--- a/kde-base/kdepim-common-libs/ChangeLog
+++ b/kde-base/kdepim-common-libs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdepim-common-libs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.111 2013/10/10 03:56:21 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.112 2013/10/29 08:47:43 dilfridge Exp $
+
+*kdepim-common-libs-4.11.2-r1 (29 Oct 2013)
+
+ 29 Oct 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdepim-common-libs-4.11.2-r1.ebuild,
+ +files/kdepim-common-libs-4.11.2-gnupgattach.patch:
+ Revbump to back-port bug fix for kde bug 286481, now really
10 Oct 2013; Chris Reffett <creffett@gentoo.org>
files/install-composereditorng.patch:
diff --git a/kde-base/kdepim-common-libs/files/kdepim-common-libs-4.11.2-gnupgattach.patch b/kde-base/kdepim-common-libs/files/kdepim-common-libs-4.11.2-gnupgattach.patch
new file mode 100644
index 000000000000..3dce746a0d35
--- /dev/null
+++ b/kde-base/kdepim-common-libs/files/kdepim-common-libs-4.11.2-gnupgattach.patch
@@ -0,0 +1,57 @@
+commit bbbdbc2180036040cac2b66492e6f0fd01c2b28c
+Author: Sandro Knauß <mail@sandroknauss.de>
+Date: Mon Oct 21 02:47:31 2013 +0200
+
+ Fix 286481 - Unable to open attachments in encrypted messages
+
+ The node has to get a correct extra content and the filename must be
+ correctly point to the attachments inside the encrypted message.
+
+ BUG: 286481
+ BUG: 300937
+ FIXED-IN: 4.11.3
+ REVIEW: 113361
+
+diff --git a/messageviewer/viewer/nodehelper.cpp b/messageviewer/viewer/nodehelper.cpp
+index 311f655..8c8ff79 100644
+--- a/messageviewer/viewer/nodehelper.cpp
++++ b/messageviewer/viewer/nodehelper.cpp
+@@ -223,7 +223,7 @@ QString NodeHelper::writeNodeToTempFile(KMime::Content* node)
+ return existingFileName.toLocalFile();
+ }
+
+- QString fname = createTempDir( node->index().toString() );
++ QString fname = createTempDir( persistentIndex( node ) );
+ if ( fname.isEmpty() )
+ return QString();
+
+@@ -237,7 +237,6 @@ QString NodeHelper::writeNodeToTempFile(KMime::Content* node)
+ fname += '/' + fileName;
+
+ //kDebug() << "Create temp file: " << fname;
+-
+ QByteArray data = node->decodedContent();
+ if ( node->contentType()->isText() && data.size() > 0 ) {
+ // convert CRLF to LF before writing text attachments to disk
+@@ -260,7 +259,7 @@ KUrl NodeHelper::tempFileUrlFromNode( const KMime::Content *node )
+ if (!node)
+ return KUrl();
+
+- const QString index = node->index().toString();
++ const QString index = persistentIndex( node );
+
+ foreach ( const QString &path, mAttachmentFilesDir->temporaryFiles() ) {
+ int right = path.lastIndexOf( '/' );
+diff --git a/messageviewer/viewer/objecttreeparser.cpp b/messageviewer/viewer/objecttreeparser.cpp
+index cde17da..369ad95 100644
+--- a/messageviewer/viewer/objecttreeparser.cpp
++++ b/messageviewer/viewer/objecttreeparser.cpp
+@@ -803,7 +803,7 @@ bool ObjectTreeParser::writeOpaqueOrMultipartSignedData( KMime::Content* data,
+ bIsOpaqueSigned = true;
+
+ CryptoProtocolSaver cpws( this, cryptProto );
+- createAndParseTempNode( data, doCheck ? cleartext.data() : cleartextData->data(),
++ createAndParseTempNode( &sign, doCheck ? cleartext.data() : cleartextData->data(),
+ "opaque signed data" );
+
+ if ( htmlWriter() )
diff --git a/kde-base/kdepim-common-libs/kdepim-common-libs-4.11.2-r1.ebuild b/kde-base/kdepim-common-libs/kdepim-common-libs-4.11.2-r1.ebuild
new file mode 100644
index 000000000000..a2fc19f603c4
--- /dev/null
+++ b/kde-base/kdepim-common-libs/kdepim-common-libs-4.11.2-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/kdepim-common-libs-4.11.2-r1.ebuild,v 1.1 2013/10/29 08:47:43 dilfridge Exp $
+
+EAPI=5
+
+KMNAME="kdepim"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Common libraries for KDE PIM apps"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ >=app-office/akonadi-server-1.9.52
+ dev-libs/grantlee
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ $(add_kdebase_dep kdepimlibs)
+"
+RDEPEND="${DEPEND}
+ !kde-base/akonadi:4
+ !kde-base/libkdepim:4
+ !kde-base/libkleo:4
+ !kde-base/libkpgp:4
+ !<kde-base/kaddressbook-4.4.90:4
+ !kde-base/kdepim-wizards:4
+ !<kde-base/kmail-4.4.80:4
+ !<kde-base/korganizer-4.5.67:4
+ !<kde-base/kmail-4.10.95:4
+ app-crypt/gnupg
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+RESTRICT="test"
+# bug 393131
+
+KMEXTRA="
+ akonadi_next/
+ calendarsupport/
+ calendarviews/
+ composereditor-ng/
+ incidenceeditor-ng/
+ libkdepim/
+ libkdepimdbusinterfaces/
+ libkleo/
+ libkpgp/
+ kdgantt2/
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ ontologies/
+ pimcommon/
+ sendlateragent/
+ templateparser/
+"
+
+KMEXTRACTONLY="
+ kleopatra/
+ kmail/
+ knode/org.kde.knode.xml
+ korganizer/korgac/org.kde.korganizer.KOrgac.xml
+ korganizer/org.kde.korganizer.Korganizer.xml
+"
+
+KMSAVELIBS="true"
+
+PATCHES=(
+ "${FILESDIR}/install-composereditorng.patch"
+ "${FILESDIR}/${P}-gnupgattach.patch"
+)