summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-11-13 20:04:41 +0000
committerJohannes Huber <johu@gentoo.org>2012-11-13 20:04:41 +0000
commite5887348a09762aa4ead5f81c3bb23d791c4a150 (patch)
tree968c7fad525dbfa6c675a68437d9a858c0162ae7 /kde-base/pykde4
parent[bump] dev-perl/DBIx-Class-0.82.40 (diff)
downloadgentoo-2-e5887348a09762aa4ead5f81c3bb23d791c4a150.tar.gz
gentoo-2-e5887348a09762aa4ead5f81c3bb23d791c4a150.tar.bz2
gentoo-2-e5887348a09762aa4ead5f81c3bb23d791c4a150.zip
Remove KDE SC 4.9.1
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog5
-rw-r--r--kde-base/pykde4/pykde4-4.9.1.ebuild157
2 files changed, 4 insertions, 158 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 679036a60d6d..13733d18ee72 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.181 2012/11/08 23:26:56 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.182 2012/11/13 20:04:40 johu Exp $
+
+ 13 Nov 2012; Johannes Huber <johu@gentoo.org> -pykde4-4.9.1.ebuild:
+ Remove KDE SC 4.9.1
*pykde4-4.9.3 (08 Nov 2012)
diff --git a/kde-base/pykde4/pykde4-4.9.1.ebuild b/kde-base/pykde4/pykde4-4.9.1.ebuild
deleted file mode 100644
index 6ca4c69be0be..000000000000
--- a/kde-base/pykde4/pykde4-4.9.1.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.9.1.ebuild,v 1.1 2012/09/04 18:45:26 johu Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="*:2.5"
-RESTRICT_PYTHON_ABIS="*-jython 2.4 2.7-pypy-*"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-
-OPENGL_REQUIRED="always"
-inherit python portability kde4-base multilib
-
-DESCRIPTION="Python bindings for KDE4"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc examples semantic-desktop"
-REQUIRED_USE="test? ( semantic-desktop )"
-
-# blocker added due to compatibility issues and error during compile time
-RDEPEND="
- >=dev-python/sip-4.13.1
- $(add_kdebase_dep kdelibs 'opengl,semantic-desktop=')
- semantic-desktop? (
- $(add_kdebase_dep kdepimlibs 'semantic-desktop')
- >=dev-libs/soprano-2.8.0
- )
- aqua? ( >=dev-python/PyQt4-4.9[dbus,declarative,sql,svg,webkit,aqua] )
- !aqua? ( >=dev-python/PyQt4-4.9[dbus,declarative,sql,svg,webkit,X] )
-"
-DEPEND="${RDEPEND}
- sys-devel/libtool
-"
-
-pkg_setup() {
- python_pkg_setup
- kde4-base_pkg_setup
-
- have_python2=false
-
- scan_python_versions() {
- [[ ${PYTHON_ABI} == 2.* ]] && have_python2=true
- :
- }
- python_execute_function -q scan_python_versions
- if ! ${have_python2}; then
- ewarn "You do not have a Python 2 version selected."
- ewarn "kpythonpluginfactory will not be built"
- fi
-}
-
-src_prepare() {
- kde4-base_src_prepare
-
- if ! use examples; then
- sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i CMakeLists.txt \
- || die "Failed to disable examples"
- fi
-
- # See bug 322351
- use arm && epatch "${FILESDIR}/${PN}-4.4.4-arm-sip.patch"
-
- sed -i -e 's/kpythonpluginfactory /kpython${PYTHON_SHORT_VERSION}pluginfactory /g' kpythonpluginfactory/CMakeLists.txt
-
- if ${have_python2}; then
- mkdir -p "${WORKDIR}/wrapper" || die "failed to copy wrapper"
- cp "${FILESDIR}/kpythonpluginfactorywrapper.c-r1" "${WORKDIR}/wrapper/kpythonpluginfactorywrapper.c" || die "failed to copy wrapper"
- fi
-}
-
-src_configure() {
- configuration() {
- local mycmakeargs=(
- -DWITH_PolkitQt=OFF
- -DWITH_QScintilla=OFF
- $(cmake-utils_use_with semantic-desktop Soprano)
- $(cmake-utils_use_with semantic-desktop Nepomuk)
- $(cmake-utils_use_with semantic-desktop KdepimLibs)
- -DPYTHON_EXECUTABLE=$(PYTHON -a)
- )
- local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
- kde4-base_src_configure
- }
-
- python_execute_function configuration
-}
-
-echo_and_run() {
- echo "$@"
- "$@"
-}
-
-src_compile() {
- compilation() {
- local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
- kde4-base_src_compile
- }
- python_execute_function compilation
-
- if ${have_python2}; then
- cd "${WORKDIR}/wrapper"
- echo_and_run libtool --tag=CC --mode=compile $(tc-getCC) \
- -shared \
- ${CFLAGS} ${CPPFLAGS} \
- -DEPREFIX="\"${EPREFIX}\"" \
- -DPLUGIN_DIR="\"/usr/$(get_libdir)/kde4\"" -c \
- -o kpythonpluginfactorywrapper.lo \
- kpythonpluginfactorywrapper.c
- echo_and_run libtool --tag=CC --mode=link $(tc-getCC) \
- -shared -module -avoid-version \
- ${CFLAGS} ${LDFLAGS} \
- -o kpythonpluginfactory.la \
- -rpath "${EPREFIX}/usr/$(get_libdir)/kde4" \
- kpythonpluginfactorywrapper.lo \
- $(dlopen_lib)
- fi
-}
-
-src_install() {
- installation() {
- cd "${S}_build-${PYTHON_ABI}"
- emake DESTDIR="${T}/images/${PYTHON_ABI}" install
- }
- python_execute_function installation
-
- python_merge_intermediate_installation_images "${T}/images"
-
- # As we don't call the eclass's src_install, we have to install the docs manually
- DOCS=("${S}"/{AUTHORS,NEWS,README})
- use doc && HTML_DOCS=("${S}/docs/html/")
- base_src_install_docs
-
- if ${have_python2}; then
- cd "${WORKDIR}/wrapper"
- echo_and_run libtool --mode=install install kpythonpluginfactory.la "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
- rm "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
- fi
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- python_mod_optimize PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
-
- if use examples; then
- echo
- elog "PyKDE4 examples have been installed to"
- elog "${EPREFIX}/usr/share/apps/${PN}/examples"
- echo
- fi
-}
-
-pkg_postrm() {
- kde4-base_pkg_postrm
-
- python_mod_cleanup PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
-}