summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-01-10 04:22:20 +0000
committerChris Reffett <creffett@gentoo.org>2014-01-10 04:22:20 +0000
commit803efb3b1f3061a26772f670a2e44a59efbf3f3f (patch)
tree82f2adcff5045d9821efd3318efe2cacf46c43ea /kde-base/plasma-workspace
parent0.7.5 bump (diff)
downloadgentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.tar.gz
gentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.tar.bz2
gentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.zip
Bump KDE SC 4.11.5
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/plasma-workspace')
-rw-r--r--kde-base/plasma-workspace/ChangeLog11
-rw-r--r--kde-base/plasma-workspace/plasma-workspace-4.11.5.ebuild126
2 files changed, 135 insertions, 2 deletions
diff --git a/kde-base/plasma-workspace/ChangeLog b/kde-base/plasma-workspace/ChangeLog
index f2f64ba9bc8d..e8e9b7422913 100644
--- a/kde-base/plasma-workspace/ChangeLog
+++ b/kde-base/plasma-workspace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/plasma-workspace
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.255 2013/12/14 22:23:58 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.256 2014/01/10 04:21:31 creffett Exp $
+
+*plasma-workspace-4.11.5 (10 Jan 2014)
+
+ 10 Jan 2014; Chris Reffett <creffett@gentoo.org>
+ +plasma-workspace-4.11.5.ebuild,
+ files/plasma-workspace-4.10.1-noplasmalock.patch:
+ Bump KDE SC 4.11.5
14 Dec 2013; Johannes Huber <johu@gentoo.org>
-files/plasma-workspace-4.10.4-crypt.patch,
diff --git a/kde-base/plasma-workspace/plasma-workspace-4.11.5.ebuild b/kde-base/plasma-workspace/plasma-workspace-4.11.5.ebuild
new file mode 100644
index 000000000000..3b80467a631a
--- /dev/null
+++ b/kde-base/plasma-workspace/plasma-workspace-4.11.5.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.11.5.ebuild,v 1.1 2014/01/10 04:21:31 creffett Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+KMMODULE="plasma"
+PYTHON_COMPAT=( python2_{6,7} )
+OPENGL_REQUIRED="always"
+inherit python-single-r1 kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gps json python qalculate semantic-desktop"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMONDEPEND="
+ dev-libs/libdbusmenu-qt
+ >=dev-qt/qtcore-4.8.4-r3:4
+ !kde-misc/ktouchpadenabler
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep ksysguard)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep libplasmaclock 'semantic-desktop?')
+ $(add_kdebase_dep libplasmagenericshell)
+ $(add_kdebase_dep libtaskmanager)
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ gps? ( >=sci-geosciences/gpsd-2.37 )
+ json? ( dev-libs/qjson )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt4-4.4.0[X,${PYTHON_USEDEP}]
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ )
+ qalculate? ( sci-libs/libqalculate )
+ semantic-desktop? (
+ dev-libs/soprano
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep nepomuk-core)
+ )
+"
+DEPEND="${COMMONDEPEND}
+ dev-libs/boost
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}
+ $(add_kdebase_dep plasma-runtime)
+"
+
+KMEXTRA="
+ appmenu/
+ ktouchpadenabler/
+ statusnotifierwatcher/
+"
+KMEXTRACTONLY="
+ kcheckpass/
+ krunner/dbus/org.freedesktop.ScreenSaver.xml
+ krunner/dbus/org.kde.krunner.App.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ ksmserver/screenlocker/
+ libs/kephal/
+ libs/kworkspace/
+ libs/taskmanager/
+ libs/plasmagenericshell/
+ libs/ksysguard/
+ libs/kdm/kgreeterplugin.h
+ ksysguard/
+"
+
+KMLOADLIBS="libkworkspace libplasmaclock libplasmagenericshell libtaskmanager"
+
+PATCHES=( "${FILESDIR}/${PN}-4.10.1-noplasmalock.patch" )
+
+pkg_setup() {
+ if use python ; then
+ python-single-r1_pkg_setup
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+=" doc/plasma-desktop"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with gps libgps)
+ $(cmake-utils_use_with json QJSON)
+ $(cmake-utils_use_with python PythonLibrary)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with semantic-desktop Akonadi)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop NepomukCore)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ -DWITH_Xmms=OFF
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ if use python; then
+ python_optimize "${ED}"
+ fi
+}