summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-01 18:10:05 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-01 18:10:05 +0000
commitb0c8c41397c5a2e84e4a1126a6ac202205014ee7 (patch)
tree1c82eef4e9829216eda4b7a814332e668a7afcea /kde-base/phonon-kde
parentVersion bump to snapshot version since there are a lot of fixes and upstream ... (diff)
downloadgentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.tar.gz
gentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.tar.bz2
gentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.zip
Version bump KDE SC 4.12.4
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog7
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.12.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index ec35231ec50e..6bf512e89152 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.212 2014/03/11 13:06:30 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.213 2014/04/01 18:09:24 johu Exp $
+
+*phonon-kde-4.12.4 (01 Apr 2014)
+
+ 01 Apr 2014; Johannes Huber <johu@gentoo.org> +phonon-kde-4.12.4.ebuild:
+ Version bump KDE SC 4.12.4
11 Mar 2014; Johannes Huber <johu@gentoo.org> -phonon-kde-4.12.2.ebuild:
Remove KDE SC 4.12.2
diff --git a/kde-base/phonon-kde/phonon-kde-4.12.4.ebuild b/kde-base/phonon-kde/phonon-kde-4.12.4.ebuild
new file mode 100644
index 000000000000..4002c86c3a4f
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.12.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.12.4.ebuild,v 1.1 2014/04/01 18:09:24 johu Exp $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa debug pulseaudio"
+
+DEPEND="
+ >=media-libs/phonon-4.4.3
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ -DWITH_Xine=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}