summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
commit588eb8e56926b65029e4de63aa398e51ed8cc9b8 (patch)
tree356a5e95843b62ad54fc9c77facba6ff67c4db94 /kde-base/ksysguard/ksysguard-4.4.5.ebuild
parentx86 stable, bug 323729 (diff)
downloadgentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.gz
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.bz2
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.zip
[kde-base] Bump KDE SC 4.4.5 =)
(Portage version: 2.2_rc67_p182/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ksysguard/ksysguard-4.4.5.ebuild')
-rw-r--r--kde-base/ksysguard/ksysguard-4.4.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/ksysguard/ksysguard-4.4.5.ebuild b/kde-base/ksysguard/ksysguard-4.4.5.ebuild
new file mode 100644
index 000000000000..9f21a0a1b184
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.4.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.4.5.ebuild,v 1.1 2010/06/30 15:36:33 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook lm_sensors"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}