summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-07 20:43:13 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-07 20:43:13 +0000
commita6736c7fd817d8d42eaff890b89f197e31cb859a (patch)
treec3d28ce4b0d1cca6746d57f6a7e23dcc386ef641 /kde-base/ksayit
parentAllow mixing of split & monolithic ebuilds, where possible, thanks to Arfreve... (diff)
downloadgentoo-2-a6736c7fd817d8d42eaff890b89f197e31cb859a.tar.gz
gentoo-2-a6736c7fd817d8d42eaff890b89f197e31cb859a.tar.bz2
gentoo-2-a6736c7fd817d8d42eaff890b89f197e31cb859a.zip
Allow mixing of split & monolithic ebuilds, where possible, thanks to Arfrever Frehtes Taifersar Arahesis!
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/ksayit')
-rw-r--r--kde-base/ksayit/ChangeLog6
-rw-r--r--kde-base/ksayit/ksayit-3.5.9.ebuild13
2 files changed, 16 insertions, 3 deletions
diff --git a/kde-base/ksayit/ChangeLog b/kde-base/ksayit/ChangeLog
index fc50757b3f0b..c8e26c49b421 100644
--- a/kde-base/ksayit/ChangeLog
+++ b/kde-base/ksayit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ksayit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ChangeLog,v 1.88 2008/03/04 04:06:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ChangeLog,v 1.89 2008/03/07 20:43:13 ingmar Exp $
+
+ 07 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org> ksayit-3.5.9.ebuild:
+ Allow mixing of split & monolithic ebuilds, where possible, thanks to
+ Arfrever Frehtes Taifersar Arahesis!
04 Mar 2008; Jeroen Roovers <jer@gentoo.org> ksayit-3.5.8.ebuild,
ksayit-3.5.9.ebuild:
diff --git a/kde-base/ksayit/ksayit-3.5.9.ebuild b/kde-base/ksayit/ksayit-3.5.9.ebuild
index 50043856f14b..3e4fb7ed0966 100644
--- a/kde-base/ksayit/ksayit-3.5.9.ebuild
+++ b/kde-base/ksayit/ksayit-3.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.5.9.ebuild,v 1.2 2008/03/04 04:06:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.5.9.ebuild,v 1.3 2008/03/07 20:43:13 ingmar Exp $
KMNAME=kdeaccessibility
EAPI="1"
inherit kde-meta
@@ -11,10 +11,19 @@ IUSE=""
DEPEND=">=kde-base/kttsd-${PV}:${SLOT}
>=kde-base/arts-${PV}:${SLOT}
- >=kde-base/kdemultimedia-arts-${PV}:${SLOT}"
+ || ( >=kde-base/kdemultimedia-arts-${PV}:${SLOT} >=kde-base/kdemultimedia-${PV}:${SLOT} )"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ kde_pkg_setup
+
+ if has_version kde-base/kdemultimedia:${SLOT} && ! built_with_use kde-base/kdemultimedia:${SLOT} arts ; then
+ eerror "You have \"arts\" USE flag enabled, but kde-base/kdemultimedia:${SLOT} was built with this flag disabled."
+ die "Reinstall kde-base/kdemultimedia:${SLOT} with USE=\"arts\""
+ fi
+}
+
src_compile() {
myconf="--enable-ksayit-audio-plugins"
kde-meta_src_compile