summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
commit4cba78c8fcd56c326a180b231d15e11076652ab8 (patch)
tree2c17ca88ed78d7e028d5db315475f32581f8ef0d /kde-base/kimono
parentVersion bump. (diff)
downloadgentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.gz
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.bz2
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.zip
Version bump KDE SC 4.12.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kimono')
-rw-r--r--kde-base/kimono/ChangeLog7
-rw-r--r--kde-base/kimono/kimono-4.12.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kimono/ChangeLog b/kde-base/kimono/ChangeLog
index 85c366a5b2cb..ba0817e487d0 100644
--- a/kde-base/kimono/ChangeLog
+++ b/kde-base/kimono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kimono
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.103 2014/01/20 15:00:04 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.104 2014/02/06 23:20:15 dilfridge Exp $
+
+*kimono-4.12.2 (06 Feb 2014)
+
+ 06 Feb 2014; Andreas K. Huettel <dilfridge@gentoo.org> +kimono-4.12.2.ebuild:
+ Version bump KDE SC 4.12.2
20 Jan 2014; Michael Palimaka <kensington@gentoo.org> -kimono-4.12.0.ebuild:
Remove KDE SC 4.12.0
diff --git a/kde-base/kimono/kimono-4.12.2.ebuild b/kde-base/kimono/kimono-4.12.2.ebuild
new file mode 100644
index 000000000000..035d2c795cfb
--- /dev/null
+++ b/kde-base/kimono/kimono-4.12.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.12.2.ebuild,v 1.1 2014/02/06 23:20:15 dilfridge Exp $
+
+EAPI=5
+
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for KDE"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug plasma semantic-desktop"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep qyoto 'webkit')
+ $(add_kdebase_dep smokeqt)
+ $(add_kdebase_dep smokekde 'semantic-desktop?')
+ plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ -DWITH_Soprano=OFF
+ )
+ kde4-base_src_configure
+}