summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-03-10 23:34:44 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-03-10 23:34:44 +0000
commitde91cd8eb7a3f9623dc115f2b019f26b81617eeb (patch)
treef72d88ebfbe3713ef14c3e241ea6a0a7fe14a44a /kde-base/kdepimlibs
parentVersion bump to KDE 4.0.2. (diff)
downloadgentoo-2-de91cd8eb7a3f9623dc115f2b019f26b81617eeb.tar.gz
gentoo-2-de91cd8eb7a3f9623dc115f2b019f26b81617eeb.tar.bz2
gentoo-2-de91cd8eb7a3f9623dc115f2b019f26b81617eeb.zip
Version bump to KDE 4.0.2.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.0.2.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index aa701f4afd4c..bf4bbb617d52 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.6 2008/03/05 19:04:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.7 2008/03/10 23:34:44 philantrop Exp $
+
+*kdepimlibs-4.0.2 (10 Mar 2008)
+
+ 10 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdepimlibs-4.0.2.ebuild:
+ Version bump to KDE 4.0.2
05 Mar 2008; Jeroen Roovers <jer@gentoo.org> kdepimlibs-4.0.1.ebuild:
Marked ~hppa.
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.0.2.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.0.2.ebuild
new file mode 100644
index 000000000000..a3fecfa03b02
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.0.2.ebuild,v 1.1 2008/03/10 23:34:44 philantrop Exp $
+
+EAPI="1"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook ldap sasl"
+LICENSE="GPL-2 LGPL-2"
+# tests last checked in 4.0.2. over 50% fails. a lot hang.
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ dev-libs/boost
+ dev-libs/libgpg-error
+ ldap? ( >=net-nds/openldap-2 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with ldap Ldap)
+ $(cmake-utils_use_with sasl Sasl2)"
+ kde4-base_src_compile
+}