summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-09-16 18:17:35 +0000
committerJohannes Huber <johu@gentoo.org>2014-09-16 18:17:35 +0000
commitf8633b9ab4fbc263024fc7d9e4b25610366de9c2 (patch)
tree6a1fa56dffbbac34e8c5f2f3a57fbdac07646b6c /kde-base/kdepim-runtime
parentAlways download/symlink unifont, bug 522956. (diff)
downloadgentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.tar.gz
gentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.tar.bz2
gentoo-2-f8633b9ab4fbc263024fc7d9e4b25610366de9c2.zip
Version bump KDE SC 4.14.1
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog7
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.14.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index c1d2b832f1ea..b1ff8c982b34 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.218 2014/08/20 16:02:47 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.219 2014/09/16 18:17:26 johu Exp $
+
+*kdepim-runtime-4.14.1 (16 Sep 2014)
+
+ 16 Sep 2014; Johannes Huber <johu@gentoo.org> +kdepim-runtime-4.14.1.ebuild:
+ Version bump KDE SC 4.14.1
*kdepim-runtime-4.14.0 (20 Aug 2014)
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.14.1.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.14.1.ebuild
new file mode 100644
index 000000000000..297f3fd6f4e8
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.14.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.14.1.ebuild,v 1.1 2014/09/16 18:17:26 johu Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ >=app-office/akonadi-server-1.12.90
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi )
+ google? ( >=net-libs/libkgapi-2.0 )
+ kolab? ( >=net-libs/libkolab-0.5 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}