summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commitb55417d98c3ac6be2310a3971632cceac43c9378 (patch)
tree76ff040300cffb0bfdb60a4c1a785df48fbbf7cd /kde-base/kcheckpass
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadgentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.gz
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.bz2
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.zip
[kde-base] Add KDE SC 4.6.0
(Portage version: 2.2.0_alpha19_p2/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.6.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 19bd39a35a59..6728a7d14f52 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.175 2011/01/10 11:53:23 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.176 2011/01/26 20:28:46 alexxy Exp $
+
+*kcheckpass-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org> +kcheckpass-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*kcheckpass-4.5.5 (10 Jan 2011)
diff --git a/kde-base/kcheckpass/kcheckpass-4.6.0.ebuild b/kde-base/kcheckpass/kcheckpass-4.6.0.ebuild
new file mode 100644
index 000000000000..f19f88462862
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.6.0.ebuild,v 1.1 2011/01/26 20:28:46 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+DEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}