summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-06-03 23:04:54 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-06-03 23:04:54 +0000
commit0c93075e937ba5c2a7cbedac1fdd56415483da7d (patch)
tree381cbf46e9bf141548eabf78ce48416685189a44 /kde-base/kcheckpass
parentSync verbosely with overlay. Add support for kde4 localization package kde-ap... (diff)
downloadgentoo-2-0c93075e937ba5c2a7cbedac1fdd56415483da7d.tar.gz
gentoo-2-0c93075e937ba5c2a7cbedac1fdd56415483da7d.tar.bz2
gentoo-2-0c93075e937ba5c2a7cbedac1fdd56415483da7d.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.20.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 442651ec38f8..817d98e50689 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.339 2015/05/15 15:53:07 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.340 2015/06/03 23:04:52 mrueg Exp $
+
+*kcheckpass-4.11.20 (03 Jun 2015)
+
+ 03 Jun 2015; Manuel Rüger <mrueg@gentoo.org> +kcheckpass-4.11.20.ebuild:
+ Version bump.
*kcheckpass-4.11.19 (15 May 2015)
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.20.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.20.ebuild
new file mode 100644
index 000000000000..6d0aa6c01eee
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.20.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.11.20.ebuild,v 1.1 2015/06/03 23:04:52 mrueg Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}