summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
commit0650db9ab87aa55db42a5157e24d12132d2832ae (patch)
treefb6d626c063029446861ab8305a09ef01b29fd36 /kde-base/kcheckpass
parentVersion bump. Remove intermediate version. (diff)
downloadgentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.tar.gz
gentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.tar.bz2
gentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.zip
Version bump to KDE SC 4.6.3.
(Portage version: 2.2.0_alpha31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog8
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.6.3.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index cd4d5dbe3df3..185a3a8bb7d2 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.178 2011/04/06 14:19:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.179 2011/05/07 10:48:07 scarabeus Exp $
+
+*kcheckpass-4.6.3 (07 May 2011)
+
+ 07 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +kcheckpass-4.6.3.ebuild:
+ Version bump KDE SC 4.6.3
*kcheckpass-4.6.2 (06 Apr 2011)
diff --git a/kde-base/kcheckpass/kcheckpass-4.6.3.ebuild b/kde-base/kcheckpass/kcheckpass-4.6.3.ebuild
new file mode 100644
index 000000000000..b8e771b18810
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.6.3.ebuild,v 1.1 2011/05/07 10:48:07 scarabeus Exp $
+
+EAPI=4
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+DEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}