summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-19 21:54:56 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-19 21:54:56 +0000
commit708e3b7a00087afd62643ab38c30983420daa779 (patch)
tree407f9b1216d35f3110489404b612accb383d4804 /kde-base/kalzium
parentBump to KDE 3.5.8. (diff)
downloadgentoo-2-708e3b7a00087afd62643ab38c30983420daa779.tar.gz
gentoo-2-708e3b7a00087afd62643ab38c30983420daa779.tar.bz2
gentoo-2-708e3b7a00087afd62643ab38c30983420daa779.zip
Bump to KDE 3.5.8.
(Portage version: 2.1.3.15)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog8
-rw-r--r--kde-base/kalzium/files/digest-kalzium-3.5.83
-rw-r--r--kde-base/kalzium/files/kalzium-3.5.7-copy_string.patch11
-rw-r--r--kde-base/kalzium/kalzium-3.5.8.ebuild35
4 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index ea535a339cc6..5bd509342316 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.74 2007/08/11 16:24:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.75 2007/10/19 21:54:55 philantrop Exp $
+
+*kalzium-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kalzium-3.5.7-copy_string.patch, +kalzium-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
11 Aug 2007; Raúl Porcel <armin76@gentoo.org> kalzium-3.5.7.ebuild:
x86 stable wrt #185823
diff --git a/kde-base/kalzium/files/digest-kalzium-3.5.8 b/kde-base/kalzium/files/digest-kalzium-3.5.8
new file mode 100644
index 000000000000..08701360db9b
--- /dev/null
+++ b/kde-base/kalzium/files/digest-kalzium-3.5.8
@@ -0,0 +1,3 @@
+MD5 aaae4c6fe82c806eb20942178cadad9e kdeedu-3.5.8.tar.bz2 30158456
+RMD160 e15dc74c572da3035b3daceb66c75b14d6e14818 kdeedu-3.5.8.tar.bz2 30158456
+SHA256 dddd4bef001ece864afe9502fe82c460dcf6329b9522ae0a4a2d0b94b5648b9b kdeedu-3.5.8.tar.bz2 30158456
diff --git a/kde-base/kalzium/files/kalzium-3.5.7-copy_string.patch b/kde-base/kalzium/files/kalzium-3.5.7-copy_string.patch
new file mode 100644
index 000000000000..6cdaf6c35aeb
--- /dev/null
+++ b/kde-base/kalzium/files/kalzium-3.5.7-copy_string.patch
@@ -0,0 +1,11 @@
+diff -Naur kalzium-3.5.7.orig/kalzium/src/solver/modwrap.c kalzium-3.5.7/kalzium/src/solver/modwrap.c
+--- kalzium-3.5.7.orig/kalzium/src/solver/modwrap.c 2005-10-10 16:55:41.000000000 +0200
++++ kalzium-3.5.7/kalzium/src/solver/modwrap.c 2007-09-10 21:55:52.000000000 +0200
+@@ -23,6 +23,7 @@
+
+ #include <caml/mlvalues.h>
+ #include <caml/callback.h>
++#include <caml/alloc.h>
+
+ char* solve_equation(const char * eq)
+ {
diff --git a/kde-base/kalzium/kalzium-3.5.8.ebuild b/kde-base/kalzium/kalzium-3.5.8.ebuild
new file mode 100644
index 000000000000..d7d075e09b59
--- /dev/null
+++ b/kde-base/kalzium/kalzium-3.5.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-3.5.8.ebuild,v 1.1 2007/10/19 21:54:55 philantrop Exp $
+KMNAME=kdeedu
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit flag-o-matic kde-meta
+
+DESCRIPTION="KDE: periodic table of the elements"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="solver"
+HOMEPAGE="http://edu.kde.org/kalzium"
+
+DEPEND="$(deprange 3.5.7-r1 $MAXKDEVER kde-base/libkdeedu)
+ solver? ( >=dev-ml/facile-1.1 )"
+
+KMEXTRACTONLY="libkdeedu/kdeeduplot
+ libkdeedu/kdeeduui"
+KMCOPYLIB="libkdeeduplot libkdeedu/kdeeduplot
+ libkdeeduui libkdeedu/kdeeduui"
+
+PATCHES="${FILESDIR}/${PN}-3.5.7-copy_string.patch"
+
+src_compile() {
+ append-ldflags -Wl,-z,noexecstack
+
+ local myconf="$(use_enable solver ocamlsolver)"
+
+ if use solver ; then
+ cd "${S}/${PN}/src/solver"
+ emake || die "compiling the ocaml resolver failed"
+ fi
+
+ kde-meta_src_compile
+}