summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
commit4cba78c8fcd56c326a180b231d15e11076652ab8 (patch)
tree2c17ca88ed78d7e028d5db315475f32581f8ef0d /kde-base/kalzium
parentVersion bump. (diff)
downloadgentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.gz
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.bz2
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.zip
Version bump KDE SC 4.12.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog8
-rw-r--r--kde-base/kalzium/kalzium-4.12.2.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index bbca94891b70..7d186224d649 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.306 2014/01/20 15:00:05 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.307 2014/02/06 23:20:13 dilfridge Exp $
+
+*kalzium-4.12.2 (06 Feb 2014)
+
+ 06 Feb 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kalzium-4.12.2.ebuild:
+ Version bump KDE SC 4.12.2
20 Jan 2014; Michael Palimaka <kensington@gentoo.org> -kalzium-4.12.0.ebuild:
Remove KDE SC 4.12.0
diff --git a/kde-base/kalzium/kalzium-4.12.2.ebuild b/kde-base/kalzium/kalzium-4.12.2.ebuild
new file mode 100644
index 000000000000..42706bc1911d
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.12.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.12.2.ebuild,v 1.1 2014/02/06 23:20:13 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements."
+HOMEPAGE="http://www.kde.org/applications/education/kalzium
+http://edu.kde.org/kalzium"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +plasma solver"
+
+DEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? (
+ >=dev-cpp/eigen-2.0.3:2
+ sci-chemistry/avogadro
+ >=sci-chemistry/openbabel-2.2
+ )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND=${DEPEND}
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor Avogadro)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}