summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-07-12 22:04:28 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-07-12 22:04:28 +0000
commit201b429dd0602047b64d14bc3670a0007c3509a3 (patch)
treec057e9502ea915d4baf117f74b2859be0eb4fafb /kde-base/kalarm/kalarm-4.4.2015.06.ebuild
parentVersion bump to Pali Rohar's noakonadi branch (diff)
downloadgentoo-2-201b429dd0602047b64d14bc3670a0007c3509a3.tar.gz
gentoo-2-201b429dd0602047b64d14bc3670a0007c3509a3.tar.bz2
gentoo-2-201b429dd0602047b64d14bc3670a0007c3509a3.zip
Version bump to Pali Rohar's noakonadi branch
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0B08240A96F66571)
Diffstat (limited to 'kde-base/kalarm/kalarm-4.4.2015.06.ebuild')
-rw-r--r--kde-base/kalarm/kalarm-4.4.2015.06.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/kalarm/kalarm-4.4.2015.06.ebuild b/kde-base/kalarm/kalarm-4.4.2015.06.ebuild
new file mode 100644
index 000000000000..57e03df2b2d8
--- /dev/null
+++ b/kde-base/kalarm/kalarm-4.4.2015.06.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalarm/kalarm-4.4.2015.06.ebuild,v 1.1 2015/07/12 22:04:28 dilfridge Exp $
+
+EAPI=5
+
+KMNAME="kdepim"
+KDE_HANDBOOK=optional
+inherit kde4-meta
+
+DESCRIPTION="Personal alarm message, command and email scheduler for KDE (noakonadi branch)"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdebase_dep kdepimlibs '' 4.6)
+ $(add_kdebase_dep libkdepim)
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ dev-libs/libxslt
+"
+
+KMEXTRACTONLY="
+ kmail/
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.11.1-underlinking.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_akonadi=OFF
+ -DXSLTPROC_EXECUTABLE="${EPREFIX}"/usr/bin/xsltproc
+ )
+ kde4-meta_src_configure
+}