summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
commit8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38 (patch)
tree101b1b44b57d9ee9df5ea837005a27beae915f3d /kde-base/dolphin
parentAdd support for Prefix. bug #407193 (diff)
downloadgentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.tar.gz
gentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.tar.bz2
gentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.zip
Version bump KDE SC 4.8.1
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.8.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index e1601e6b7b73..2217954ea9a6 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.126 2012/02/21 12:52:34 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.127 2012/03/06 23:35:19 dilfridge Exp $
+
+*dolphin-4.8.1 (06 Mar 2012)
+
+ 06 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> +dolphin-4.8.1.ebuild:
+ Version bump KDE SC 4.8.1
20 Feb 2012; Johannes Huber <johu@gentoo.org> -dolphin-4.6.3.ebuild:
Remove KDE SC 4.6.3
diff --git a/kde-base/dolphin/dolphin-4.8.1.ebuild b/kde-base/dolphin/dolphin-4.8.1.ebuild
new file mode 100644
index 000000000000..e30770cc4b64
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.8.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.8.1.ebuild,v 1.1 2012/03/06 23:35:19 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( dev-libs/shared-desktop-ontologies )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ echo
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ echo
+}