summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-03-06 23:35:37 +0000
commit8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38 (patch)
tree101b1b44b57d9ee9df5ea837005a27beae915f3d /kde-base/dolphin-plugins
parentAdd support for Prefix. bug #407193 (diff)
downloadgentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.tar.gz
gentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.tar.bz2
gentoo-2-8ba7b39dcce5286ea5776b5f7b3d9f7a27ecff38.zip
Version bump KDE SC 4.8.1
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog8
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.8.1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 26a92911dca6..b9fad4aa2809 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.42 2012/02/21 12:52:29 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.43 2012/03/06 23:35:17 dilfridge Exp $
+
+*dolphin-plugins-4.8.1 (06 Mar 2012)
+
+ 06 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +dolphin-plugins-4.8.1.ebuild:
+ Version bump KDE SC 4.8.1
20 Feb 2012; Johannes Huber <johu@gentoo.org> -dolphin-plugins-4.6.3.ebuild:
Remove KDE SC 4.6.3
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.8.1.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.8.1.ebuild
new file mode 100644
index 000000000000..262efd45cccb
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.8.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.8.1.ebuild,v 1.1 2012/03/06 23:35:17 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bazaar git mercurial subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )
+"
+
+KMLOADLIBS="libkonq"
+
+#
+# See bug 351147 for why this is necessary
+#
+src_prepare() {
+ echo 'macro_optional_add_subdirectory ( dolphin-plugins )' >> CMakeLists.txt || die
+ echo > dolphin-plugins/CMakeLists.txt || die
+ use bazaar && echo 'add_subdirectory ( bazaar )' >> dolphin-plugins/CMakeLists.txt
+ use git && echo 'add_subdirectory ( git )' >> dolphin-plugins/CMakeLists.txt
+ use mercurial && echo 'add_subdirectory ( hg )' >> dolphin-plugins/CMakeLists.txt
+ use subversion && echo 'add_subdirectory ( svn )' >> dolphin-plugins/CMakeLists.txt
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ { use bazaar || use git || use mercurial || use subversion; } && kde4-meta_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use git && ! use mercurial && ! use subversion ; then
+ einfo
+ einfo "You have disabled all plugin use flags. If you want to have vcs"
+ einfo "integration in dolphin, enable those of your needs."
+ einfo
+ fi
+}