summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
commit318092ea225b3d6ad7192e8ae024a631e482b266 (patch)
tree91df8808be8c8389bc73293ff837135ae83c78e3 /kde-base/dolphin-plugins
parentUpdate init file /var/run/apcupsd directory > /run/apcupsd (diff)
downloadgentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.gz
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.bz2
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.zip
Version bump KDE SC 4.11.4
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog7
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.11.4.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 75037c09007b..b05b7b73d33a 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.118 2013/11/05 22:22:56 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.119 2013/12/03 22:35:44 johu Exp $
+
+*dolphin-plugins-4.11.4 (03 Dec 2013)
+
+ 03 Dec 2013; Johannes Huber <johu@gentoo.org> +dolphin-plugins-4.11.4.ebuild:
+ Version bump KDE SC 4.11.4
*dolphin-plugins-4.11.3 (05 Nov 2013)
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.11.4.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.11.4.ebuild
new file mode 100644
index 000000000000..ceed0da9df5d
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.11.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.11.4.ebuild,v 1.1 2013/12/03 22:35:45 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bazaar git mercurial subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )
+"
+
+src_install() {
+ { use bazaar || use git || use mercurial || use subversion; } && kde4-base_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use git && ! use mercurial && ! use subversion ; then
+ einfo
+ einfo "You have disabled all plugin use flags. If you want to have vcs"
+ einfo "integration in dolphin, enable those of your needs."
+ einfo
+ fi
+}