summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-01 09:55:21 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-01 09:55:21 +0000
commit2ea65d720e9bc55ee25b494af42cbec2f6aff341 (patch)
treea8b1dff64d1a0adaff18e741a6f9ec16d2186ca7 /kde-base/akonadi
parentx86 stable, bug #278409 (diff)
downloadgentoo-2-2ea65d720e9bc55ee25b494af42cbec2f6aff341.tar.gz
gentoo-2-2ea65d720e9bc55ee25b494af42cbec2f6aff341.tar.bz2
gentoo-2-2ea65d720e9bc55ee25b494af42cbec2f6aff341.zip
Version bump KDE 4.3.4
(Portage version: 2.2_rc54/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/akonadi')
-rw-r--r--kde-base/akonadi/ChangeLog7
-rw-r--r--kde-base/akonadi/akonadi-4.3.4.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/kde-base/akonadi/ChangeLog b/kde-base/akonadi/ChangeLog
index 5093edc5de2c..f0190c3b72f9 100644
--- a/kde-base/akonadi/ChangeLog
+++ b/kde-base/akonadi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/akonadi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.42 2009/11/30 06:54:53 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/ChangeLog,v 1.43 2009/12/01 09:55:21 wired Exp $
+
+*akonadi-4.3.4 (01 Dec 2009)
+
+ 01 Dec 2009; Alex Alexander <wired@gentoo.org> +akonadi-4.3.4.ebuild:
+ Version bump
30 Nov 2009; Joseph Jezak <josejx@gentoo.org> akonadi-4.3.3.ebuild:
Marked ppc/ppc64 stable for bug #292455.
diff --git a/kde-base/akonadi/akonadi-4.3.4.ebuild b/kde-base/akonadi/akonadi-4.3.4.ebuild
new file mode 100644
index 000000000000..8e2f87abf159
--- /dev/null
+++ b/kde-base/akonadi/akonadi-4.3.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akonadi/akonadi-4.3.4.ebuild,v 1.1 2009/12/01 09:55:21 wired Exp $
+
+EAPI="2"
+
+if [[ ${PV} = *9999* ]]; then
+ KMNAME="kdepim"
+ eclass="kde4-meta"
+else
+ KMNAME="kdepim-runtime"
+ eclass="kde4-base"
+fi
+inherit ${eclass}
+
+DESCRIPTION="An extensible cross-desktop storage service for PIM data and meta data"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# add when libmapi becomes available with an ebuild
+#exchange
+IUSE="debug +semantic-desktop"
+
+# add when libmapi becomes available with an ebuild
+#exchange? ( net-libs/libmapi )
+DEPEND="
+ dev-libs/boost
+ dev-libs/libxml2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ >=app-office/akonadi-server-1.2.1
+"
+
+# @since 4.3 - blocks kdemaildir - no longer provided (it's in akonadi now)
+add_blocker kdemaildir
+add_blocker kdepim-kresources '<4.2.95'
+
+[[ ${KMNAME} = "kdepim-runtime" ]] && S="${WORKDIR}/${KMNAME}-${PV}"
+
+src_prepare() {
+ local pref="${S}"
+ [[ ${KMNAME} != "kdepim-runtime" ]] && pref="${S}/${PN}"
+ if ! use semantic-desktop; then
+ sed -i -e "s/add_subdirectory( nepomuktag )//"\
+ "${pref}"/resources/CMakeLists.txt\
+ || die "Failed to disable nepomuktag"
+ fi
+
+ ${eclass}_src_prepare
+}
+
+src_configure() {
+ # Set the dbus dirs, otherwise it searches in KDEDIR
+ mycmakeargs="${mycmakeargs}
+ -DAKONADI_DBUS_INTERFACES_INSTALL_DIR=/usr/share/dbus-1/interfaces
+ -DAKONADI_DBUS_SERVICES_INSTALL_DIR=/usr/share/dbus-1/services"
+ # replace with $(cmake-utils_use_with exchange OpenChange) when libmapi becomes available with an ebuild
+ mycmakeargs="${mycmakeargs}
+ -DWITH_LibXslt=ON
+ -DWITH_OpenChange=OFF
+ -DWITH_GNOKII=OFF
+ -DWITH_GLIB2=OFF
+ -DWITH_OpenSync=OFF
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ ${eclass}_src_configure
+}
+
+src_test() {
+ # disable broken tests
+ sed -i -e '/kcalserializertest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/plugins/tests/CMakeLists.txt || \
+ die "sed to disable kcalserializertest failed."
+ sed -i -e '/kresmigrationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/migration/kres/tests/CMakeLists.txt || \
+ die "sed to disable kresmigrationtest failed."
+
+ ${eclass}_src_test
+}
+
+src_install() {
+ ${eclass}_src_install
+ # colliding files with nepomuk
+ rm -rf "${D}"/${KDEDIR}/share/apps/nepomuk/ontologies/n{m,c}o.{desktop,trig}
+}