summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-08-16 02:54:27 +0000
committerAchim Gottinger <achim@gentoo.org>2001-08-16 02:54:27 +0000
commit67a45a57a7d43ebdd983896937656ccc120f8ce9 (patch)
tree8ee9a256379c5006109335c15647f02d78e3ba7d /kde-apps
parentmodified some startup paramters to add apache style log file generation. (diff)
downloadgentoo-2-67a45a57a7d43ebdd983896937656ccc120f8ce9.tar.gz
gentoo-2-67a45a57a7d43ebdd983896937656ccc120f8ce9.tar.bz2
gentoo-2-67a45a57a7d43ebdd983896937656ccc120f8ce9.zip
*** empty log message ***
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/kdeadmin/files/digest-kdeadmin-2.21
-rw-r--r--kde-apps/kdeadmin/kdeadmin-2.2.ebuild51
-rw-r--r--kde-apps/kdegraphics/files/digest-kdegraphics-2.21
-rw-r--r--kde-apps/kdegraphics/kdegraphics-2.2.ebuild56
-rw-r--r--kde-apps/kdemultimedia/files/digest-kdemultimedia-2.21
-rw-r--r--kde-apps/kdemultimedia/kdemultimedia-2.2.ebuild96
6 files changed, 206 insertions, 0 deletions
diff --git a/kde-apps/kdeadmin/files/digest-kdeadmin-2.2 b/kde-apps/kdeadmin/files/digest-kdeadmin-2.2
new file mode 100644
index 000000000000..1a4a2ea5d6c7
--- /dev/null
+++ b/kde-apps/kdeadmin/files/digest-kdeadmin-2.2
@@ -0,0 +1 @@
+MD5 13ee99fa898fc177dd65dc2564fefd60 kdeadmin-2.2.tar.bz2
diff --git a/kde-apps/kdeadmin/kdeadmin-2.2.ebuild b/kde-apps/kdeadmin/kdeadmin-2.2.ebuild
new file mode 100644
index 000000000000..1675466732fc
--- /dev/null
+++ b/kde-apps/kdeadmin/kdeadmin-2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+V=2.2
+A=${PN}-${V}.tar.bz2
+S=${WORKDIR}/${PN}-${V}
+DESCRIPTION="KDE ${V} - Administration"
+SRC_PATH="kde/stable/${V}/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.fh-heilbronn.de/pub/mirrors/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=kde-base/kdelibs-${PV}
+ >=app-arch/rpm-3.0.5
+ pam? ( >=sys-libs/pam-0.72 )"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ local myconf
+ if [ "`use pam`" ]
+ then
+ myconf="--with-pam"
+ else
+ myconf="--without-pam"
+ fi
+ if [ "`use qtmt`" ]
+ then
+ myconf="$myconf --enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ QTBASE=/usr/X11R6/lib/qt
+ try ./configure --prefix=$KDEDIR --host=${CHOST} \
+ --with-qt-dir=$QTBASE \
+ --with-rpm --with-xinerama $myconf
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc AUTHORS COPYING README
+}
+
+
+
diff --git a/kde-apps/kdegraphics/files/digest-kdegraphics-2.2 b/kde-apps/kdegraphics/files/digest-kdegraphics-2.2
new file mode 100644
index 000000000000..69cb98089921
--- /dev/null
+++ b/kde-apps/kdegraphics/files/digest-kdegraphics-2.2
@@ -0,0 +1 @@
+MD5 32125d00243c884017daa4345b87e2fe kdegraphics-2.2.tar.bz2
diff --git a/kde-apps/kdegraphics/kdegraphics-2.2.ebuild b/kde-apps/kdegraphics/kdegraphics-2.2.ebuild
new file mode 100644
index 000000000000..617541736fbf
--- /dev/null
+++ b/kde-apps/kdegraphics/kdegraphics-2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+V=2.2
+A=${PN}-${V}.tar.bz2
+S=${WORKDIR}/${PN}-${V}
+DESCRIPTION="KDE ${V} - Graphics"
+SRC_PATH="kde/stable/${V}/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.fh-heilbronn.de/pub/mirrors/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org"
+
+DEPEND=">=kde-base/kdelibs-${PV} sys-devel/perl
+ tex? ( >=app-text/tetex-1.0.7 )
+ gphoto2? ( >=gnome-apps/gphoto-2.0_beta1 >=media-libs/libgpio-20010607 )"
+
+RDEPEND=">=kde-base/kdelibs-${PV} gphoto2? ( >=gnome-apps/gphoto-2.0_beta1 >=media-libs/libgpio-20010607 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ QTBASE=/usr/X11R6/lib/qt
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ if [ "`use gphoto2`" ] ; then
+ myconf="$myconf --with-gphoto2-includes=/usr/include/gphoto2 --with-gphoto2-libraries=/usr/lib/gphoto2"
+ else
+ myconf="$myconf --without-kamera"
+ fi
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} \
+ --with-qt-dir=$QTBASE $myconf --with-xinerama
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc AUTHORS COPYING README ChangeLog
+}
+
+
+
+
diff --git a/kde-apps/kdemultimedia/files/digest-kdemultimedia-2.2 b/kde-apps/kdemultimedia/files/digest-kdemultimedia-2.2
new file mode 100644
index 000000000000..164f9cb7e505
--- /dev/null
+++ b/kde-apps/kdemultimedia/files/digest-kdemultimedia-2.2
@@ -0,0 +1 @@
+MD5 530a05d3671aaf093805083658dd8030 kdemultimedia-2.2.tar.bz2
diff --git a/kde-apps/kdemultimedia/kdemultimedia-2.2.ebuild b/kde-apps/kdemultimedia/kdemultimedia-2.2.ebuild
new file mode 100644
index 000000000000..3b9db7564712
--- /dev/null
+++ b/kde-apps/kdemultimedia/kdemultimedia-2.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+V=2.2
+A=${PN}-${V}.tar.bz2
+S=${WORKDIR}/${PN}-${V}
+DESCRIPTION="KDE ${V} - Multimedia"
+SRC_PATH="kde/stable/${V}/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.fh-heilbronn.de/pub/mirrors/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org"
+
+DEPEND=">=kde-base/kdelibs-${PV}
+ >=sys-libs/ncurses-5.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-libs/libvorbis-1.0_beta4
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ nas? ( >=media-sound/nas-1.4.1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ gtk? ( >=x11-libs/gtk+-1.2.10 )
+ slang? ( >=sys-libs/slang-1.4.4 )"
+# tcltk? ( =dev-lang/tcl-tk.8.0.5-r2 )
+
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ local myconf
+ local myaudio
+ local myinteface
+ myaudio="--enable-audio=oss"
+ myinterface="--enable-interface=xaw,ncurses"
+ if [ -n "`use alsa`" ]
+ then
+ myconf="--with-alsa"
+ myaudio="$myaudio,alsa"
+ fi
+ if [ -n "`use nas`" ]
+ then
+ myaudio="$myaudio,nas"
+ fi
+ if [ -n "`use esd`" ]
+ then
+ myaudio="$myaudio,esd"
+ fi
+ if [ -n "`use motif`" ]
+ then
+ myinterface="$myinterface,motif"
+ fi
+ if [ -n "`use gtk`" ]
+ then
+ myinterface="$myinterface,gtk"
+ fi
+# tcl tk does not work
+# if [ "`use tcltk`" ]
+# then
+# myinterface="$myinterface,tcltk"
+# fi
+ if [ -n "`use slang`" ]
+ then
+ myinterface="$myinterface,slang"
+ fi
+ if [ "`use qtmt`" ]
+ then
+ myconf="$myconf --enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ QTBASE=/usr/X11R6/lib/qt
+# export CFLAGS="${CFLAGS/-march=i?86/}"
+# export CXXFLAGS="${CXXFLAGS/-march=i?86/}"
+# unset CFLAGS
+# unset CXXFLAGS
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} \
+ --with-qt-dir=$QTBASE --with-xinerama \
+ $myconf $myaudio $myinterface
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc AUTHORS ChangeLog COPYING README*
+}
+
+
+
+
+
+
+