summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-06-23 20:24:47 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-06-23 20:24:47 +0000
commit9522200650f7fb056366fd133a760864986f3f07 (patch)
tree32d3e6563fcef5c383a37798579180d8f79256e9 /gnustep-base
parentstable x86, bug 324735 (diff)
downloadgentoo-2-9522200650f7fb056366fd133a760864986f3f07.tar.gz
gentoo-2-9522200650f7fb056366fd133a760864986f3f07.tar.bz2
gentoo-2-9522200650f7fb056366fd133a760864986f3f07.zip
Bugfix release bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-base/ChangeLog8
-rw-r--r--gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-base/ChangeLog b/gnustep-base/gnustep-base/ChangeLog
index c18160b00b9b..97318599a568 100644
--- a/gnustep-base/gnustep-base/ChangeLog
+++ b/gnustep-base/gnustep-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-base
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.95 2010/05/19 15:33:12 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/ChangeLog,v 1.96 2010/06/23 20:24:47 voyageur Exp $
+
+*gnustep-base-1.20.1 (23 Jun 2010)
+
+ 23 Jun 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-base-1.20.1.ebuild:
+ Bugfix release bump
19 May 2010; Bernard Cafarelli <voyageur@gentoo.org>
-gnustep-base-1.18.0-r5.ebuild, gnustep-base-1.20.0.ebuild:
diff --git a/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild b/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild
new file mode 100644
index 000000000000..d6a1b517bf69
--- /dev/null
+++ b/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-base/gnustep-base-1.20.1.ebuild,v 1.1 2010/06/23 20:24:47 voyageur Exp $
+
+EAPI="3"
+
+inherit gnustep-base
+
+DESCRIPTION="A library of general-purpose, non-graphical Objective C objects."
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+IUSE="+libffi gnutls zeroconf"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-make-2.0.8
+ !libffi? ( dev-libs/ffcall
+ gnustep-base/gnustep-make[-native-exceptions] )
+ libffi? ( virtual/libffi )
+ gnutls? ( net-libs/gnutls )
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/libxslt-1.1
+ >=dev-libs/gmp-4.1
+ >=dev-libs/openssl-0.9.7
+ >=sys-libs/zlib-1.2
+ zeroconf? ( || (
+ net-dns/avahi[mdnsresponder-compat]
+ net-misc/mDNSResponder ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ egnustep_env
+
+ local myconf
+ if use libffi;
+ then
+ myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
+ else
+ myconf="--disable-libffi --enable-ffcall"
+ fi
+
+ myconf="$myconf $(use_enable gnutls tls)"
+ myconf="$myconf $(use_enable zeroconf)"
+ myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
+ myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
+ myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf"
+
+ econf $myconf || die "configure failed"
+}
+
+src_install() {
+ # We need to set LD_LIBRARY_PATH because the doc generation program
+ # uses the gnustep-base libraries. Since egnustep_env "cleans the
+ # environment" including our LD_LIBRARY_PATH, we're left no choice
+ # but doing it like this.
+
+ egnustep_env
+ egnustep_install
+
+ if use doc ; then
+ export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
+ egnustep_doc
+ fi
+ egnustep_install_config
+
+ dodir /etc/revdep-rebuild
+ sed -e 's|$GNUSTEP_SEARCH_DIRS|'"$GNUSTEP_SYSTEM_LIBRARIES $GNUSTEP_SYSTEM_TOOLS $GNUSTEP_LOCAL_LIBRARIES $GNUSTEP_LOCAL_TOOLS"'|' \
+ "${FILESDIR}"/50-gnustep-revdep \
+ > "${ED}/etc/revdep-rebuild/50-gnustep-revdep"
+}
+
+pkg_postinst() {
+ ewarn "The shared library version has changed in this release."
+ ewarn "You will need to recompile all Applications/Tools/etc in order"
+ ewarn "to use this library."
+ ewarn "Run:"
+ ewarn "revdep-rebuild --library \"libgnustep-base.so.1.1[0-6]\""
+}