summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-05-10 18:42:06 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-05-10 18:42:06 +0000
commit311882fade6742de06748a5965f2933c35ec1e68 (patch)
tree76aaf786535b778125af6d46ac3eef85ee82536e /gnustep-base
parentppc stable #318259 (diff)
downloadgentoo-2-311882fade6742de06748a5965f2933c35ec1e68.tar.gz
gentoo-2-311882fade6742de06748a5965f2933c35ec1e68.tar.bz2
gentoo-2-311882fade6742de06748a5965f2933c35ec1e68.zip
Stable release bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog8
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.4.0.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index ac2386b6f198..659e3363b3cc 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-make
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.88 2010/03/09 18:52:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.89 2010/05/10 18:42:06 voyageur Exp $
+
+*gnustep-make-2.4.0 (10 May 2010)
+
+ 10 May 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-make-2.4.0.ebuild:
+ Stable release bump
*gnustep-make-2.2.0-r1 (09 Mar 2010)
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.4.0.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.4.0.ebuild
new file mode 100644
index 000000000000..84090960f83e
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-2.4.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.4.0.ebuild,v 1.1 2010/05/10 18:42:06 voyageur Exp $
+
+EAPI="3"
+
+inherit gnustep-base eutils prefix
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="native-exceptions"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=sys-devel/gcc-3.3[objc]
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1-destdir.patch
+ cp "${FILESDIR}"/gnustep-3.{csh,sh} "${T}"/
+ eprefixify "${T}"/gnustep-3.{csh,sh}
+}
+
+src_configure() {
+ econf \
+ --prefix="${GNUSTEP_PREFIX}" \
+ --with-layout=gnustep \
+ --with-config-file="${EPREFIX}"/etc/GNUstep/GNUstep.conf \
+ $(use_enable native-exceptions native-objc-exceptions) \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake || die "compilation failed"
+ # Prepare doc here (needed when no gnustep-make is already installed)
+ if use doc ; then
+ # If a gnustep-1 environment is set
+ unset GNUSTEP_MAKEFILES
+ cd Documentation
+ emake all install || die "doc make has failed"
+ cd ..
+ fi
+}
+
+src_install() {
+ # Get GNUSTEP_* variables
+ . ./GNUstep.conf
+
+ local make_eval
+ use debug || make_eval="${make_eval} debug=no"
+ make_eval="${make_eval} verbose=yes"
+
+ emake ${make_eval} DESTDIR="${D}" install || die "install has failed"
+
+ # Copy the documentation
+ if use doc ; then
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -r Documentation/tmp-installation/System/Library/Documentation \
+ "${ED}"${GNUSTEP_SYSTEM_LIBRARY}
+ fi
+
+ dodoc FAQ README RELEASENOTES
+
+ exeinto /etc/profile.d
+ doexe "${T}"/gnustep-3.sh
+ doexe "${T}"/gnustep-3.csh
+
+ dodir /etc/env.d
+ cat <<- EOF > "${ED}"/etc/env.d/99gnustep
+PATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+ROOTPATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+LDPATH=${GNUSTEP_SYSTEM_LIBRARIES}:${GNUSTEP_LOCAL_LIBRARIES}
+MANPATH=${GNUSTEP_SYSTEM_DOC_MAN}:${GNUSTEP_LOCAL_DOC_MAN}
+INFOPATH=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+INFODIR=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+EOF
+}