summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-11-23 17:18:46 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-11-23 17:18:46 +0000
commit40a4a058f54c3a4ea25cee613dc6fe757d89c4f2 (patch)
tree352eadc727d21f79ae6839d118bb09eb0be2e766 /gnome-extra/libgda
parentmark stable (Manifest recommit) (diff)
downloadgentoo-2-40a4a058f54c3a4ea25cee613dc6fe757d89c4f2.tar.gz
gentoo-2-40a4a058f54c3a4ea25cee613dc6fe757d89c4f2.tar.bz2
gentoo-2-40a4a058f54c3a4ea25cee613dc6fe757d89c4f2.zip
added firebird provider patch (#71708)
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog6
-rw-r--r--gnome-extra/libgda/files/libgda-1.0.4-firebird-provider.patch40
-rw-r--r--gnome-extra/libgda/libgda-1.0.4.ebuild5
3 files changed, 48 insertions, 3 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 3179eef7ae9d..06fa63c3d0d5 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.52 2004/10/29 08:16:58 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.53 2004/11/23 17:18:46 liquidx Exp $
+
+ 23 Nov 2004; Alastair Tse <liquidx@gentoo.org>
+ +files/libgda-1.0.4-firebird-provider.patch, libgda-1.0.4.ebuild:
+ added firebird provider patch (#71708)
29 Oct 2004; Joseph Jezak <josejx@gentoo.org> libgda-1.0.3.ebuild:
Keyworded ppc to fix compiling with gcc 3.4
diff --git a/gnome-extra/libgda/files/libgda-1.0.4-firebird-provider.patch b/gnome-extra/libgda/files/libgda-1.0.4-firebird-provider.patch
new file mode 100644
index 000000000000..cfede126522a
--- /dev/null
+++ b/gnome-extra/libgda/files/libgda-1.0.4-firebird-provider.patch
@@ -0,0 +1,40 @@
+--- providers/firebird/gda-firebird-provider.c_old 2004-11-19 08:23:39.164945104 +0900
++++ providers/firebird/gda-firebird-provider.c 2004-11-19 08:24:18.867909336 +0900
+@@ -346,6 +346,20 @@
+ return model;
+ }
+
++isc_tr_handle *
++gda_firebird_command_get_transaction (GdaCommand *cmd)
++{
++ GdaTransaction *xaction;
++ isc_tr_handle *itr;
++
++ xaction = gda_command_get_transaction (cmd);
++ if (!GDA_IS_TRANSACTION (xaction))
++ return NULL;
++
++ itr = g_object_get_data (G_OBJECT (xaction), TRANSACTION_DATA);
++ return itr;
++}
++
+ /* execute_command handler for the GdaFirebirdProvider class */
+ static GList *
+ gda_firebird_provider_execute_command (GdaServerProvider *provider,
+@@ -547,16 +561,3 @@
+ gda_connection_add_error (cnc, error);
+ }
+
+-isc_tr_handle *
+-gda_firebird_command_get_transaction (GdaCommand *cmd)
+-{
+- GdaTransaction *xaction;
+- isc_tr_handle *itr;
+-
+- xaction = gda_command_get_transaction (cmd);
+- if (!GDA_IS_TRANSACTION (xaction))
+- return NULL;
+-
+- itr = g_object_get_data (G_OBJECT (xaction), TRANSACTION_DATA);
+- return itr;
+-}
diff --git a/gnome-extra/libgda/libgda-1.0.4.ebuild b/gnome-extra/libgda/libgda-1.0.4.ebuild
index 75aae774468a..490c920aee4e 100644
--- a/gnome-extra/libgda/libgda-1.0.4.ebuild
+++ b/gnome-extra/libgda/libgda-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.0.4.ebuild,v 1.3 2004/08/06 01:34:08 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.0.4.ebuild,v 1.4 2004/11/23 17:18:46 liquidx Exp $
inherit gnome2 eutils
@@ -49,7 +49,8 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-1.0.3-gcc3.4.patch
# freetds patch (#48611)
epatch ${FILESDIR}/${PN}-1.0.4-freetds-0.6x.patch
-
+ # firebird function reorder (#71708)
+ epatch ${FILESDIR}/${PN}-1.0.4-firebird-provider.patch
}
src_compile() {