summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-24 07:57:16 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-24 07:57:16 +0000
commite37dc21099274264247bc4b814d144ccab27ffc2 (patch)
treebccf4fe5a73393bf3aad7c8e1ea78e561adc8766 /gnome-extra/gnome-do
parentRemove old version. (diff)
downloadgentoo-2-e37dc21099274264247bc4b814d144ccab27ffc2.tar.gz
gentoo-2-e37dc21099274264247bc4b814d144ccab27ffc2.tar.bz2
gentoo-2-e37dc21099274264247bc4b814d144ccab27ffc2.zip
Fix compilation with mono 2.8.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gnome-do')
-rw-r--r--gnome-extra/gnome-do/ChangeLog6
-rw-r--r--gnome-extra/gnome-do/files/gnome-do-0.8.3.1-mono-2.8.patch70
-rw-r--r--gnome-extra/gnome-do/gnome-do-0.8.3.1.ebuild6
3 files changed, 80 insertions, 2 deletions
diff --git a/gnome-extra/gnome-do/ChangeLog b/gnome-extra/gnome-do/ChangeLog
index 1739df497e4c..fd61790f5a57 100644
--- a/gnome-extra/gnome-do/ChangeLog
+++ b/gnome-extra/gnome-do/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/gnome-do
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/ChangeLog,v 1.22 2010/10/09 09:29:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/ChangeLog,v 1.23 2010/10/24 07:57:16 graaff Exp $
+
+ 24 Oct 2010; Hans de Graaff <graaff@gentoo.org> gnome-do-0.8.3.1.ebuild,
+ +files/gnome-do-0.8.3.1-mono-2.8.patch:
+ Fix compilation with mono 2.8.
09 Oct 2010; Hans de Graaff <graaff@gentoo.org> -gnome-do-0.8.2.ebuild:
Remove old version.
diff --git a/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-mono-2.8.patch b/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-mono-2.8.patch
new file mode 100644
index 000000000000..2e492a87edde
--- /dev/null
+++ b/gnome-extra/gnome-do/files/gnome-do-0.8.3.1-mono-2.8.patch
@@ -0,0 +1,70 @@
+https://bugs.launchpad.net/do/+bug/634556
+https://bugs.launchpad.net/do/+bug/634550
+
+Patches by Andrew Jorgensen
+
+--- Do.Interface.Linux.Docky/src/Docky.Interface/TextRenderContext.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do.Interface.Linux.Docky/src/Docky.Interface/TextRenderContext.cs 2010-09-01 13:11:53.000000000 -0600
+@@ -45,12 +45,12 @@
+
+ public TextRenderContext (Cairo.Context cr, string text, int width)
+ {
+- Context = cr;
+- Text = text;
+- Alignment = Alignment.Left;
+- MaximumWidth = width;
+- WrapMode = WrapMode.WordChar;
+- EllipsizeMode = EllipsizeMode.End;
++ this.Context = cr;
++ this.Text = text;
++ this.Alignment = Alignment.Left;
++ this.MaximumWidth = width;
++ this.WrapMode = WrapMode.WordChar;
++ this.EllipsizeMode = EllipsizeMode.End;
+ }
+ }
+ }
+--- Do/gtk-gui/Do.UI.ColorConfigurationWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.ColorConfigurationWidget.cs 2010-09-01 13:58:26.000000000 -0600
+@@ -57,7 +57,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.ColorConfigurationWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.ColorConfigurationWidget";
++ base.Name = "Do.UI.ColorConfigurationWidget";
+ // Container child Do.UI.ColorConfigurationWidget.Gtk.Container+ContainerChild
+ this.vbox2 = new Gtk.VBox();
+ this.vbox2.Name = "vbox2";
+--- Do/gtk-gui/Do.UI.GeneralPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.GeneralPreferencesWidget.cs 2010-09-01 13:58:43.000000000 -0600
+@@ -33,7 +33,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.GeneralPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.GeneralPreferencesWidget";
++ base.Name = "Do.UI.GeneralPreferencesWidget";
+ // Container child Do.UI.GeneralPreferencesWidget.Gtk.Container+ContainerChild
+ this.alignment4 = new Gtk.Alignment(0.5F, 0.5F, 1F, 1F);
+ this.alignment4.Name = "alignment4";
+--- Do/gtk-gui/Do.UI.KeybindingsPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.KeybindingsPreferencesWidget.cs 2010-09-01 13:59:08.000000000 -0600
+@@ -27,7 +27,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.KeybindingsPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.KeybindingsPreferencesWidget";
++ base.Name = "Do.UI.KeybindingsPreferencesWidget";
+ // Container child Do.UI.KeybindingsPreferencesWidget.Gtk.Container+ContainerChild
+ this.vbox2 = new Gtk.VBox();
+ this.vbox2.Name = "vbox2";
+--- Do/gtk-gui/Do.UI.ManagePluginsPreferencesWidget.cs 2009-06-28 18:19:29.000000000 -0600
++++ Do/gtk-gui/Do.UI.ManagePluginsPreferencesWidget.cs 2010-09-01 13:59:19.000000000 -0600
+@@ -43,7 +43,7 @@
+ Stetic.Gui.Initialize(this);
+ // Widget Do.UI.ManagePluginsPreferencesWidget
+ Stetic.BinContainer.Attach(this);
+- this.Name = "Do.UI.ManagePluginsPreferencesWidget";
++ base.Name = "Do.UI.ManagePluginsPreferencesWidget";
+ // Container child Do.UI.ManagePluginsPreferencesWidget.Gtk.Container+ContainerChild
+ this.vbox3 = new Gtk.VBox();
+ this.vbox3.Name = "vbox3";
diff --git a/gnome-extra/gnome-do/gnome-do-0.8.3.1.ebuild b/gnome-extra/gnome-do/gnome-do-0.8.3.1.ebuild
index 336c3ac41f4d..e565879f1557 100644
--- a/gnome-extra/gnome-do/gnome-do-0.8.3.1.ebuild
+++ b/gnome-extra/gnome-do/gnome-do-0.8.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/gnome-do-0.8.3.1.ebuild,v 1.3 2010/07/10 07:48:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do/gnome-do-0.8.3.1.ebuild,v 1.4 2010/10/24 07:57:16 graaff Exp $
# TODO: GNOME Do defaults to a debug build; to disable, --enable-release must
# be passed. However, when doing this the build fails; figure out why.
@@ -42,6 +42,10 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-mono-2.8.patch
+}
+
src_configure() {
gnome2_src_configure
}