summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-07 11:40:13 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-07 11:40:13 +0000
commite5f8597da8d2f74492fbe0a6e812bbcbecdb0457 (patch)
tree03a50bf9ebc37eaf62a8035853009c42ffc6c6fb /gnome-extra/evolution-exchange
parentLastrite dev-php5/mongo (diff)
downloadgentoo-2-e5f8597da8d2f74492fbe0a6e812bbcbecdb0457.tar.gz
gentoo-2-e5f8597da8d2f74492fbe0a6e812bbcbecdb0457.tar.bz2
gentoo-2-e5f8597da8d2f74492fbe0a6e812bbcbecdb0457.zip
Version bump with some bugfixes.
(Portage version: 2.1.9.36/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/evolution-exchange')
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog10
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.32.2.ebuild57
2 files changed, 65 insertions, 2 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index 567d3f7a66c2..56ada0a4fba3 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-exchange
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.129 2010/11/16 20:34:13 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.130 2011/02/07 11:40:13 pacho Exp $
+
+*evolution-exchange-2.32.2 (07 Feb 2011)
+
+ 07 Feb 2011; Pacho Ramos <pacho@gentoo.org>
+ +evolution-exchange-2.32.2.ebuild:
+ Version bump with some bugfixes.
*evolution-exchange-2.32.1 (16 Nov 2010)
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.32.2.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.32.2.ebuild
new file mode 100644
index 000000000000..cc5e5761c0da
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.32.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.32.2.ebuild,v 1.1 2011/02/07 11:40:13 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://projects.gnome.org/evolution/"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-${PV}:2.0
+ >=gnome-extra/evolution-data-server-${PV}[ldap,kerberos]
+ >=dev-libs/glib-2.16:2
+ >=x11-libs/gtk+-2.20:2
+ >=gnome-base/gconf-2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ >=net-nds/openldap-2.1.30-r2
+ virtual/krb5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-krb5=/usr
+ --with-openldap
+ --disable-static
+ --disable-maintainer-mode
+ --disable-gtk3
+ $(use_enable debug e2k-debug)
+ $(use_with static static-ldap)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/^\(AM_CPPFLAGS="\)$WARNING_FLAGS/\1/' \
+ -i configure.ac configure || die "sed 1 failed"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "la files removal failed"
+}