summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-19 17:09:55 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-19 17:09:55 +0000
commitf693051feb6cb2bbd11c8d63d29cc7ae61c23509 (patch)
treefdb38d116fa21aad4e53824b5aa4b022f2f50f56 /gnome-base
parentVersion bump (diff)
downloadgentoo-2-f693051feb6cb2bbd11c8d63d29cc7ae61c23509.tar.gz
gentoo-2-f693051feb6cb2bbd11c8d63d29cc7ae61c23509.tar.bz2
gentoo-2-f693051feb6cb2bbd11c8d63d29cc7ae61c23509.zip
Updated to version 2.0.0 and dep update as well.
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/librsvg/ChangeLog5
-rw-r--r--gnome-base/librsvg/files/digest-librsvg-2.0.01
-rw-r--r--gnome-base/librsvg/librsvg-2.0.0.ebuild48
3 files changed, 53 insertions, 1 deletions
diff --git a/gnome-base/librsvg/ChangeLog b/gnome-base/librsvg/ChangeLog
index 6460a57551b4..3c3f335bafb0 100644
--- a/gnome-base/librsvg/ChangeLog
+++ b/gnome-base/librsvg/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for gnome-base/librsvg
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.2 2002/05/22 22:06:10 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.3 2002/06/19 17:09:55 stroke Exp $
+*librsvg-2.0.0 (19 May 2002)
+ 22 May 2002; Gabriele Giorgetti <stroke@gentoo.org> librsvg-2.0.0.ebuild:
+ Yay! version 2.0.0
*librsvg-1.1.6-r2 (22 May 2002)
22 May 2002; Spider <spider@gentoo.org> librsvg-1.1.6-r2.ebuild:
diff --git a/gnome-base/librsvg/files/digest-librsvg-2.0.0 b/gnome-base/librsvg/files/digest-librsvg-2.0.0
new file mode 100644
index 000000000000..e47fe96e2a31
--- /dev/null
+++ b/gnome-base/librsvg/files/digest-librsvg-2.0.0
@@ -0,0 +1 @@
+MD5 6a216a7f75956ce936755f365be1a16d librsvg-2.0.0.tar.bz2 154789
diff --git a/gnome-base/librsvg/librsvg-2.0.0.ebuild b/gnome-base/librsvg/librsvg-2.0.0.ebuild
new file mode 100644
index 000000000000..2b11a107703f
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.0.0.ebuild,v 1.1 2002/06/19 17:09:55 stroke Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="rendering svg library"
+SRC_URI="ftp://ftp.gnome.org/pub/gnome/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="2"
+LICENSE="GPL-2 LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=media-libs/libart_lgpl-2.3.8-r1
+ >=dev-libs/libxml2-2.4.17
+ >=x11-libs/pango-1.0.3"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-platform-gnome-2 \
+ --enable-debug=yes || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYIN* README INSTALL NEWS TODO
+}
+
+