summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-14 10:43:43 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-14 10:43:43 +0000
commitf68a81248bc05e58519bdf6f872ef40af41c03c8 (patch)
treef6af6942d0c118708bf04571c014766d8ca8d319 /gnome-base
parentUse correct language packs. (diff)
downloadgentoo-2-f68a81248bc05e58519bdf6f872ef40af41c03c8.tar.gz
gentoo-2-f68a81248bc05e58519bdf6f872ef40af41c03c8.tar.bz2
gentoo-2-f68a81248bc05e58519bdf6f872ef40af41c03c8.zip
Fix crash in date and time panel with gnome-settings-daemon[-policykit] (bug #403527, thanks to Johann Schmitz for reporting). Add a patch to respect LINGUAS for timezone translations. Drop old.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-control-center/ChangeLog12
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.2.2-timezone-free.patch31
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.2.2-timezones-linguas.patch39
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-3.2.2-r1.ebuild (renamed from gnome-base/gnome-control-center/gnome-control-center-3.2.1.ebuild)17
4 files changed, 95 insertions, 4 deletions
diff --git a/gnome-base/gnome-control-center/ChangeLog b/gnome-base/gnome-control-center/ChangeLog
index 5748aaf0af8e..f4efdac4f085 100644
--- a/gnome-base/gnome-control-center/ChangeLog
+++ b/gnome-base/gnome-control-center/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnome-base/gnome-control-center
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/ChangeLog,v 1.96 2012/02/14 04:55:31 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/ChangeLog,v 1.97 2012/02/14 10:43:43 tetromino Exp $
+
+*gnome-control-center-3.2.2-r1 (14 Feb 2012)
+
+ 14 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -gnome-control-center-3.2.1.ebuild, +gnome-control-center-3.2.2-r1.ebuild,
+ +files/gnome-control-center-3.2.2-timezone-free.patch,
+ +files/gnome-control-center-3.2.2-timezones-linguas.patch:
+ Fix crash in date and time panel with gnome-settings-daemon[-policykit] (bug
+ #403527, thanks to Johann Schmitz for reporting). Add a patch to respect
+ LINGUAS for timezone translations. Drop old.
14 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
gnome-control-center-3.2.1.ebuild, gnome-control-center-3.2.2.ebuild:
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.2.2-timezone-free.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.2.2-timezone-free.patch
new file mode 100644
index 000000000000..3d02ca328fd7
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.2.2-timezone-free.patch
@@ -0,0 +1,31 @@
+From 0c5f7f64d6f8ffd24eda8d6115f54189a18e191e Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 14 Feb 2012 04:21:05 -0500
+Subject: [PATCH] datetime: Make sure timezone is initialized in
+ get_timezone_cb()
+
+If date_time_mechanism_call_get_timezone_finish() fails, timezone is
+left uninitialized, and attempting to free it at the end of
+get_timezone_cb() results in a crash.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=670042
+---
+ panels/datetime/cc-datetime-panel.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/panels/datetime/cc-datetime-panel.c b/panels/datetime/cc-datetime-panel.c
+index 555eaaa..413986e 100644
+--- a/panels/datetime/cc-datetime-panel.c
++++ b/panels/datetime/cc-datetime-panel.c
+@@ -553,7 +553,7 @@ get_timezone_cb (GObject *source,
+ {
+ CcDateTimePanel *self = user_data;
+ GtkWidget *widget;
+- gchar *timezone;
++ gchar *timezone = NULL;
+ GError *error;
+
+ error = NULL;
+--
+1.7.8.4
+
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.2.2-timezones-linguas.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.2.2-timezones-linguas.patch
new file mode 100644
index 000000000000..4473f57cead6
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.2.2-timezones-linguas.patch
@@ -0,0 +1,39 @@
+From 58d3dd9362ede7b0644242dce55b413a49034949 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 14 Feb 2012 05:07:58 -0500
+Subject: [PATCH] datetime: respect LINGUAS for timezone translations
+
+https://bugzilla.gnome.org/show_bug.cgi?id=670051
+---
+ panels/datetime/po-timezones/Makefile.am | 12 ++++++++++--
+ 1 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/panels/datetime/po-timezones/Makefile.am b/panels/datetime/po-timezones/Makefile.am
+index 0845a51..33fd5e0 100644
+--- a/panels/datetime/po-timezones/Makefile.am
++++ b/panels/datetime/po-timezones/Makefile.am
+@@ -1,4 +1,12 @@
+-CATALOGS = $(patsubst %.po,%.mo,$(wildcard *.po))
++PO_LINGUAS = $(subst .po,,$(wildcard *.po))
++
++USER_LINGUAS = $(filter $(LINGUAS),$(PO_LINGUAS))
++
++USE_LINGUAS = $(shell if test -n "$(USER_LINGUAS)" -o -n "$(LINGUAS)"; then LLINGUAS="$(USER_LINGUAS)"; else LLINGUAS="$(PO_LINGUAS)"; fi; for lang in $$LLINGUAS; do printf "$$lang "; done)
++
++ALL_CATALOGS = $(patsubst %.po,%.mo,$(wildcard *.po))
++
++CATALOGS = $(USE_LINGUAS:%=%.mo)
+
+ all: $(CATALOGS)
+
+@@ -20,6 +28,6 @@ install: $(CATALOGS)
+
+ EXTRA_DIST=$(wildcard *.po)
+
+-CLEANFILES = $(CATALOGS)
++CLEANFILES = $(ALL_CATALOGS)
+
+ -include $(top_srcdir)/git.mk
+--
+1.7.8.4
+
diff --git a/gnome-base/gnome-control-center/gnome-control-center-3.2.1.ebuild b/gnome-base/gnome-control-center/gnome-control-center-3.2.2-r1.ebuild
index a718f5cd0248..be38a538aadc 100644
--- a/gnome-base/gnome-control-center/gnome-control-center-3.2.1.ebuild
+++ b/gnome-base/gnome-control-center/gnome-control-center-3.2.2-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/gnome-control-center-3.2.1.ebuild,v 1.4 2012/02/14 04:55:31 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/gnome-control-center-3.2.2-r1.ebuild,v 1.1 2012/02/14 10:43:43 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen
-inherit autotools gnome2
+inherit autotools eutils gnome2
DESCRIPTION="GNOME Desktop Configuration Tool"
HOMEPAGE="http://www.gnome.org/"
@@ -86,7 +86,9 @@ DEPEND="${COMMON_DEPEND}
app-text/scrollkeeper
>=app-text/gnome-doc-utils-0.10.1
- cups? ( sys-apps/sed )"
+ cups? ( sys-apps/sed )
+
+ gnome-base/gnome-common"
# Needed for autoreconf
# gnome-base/gnome-common
@@ -102,6 +104,15 @@ pkg_setup() {
}
src_prepare() {
+ # Upstream patch to not crash on missing metacity; will be in next release
+ epatch "${FILESDIR}/${P}-metacity-gconf.patch"
+
+ # bug #403527, https://bugzilla.gnome.org/show_bug.cgi?id=670042
+ epatch "${FILESDIR}/${P}-timezone-free.patch"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=670051, requires eautoreconf
+ epatch "${FILESDIR}/${P}-timezones-linguas.patch"
+
# Make colord plugin optional; requires eautoreconf
epatch "${FILESDIR}/${PN}-3.2.1-optional-colord.patch"
eautoreconf