summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-01-30 15:52:26 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-01-30 15:52:26 +0000
commit7ff11ed106e20d0ae85d4478e57df68d0301872d (patch)
tree48ab1dcf1977c8507357de032e90791dc302d823 /gnome-base
parentAdding 1.0.16 release candidates, for bug #207427. (diff)
downloadgentoo-2-7ff11ed106e20d0ae85d4478e57df68d0301872d.tar.gz
gentoo-2-7ff11ed106e20d0ae85d4478e57df68d0301872d.tar.bz2
gentoo-2-7ff11ed106e20d0ae85d4478e57df68d0301872d.zip
Bump to 2.14.12
+ Fix the build with glib 2.15 + Various cleanups and fixes for win32 (Tor) + Fix off by one in all method name lengths. Fixes interoperability with other ORBs (J. Specht) (Portage version: 2.1.4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/orbit/ChangeLog11
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.14.123
-rw-r--r--gnome-base/orbit/orbit-2.14.12.ebuild38
3 files changed, 51 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index d0c32a32d8d6..d211294054af 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.119 2008/01/01 22:53:12 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.120 2008/01/30 15:52:25 dang Exp $
+
+*orbit-2.14.12 (30 Jan 2008)
+
+ 30 Jan 2008; Daniel Gryniewicz <dang@gentoo.org> +orbit-2.14.12.ebuild:
+ Bump to 2.14.12
+ + Fix the build with glib 2.15
+ + Various cleanups and fixes for win32 (Tor)
+ + Fix off by one in all method name lengths.
+ Fixes interoperability with other ORBs (J. Specht)
01 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org> -orbit-2.14.2.ebuild,
-orbit-2.14.8-r2.ebuild, -orbit-2.14.9.ebuild:
diff --git a/gnome-base/orbit/files/digest-orbit-2.14.12 b/gnome-base/orbit/files/digest-orbit-2.14.12
new file mode 100644
index 000000000000..eefaf654fdd0
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.14.12
@@ -0,0 +1,3 @@
+MD5 6f4bf7d803d442e9d093a0daa203d506 ORBit2-2.14.12.tar.bz2 746309
+RMD160 ab535a00dacef3f4a80d685406c0dd115b424207 ORBit2-2.14.12.tar.bz2 746309
+SHA256 d60027a4a36e64d02723d00b76c08e8d92850cab6269b2edcda4a1bb30cc7723 ORBit2-2.14.12.tar.bz2 746309
diff --git a/gnome-base/orbit/orbit-2.14.12.ebuild b/gnome-base/orbit/orbit-2.14.12.ebuild
new file mode 100644
index 000000000000..77974e921235
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.12.ebuild,v 1.1 2008/01/30 15:52:25 dang Exp $
+
+inherit gnome2 eutils
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libIDL-0.8.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}