summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-22 07:37:37 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-22 07:37:37 +0000
commit60129370651af3b810f8b44c97fd588d42ece571 (patch)
treeb6dd76780d8a79b1d061f61ea2d7adce8c117e74 /gnome-base
parentadd support for checking out via a date string (-D) by Thomas Rausch #443014 (diff)
downloadgentoo-2-60129370651af3b810f8b44c97fd588d42ece571.tar.gz
gentoo-2-60129370651af3b810f8b44c97fd588d42ece571.tar.bz2
gentoo-2-60129370651af3b810f8b44c97fd588d42ece571.zip
Version bump; fixes lots of bugs, including #450290 (gsettings-list-recursively crash), #451042 (caps lock key unreliable if used for layout switching), and adds a KDE-compatible org.freedesktop.ScreenSaver.xml dbus interface. Rename USE=wacom to INPUT_DEVICES=wacom to match the rest of the tree. Update license. Drop old.
(Portage version: 2.2.0_alpha158/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/ChangeLog15
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.6.4-optional-color-wacom.patch76
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.32.1-r2.ebuild6
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.2.3.ebuild129
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild51
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.3.ebuild39
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.4.ebuild119
-rw-r--r--gnome-base/gnome-settings-daemon/metadata.xml2
8 files changed, 258 insertions, 179 deletions
diff --git a/gnome-base/gnome-settings-daemon/ChangeLog b/gnome-base/gnome-settings-daemon/ChangeLog
index ea30d5addf68..d8422b360976 100644
--- a/gnome-base/gnome-settings-daemon/ChangeLog
+++ b/gnome-base/gnome-settings-daemon/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for gnome-base/gnome-settings-daemon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.114 2013/01/06 09:37:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.115 2013/01/22 07:37:37 tetromino Exp $
+
+*gnome-settings-daemon-3.6.4 (22 Jan 2013)
+
+ 22 Jan 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gnome-settings-daemon-2.32.1-r2.ebuild, -gnome-settings-daemon-3.2.3.ebuild,
+ gnome-settings-daemon-3.4.2.ebuild, gnome-settings-daemon-3.6.3.ebuild,
+ +gnome-settings-daemon-3.6.4.ebuild,
+ +files/gnome-settings-daemon-3.6.4-optional-color-wacom.patch, metadata.xml:
+ Version bump; fixes lots of bugs, including #450290
+ (gsettings-list-recursively crash), #451042 (caps lock key unreliable if used
+ for layout switching), and adds a KDE-compatible
+ org.freedesktop.ScreenSaver.xml dbus interface. Rename USE=wacom to
+ INPUT_DEVICES=wacom to match the rest of the tree. Update license. Drop old.
06 Jan 2013; Agostino Sarubbo <ago@gentoo.org>
gnome-settings-daemon-3.6.3.ebuild:
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.6.4-optional-color-wacom.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.6.4-optional-color-wacom.patch
new file mode 100644
index 000000000000..bd02900a40af
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.6.4-optional-color-wacom.patch
@@ -0,0 +1,76 @@
+diff --git a/configure.ac b/configure.ac
+index d1739c4..752c09d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -241,7 +241,20 @@ dnl ---------------------------------------------------------------------------
+ dnl - color
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++AC_ARG_ENABLE([color],
++ AS_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [with_color=$enableval],
++ [with_color=yes]) dnl Default value
++
++if test x$with_color = xyes; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ AC_DEFINE(HAVE_COLOR, 1, [Define if color plugin is enabled])
++fi
++AM_CONDITIONAL(WITH_COLOR, test "x$with_color" = "xyes")
++
++AC_SUBST(COLOR_CFLAGS)
++AC_SUBST(COLOR_LIBS)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - wacom (disabled for s390/s390x and non Linux platforms)
+@@ -253,11 +266,22 @@ case $host_os in
+ have_wacom=no
+ else
+ if test x$enable_gudev != xno; then
+- PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
++ AC_ARG_ENABLE([wacom],
++ AS_HELP_STRING([--disable-wacom],
++ [turn off wacom plugin]),
++ [with_wacom=$enableval],
++ [with_wacom=no]) dnl Default value
++
++ if test x$with_wacom = xyes; then
++ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
++ have_wacom=yes
++ fi
++
++ AC_SUBST(WACOM_CFLAGS)
++ AC_SUBST(WACOM_LIBS)
+ else
+ AC_MSG_ERROR([GUdev is necessary to compile Wacom support])
+ fi
+- have_wacom=yes
+ fi
+ ;;
+ *)
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 69b7181..a1cdf6c 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -6,7 +6,6 @@ enabled_plugins = \
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ dummy \
+ power \
+@@ -22,6 +21,12 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if WITH_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if HAVE_PACKAGEKIT
+ enabled_plugins += updates
+ else
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.32.1-r2.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.32.1-r2.ebuild
index ab46df9b5168..9aa88ae3bbe5 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.32.1-r2.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.32.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.32.1-r2.ebuild,v 1.9 2012/05/05 05:38:09 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.32.1-r2.ebuild,v 1.10 2013/01/22 07:37:37 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
@@ -17,7 +17,7 @@ SRC_URI="${SRC_URI} http://dev.gentoo.org/~pacho/gnome/gnome-settings-daemon-2.3
# mirror://gentoo/${PN}-2.30.0-gst-vol-control-support.patch" -> this causes bug #327609
# mirror://gentoo/${PN}-2.30.2-gst-vol-control-support.patch.bz2" -> this patch has worse problems like bug #339732
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="debug libnotify policykit pulseaudio smartcard"
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.2.3.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.2.3.ebuild
deleted file mode 100644
index 99e297fc1673..000000000000
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.2.3.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.2.3.ebuild,v 1.5 2012/12/11 09:33:51 ssuominen Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit autotools eutils gnome2 virtualx
-
-DESCRIPTION="Gnome Settings Daemon"
-HOMEPAGE="http://www.gnome.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+colord +cups debug packagekit policykit +short-touchpad-timeout smartcard +udev"
-
-# Latest gsettings-desktop-schemas is needed due to commit e8d1de92
-# Latest gnome-desktop needed to fix the DPMS timeout bug #385063
-# colord-0.1.13 needed to avoid polkit errors in CreateProfile and CreateDevice
-# upower-0.9.11 needed for UpSleepKind
-COMMON_DEPEND=">=dev-libs/dbus-glib-0.74
- >=dev-libs/glib-2.29.14:2
- >=x11-libs/gtk+-3.1.10:3
- >=gnome-base/gconf-2.6.1:2
- >=gnome-base/libgnomekbd-2.91.1
- >=gnome-base/gnome-desktop-3.2.0-r1:3
- >=gnome-base/gsettings-desktop-schemas-0.1.7.1
- media-fonts/cantarell
- media-libs/fontconfig
- >=media-libs/lcms-2.2:2
- media-libs/libcanberra[gtk3]
- >=media-sound/pulseaudio-0.9.16
- >=sys-power/upower-0.9.11
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- >=x11-libs/libnotify-0.7.3
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXxf86misc
- >=x11-libs/libxklavier-5.0
- >=media-sound/pulseaudio-0.9.16
-
- colord? ( >=x11-misc/colord-0.1.13 )
- cups? ( >=net-print/cups-1.4[dbus] )
- packagekit? (
- virtual/udev[gudev]
- >=app-admin/packagekit-base-0.6.12 )
- policykit? (
- >=sys-auth/polkit-0.97
- >=sys-apps/dbus-1.1.2[X] )
- smartcard? ( >=dev-libs/nss-3.11.2 )
- udev? ( virtual/udev[gudev] )"
-# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
-# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
-# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
-RDEPEND="${COMMON_DEPEND}
- gnome-base/dconf
- >=x11-themes/gnome-themes-standard-2.91
- >=x11-themes/gnome-icon-theme-2.91
- >=x11-themes/gnome-icon-theme-symbolic-2.91
- !<gnome-base/gnome-control-center-2.22
- !<gnome-extra/gnome-color-manager-3.1.1
- !<gnome-extra/gnome-power-manager-3.1.3"
-# xproto-7.0.15 needed for power plugin
-DEPEND="${COMMON_DEPEND}
- cups? ( sys-apps/sed )
- sys-devel/gettext
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- x11-proto/inputproto
- x11-proto/kbproto
- x11-proto/xf86miscproto
- >=x11-proto/xproto-7.0.15"
-
-pkg_setup() {
- # README is empty
- DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
- G2CONF="${G2CONF}
- --disable-static
- --disable-schemas-compile
- --enable-gconf-bridge
- --with-pnpids=${EPREFIX}/usr/share/libgnome-desktop-3.0/pnp.ids
- $(use_enable colord color)
- $(use_enable cups)
- $(use_enable debug)
- $(use_enable debug more-warnings)
- $(use_enable packagekit)
- $(use_enable policykit polkit)
- $(use_enable smartcard smartcard-support)
- $(use_enable udev gudev)"
-}
-
-src_prepare() {
- # Backport patch from git master branch (not in gnome-3-2 branch yet)
- # fixing loading color profiles at startup
- epatch "${FILESDIR}/${PN}-3.2.0-color-unbreak-loading-profiles.patch"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=621836
- # Apparently this change severely affects touchpad usability for some
- # people, so revert it if USE=short-touchpad-timeout.
- # Revisit if/when upstream adds a setting for customizing the timeout.
- use short-touchpad-timeout &&
- epatch "${FILESDIR}/${PN}-3.0.2-short-touchpad-timeout.patch"
-
- # Make colord optional; requires eautoreconf
- epatch "${FILESDIR}/${PN}-3.2.1-optional-colord.patch"
-
- # bug #428816, https://bugzilla.gnome.org/show_bug.cgi?id=679761
- epatch "${FILESDIR}/${PN}-3.4.2-cups-1.6.patch"
-
- eautoreconf
-
- gnome2_src_prepare
-}
-
-src_test() {
- Xemake check
-}
-
-src_install() {
- gnome2_src_install
-
- echo 'GSETTINGS_BACKEND="dconf"' >> 51gsettings-dconf
- doenvd 51gsettings-dconf || die "doenvd failed"
-}
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild
index 32de5b7b06cd..bf0daf15c906 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild,v 1.5 2012/12/11 09:33:51 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild,v 1.6 2013/01/22 07:37:37 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -11,10 +11,10 @@ inherit autotools eutils gnome2 virtualx
DESCRIPTION="Gnome Settings Daemon"
HOMEPAGE="http://www.gnome.org"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+colord +cups debug packagekit policykit +short-touchpad-timeout smartcard systemd +udev wacom"
+IUSE="+colord +cups debug input_devices_wacom packagekit policykit +short-touchpad-timeout smartcard systemd +udev"
# colord-0.1.13 needed to avoid polkit errors in CreateProfile and CreateDevice
COMMON_DEPEND="
@@ -43,6 +43,9 @@ COMMON_DEPEND="
colord? ( >=x11-misc/colord-0.1.13 )
cups? ( >=net-print/cups-1.4[dbus] )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.6
+ x11-drivers/xf86-input-wacom )
packagekit? (
virtual/udev[gudev]
>=app-admin/packagekit-base-0.6.12 )
@@ -51,8 +54,7 @@ COMMON_DEPEND="
>=dev-libs/nss-3.11.2 )
systemd? ( >=sys-apps/systemd-31 )
udev? ( virtual/udev[gudev] )
- wacom? ( >=dev-libs/libwacom-0.3
- x11-drivers/xf86-input-wacom )"
+"
# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
@@ -75,24 +77,8 @@ DEPEND="${COMMON_DEPEND}
x11-proto/inputproto
x11-proto/kbproto
x11-proto/xf86miscproto
- >=x11-proto/xproto-7.0.15"
-
-pkg_setup() {
- # README is empty
- DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
- G2CONF="${G2CONF}
- --disable-static
- --disable-schemas-compile
- $(use_enable colord color)
- $(use_enable cups)
- $(use_enable debug)
- $(use_enable debug more-warnings)
- $(use_enable packagekit)
- $(use_enable smartcard smartcard-support)
- $(use_enable systemd)
- $(use_enable udev gudev)
- $(use_enable wacom)"
-}
+ >=x11-proto/xproto-7.0.15
+"
src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=621836
@@ -117,6 +103,23 @@ src_prepare() {
gnome2_src_prepare
}
+src_configure() {
+ # README is empty
+ DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+ gnome2_src_configure \
+ --disable-static \
+ --disable-schemas-compile \
+ $(use_enable colord color) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable debug more-warnings) \
+ $(use_enable packagekit) \
+ $(use_enable smartcard smartcard-support) \
+ $(use_enable systemd) \
+ $(use_enable udev gudev) \
+ $(use_enable input_devices_wacom wacom)
+}
+
src_test() {
Xemake check
}
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.3.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.3.ebuild
index 4c966422ee99..e37bf8189ec9 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.3.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.3.ebuild,v 1.4 2013/01/06 09:37:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.3.ebuild,v 1.5 2013/01/22 07:37:37 tetromino Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -11,9 +11,9 @@ inherit autotools eutils gnome2 virtualx
DESCRIPTION="Gnome Settings Daemon"
HOMEPAGE="http://www.gnome.org"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
-IUSE="+colord +cups debug +i18n packagekit policykit +short-touchpad-timeout smartcard systemd +udev wacom"
+IUSE="+colord +cups debug +i18n input_devices_wacom packagekit policykit +short-touchpad-timeout smartcard systemd +udev"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
REQUIRED_USE="
packagekit? ( udev )
@@ -46,13 +46,13 @@ COMMON_DEPEND="
colord? ( >=x11-misc/colord-0.1.13 )
cups? ( >=net-print/cups-1.4[dbus] )
i18n? ( >=app-i18n/ibus-1.4.99 )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.6
+ x11-drivers/xf86-input-wacom )
packagekit? ( >=app-admin/packagekit-base-0.7.4 )
smartcard? ( >=dev-libs/nss-3.11.2 )
systemd? ( >=sys-apps/systemd-31 )
udev? ( virtual/udev[gudev] )
- wacom? (
- >=dev-libs/libwacom-0.6
- x11-drivers/xf86-input-wacom )
"
# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
@@ -99,20 +99,19 @@ src_prepare() {
src_configure() {
# README is empty
DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
- G2CONF="${G2CONF}
- --disable-static
- --enable-man
- $(use_enable colord color)
- $(use_enable cups)
- $(use_enable debug)
- $(use_enable debug more-warnings)
- $(use_enable i18n ibus)
- $(use_enable packagekit)
- $(use_enable smartcard smartcard-support)
- $(use_enable systemd)
- $(use_enable udev gudev)
- $(use_enable wacom)"
- gnome2_src_configure
+ gnome2_src_configure \
+ --disable-static \
+ --enable-man \
+ $(use_enable colord color) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable debug more-warnings) \
+ $(use_enable i18n ibus) \
+ $(use_enable packagekit) \
+ $(use_enable smartcard smartcard-support) \
+ $(use_enable systemd) \
+ $(use_enable udev gudev) \
+ $(use_enable input_devices_wacom wacom)
}
src_test() {
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.4.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.4.ebuild
new file mode 100644
index 000000000000..dc17ed292987
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.6.4.ebuild,v 1.1 2013/01/22 07:37:37 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 virtualx
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+colord +cups debug +i18n input_devices_wacom packagekit policykit +short-touchpad-timeout smartcard systemd +udev"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+REQUIRED_USE="
+ packagekit? ( udev )
+ smartcard? ( udev )
+"
+
+# require colord-0.1.27 dependency for connection type support
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31.0:2
+ >=x11-libs/gtk+-3.3.4:3
+ >=gnome-base/gnome-desktop-3.5.3:3=
+ >=gnome-base/gsettings-desktop-schemas-3.5.90
+ media-fonts/cantarell
+ media-libs/fontconfig
+ >=media-libs/lcms-2.2:2
+ media-libs/libcanberra[gtk3]
+ >=media-sound/pulseaudio-0.9.16
+ >=sys-power/upower-0.9.11
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libnotify-0.7.3:=
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ x11-libs/libXxf86misc
+
+ colord? ( >=x11-misc/colord-0.1.27:= )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ i18n? ( >=app-i18n/ibus-1.4.99 )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.6
+ x11-drivers/xf86-input-wacom )
+ packagekit? ( >=app-admin/packagekit-base-0.7.4 )
+ smartcard? ( >=dev-libs/nss-3.11.2 )
+ systemd? ( >=sys-apps/systemd-31 )
+ udev? ( virtual/udev[gudev] )
+"
+# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
+# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
+# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ >=x11-themes/gnome-themes-standard-2.91
+ >=x11-themes/gnome-icon-theme-2.91
+ >=x11-themes/gnome-icon-theme-symbolic-2.91
+ !<gnome-base/gnome-control-center-2.22
+ !<gnome-extra/gnome-color-manager-3.1.1
+ !<gnome-extra/gnome-power-manager-3.1.3
+
+ !systemd? ( sys-auth/consolekit )
+"
+# xproto-7.0.15 needed for power plugin
+DEPEND="${COMMON_DEPEND}
+ cups? ( sys-apps/sed )
+ dev-libs/libxml2:2
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ x11-proto/inputproto
+ x11-proto/xf86miscproto
+ >=x11-proto/xproto-7.0.15
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=621836
+ # Apparently this change severely affects touchpad usability for some
+ # people, so revert it if USE=short-touchpad-timeout.
+ # Revisit if/when upstream adds a setting for customizing the timeout.
+ use short-touchpad-timeout &&
+ epatch "${FILESDIR}/${PN}-3.5.91-short-touchpad-timeout.patch"
+
+ # Make colord and wacom optional; requires eautoreconf
+ epatch "${FILESDIR}/${PN}-3.6.4-optional-color-wacom.patch"
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # README is empty
+ DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+ gnome2_src_configure \
+ --disable-static \
+ --enable-man \
+ $(use_enable colord color) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable debug more-warnings) \
+ $(use_enable i18n ibus) \
+ $(use_enable packagekit) \
+ $(use_enable smartcard smartcard-support) \
+ $(use_enable systemd) \
+ $(use_enable udev gudev) \
+ $(use_enable input_devices_wacom wacom)
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/gnome-base/gnome-settings-daemon/metadata.xml b/gnome-base/gnome-settings-daemon/metadata.xml
index b258fed96ee3..5b106cd32729 100644
--- a/gnome-base/gnome-settings-daemon/metadata.xml
+++ b/gnome-base/gnome-settings-daemon/metadata.xml
@@ -13,7 +13,5 @@
it's effective for fast typists</flag>
<flag name="systemd">Use <pkg>sys-apps/systemd</pkg> instead of
<pkg>sys-auth/consolekit</pkg> for session tracking</flag>
- <flag name="wacom">Enable support for Wacom tablets and drawing
- devices</flag>
</use>
</pkgmetadata>