summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-03-30 11:57:26 +0000
committerPacho Ramos <pacho@gentoo.org>2010-03-30 11:57:26 +0000
commit222922b5957b5d74b6d37622d88304d77ecd2432 (patch)
treed06759b934c6bf697cc5c6571f5af4c77a7fb45a /gnome-base/orbit
parentChange USE pango to cairo reflecting desktop/make.defaults logic. (diff)
downloadgentoo-2-222922b5957b5d74b6d37622d88304d77ecd2432.tar.gz
gentoo-2-222922b5957b5d74b6d37622d88304d77ecd2432.tar.bz2
gentoo-2-222922b5957b5d74b6d37622d88304d77ecd2432.zip
Version bump with some bug fixes
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog9
-rw-r--r--gnome-base/orbit/orbit-2.14.18.ebuild59
2 files changed, 67 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 5805ba189b18..945d8ce995bc 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.157 2010/01/18 00:01:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.158 2010/03/30 11:57:26 pacho Exp $
+
+*orbit-2.14.18 (30 Mar 2010)
+
+ 30 Mar 2010; Pacho Ramos <pacho@gentoo.org> +orbit-2.14.18.ebuild:
+ Version bump with some bug fixes: add a g_warning, fix FMR in forwarding
+ code, fix some problems with the preprocessor on Solaris, add a
+ CORBA_wstring_dup function.
18 Jan 2010; Jeroen Roovers <jer@gentoo.org> orbit-2.14.17.ebuild:
Stable for HPPA (bug #281427).
diff --git a/gnome-base/orbit/orbit-2.14.18.ebuild b/gnome-base/orbit/orbit-2.14.18.ebuild
new file mode 100644
index 000000000000..ecbbc7c51458
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.18.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.18.ebuild,v 1.1 2010/03/30 11:57:26 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 toolchain-funcs
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libIDL-0.8.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix wrong process kill, bug #268142
+ sed "s:killall lt-timeout-server:killall timeout-server:" \
+ -i test/timeout.sh || die "sed failed"
+}
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ # We need to use the hosts IDL compiler if cross-compiling, bug #262741
+ if tc-is-cross-compiler; then
+ # check that host version is present and executable
+ [ -x /usr/bin/orbit-idl-2 ] || die "Please emerge ~${CATEGORY}/${P} on the host system first"
+ G2CONF="${G2CONF} --with-idl-compiler=/usr/bin/orbit-idl-2"
+ fi
+
+ gnome2_src_compile
+}
+
+src_test() {
+ # can fail in parallel, see bug #235994
+ emake -j1 check || die "tests failed"
+}