summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 17:15:56 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 17:15:56 +0000
commitebb95200f71b0eca2bdec43cc9ea64236be7fb6b (patch)
tree25bb8af08f227ab22d9ec6ab3c2809145128dda8 /gnome-base/libgnome-keyring/libgnome-keyring-3.8.0.ebuild
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-ebb95200f71b0eca2bdec43cc9ea64236be7fb6b.tar.gz
gentoo-2-ebb95200f71b0eca2bdec43cc9ea64236be7fb6b.tar.bz2
gentoo-2-ebb95200f71b0eca2bdec43cc9ea64236be7fb6b.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/libgnome-keyring/libgnome-keyring-3.8.0.ebuild')
-rw-r--r--gnome-base/libgnome-keyring/libgnome-keyring-3.8.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnome-base/libgnome-keyring/libgnome-keyring-3.8.0.ebuild b/gnome-base/libgnome-keyring/libgnome-keyring-3.8.0.ebuild
new file mode 100644
index 000000000000..cb3d9d98e744
--- /dev/null
+++ b/gnome-base/libgnome-keyring/libgnome-keyring-3.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome-keyring/libgnome-keyring-3.8.0.ebuild,v 1.1 2013/03/28 17:15:56 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit gnome2 python-any-r1 vala
+
+DESCRIPTION="Compatibility library for accessing secrets"
+HOMEPAGE="http://live.gnome.org/GnomeKeyring"
+
+LICENSE="LGPL-2+ GPL-2+" # tests are GPL-2
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris"
+IUSE="debug +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=sys-apps/dbus-1.0
+ >=gnome-base/gnome-keyring-3.1.92
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ G2CONF="${G2CONF} $(use_enable vala)"
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+
+ # FIXME: Remove silly CFLAGS
+ sed -e 's:CFLAGS="$CFLAGS -g:CFLAGS="$CFLAGS:' \
+ -e 's:CFLAGS="$CFLAGS -O0:CFLAGS="$CFLAGS:' \
+ -i configure.ac configure || die "sed failed"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ dbus-launch emake check || die "tests failed"
+}