summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-03-22 17:50:32 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-03-22 17:50:32 +0000
commit2e1631d99cbe165cdd8dec2539f229472bdf9336 (patch)
tree2f43007afa6a2e23372c1e411e0f8eb7580e8fa1 /gnome-base/gnome-session
parentVersion bump (diff)
downloadgentoo-2-2e1631d99cbe165cdd8dec2539f229472bdf9336.tar.gz
gentoo-2-2e1631d99cbe165cdd8dec2539f229472bdf9336.tar.bz2
gentoo-2-2e1631d99cbe165cdd8dec2539f229472bdf9336.zip
Set XCURSOR_THEME from current dconf settings so non-gtk applications get the right mouse cursor. Note: you will have to log out and back in to update the env variable after changing the mouse cursor in gnome-tweak-tool.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'gnome-base/gnome-session')
-rw-r--r--gnome-base/gnome-session/ChangeLog11
-rw-r--r--gnome-base/gnome-session/files/90-xcursor-theme-gnome11
-rw-r--r--gnome-base/gnome-session/gnome-session-3.14.0-r2.ebuild125
3 files changed, 146 insertions, 1 deletions
diff --git a/gnome-base/gnome-session/ChangeLog b/gnome-base/gnome-session/ChangeLog
index 5deeb6630163..11b97e63ea46 100644
--- a/gnome-base/gnome-session/ChangeLog
+++ b/gnome-base/gnome-session/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-base/gnome-session
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-session/ChangeLog,v 1.348 2015/03/15 13:23:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-session/ChangeLog,v 1.349 2015/03/22 17:50:31 tetromino Exp $
+
+*gnome-session-3.14.0-r2 (22 Mar 2015)
+
+ 22 Mar 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gnome-session-3.14.0-r2.ebuild, +files/90-xcursor-theme-gnome:
+ Set XCURSOR_THEME from current dconf settings so non-gtk applications get the
+ right mouse cursor.
+ Note: you will have to log out and back in to update the env variable after
+ changing the mouse cursor in gnome-tweak-tool.
15 Mar 2015; Pacho Ramos <pacho@gentoo.org> gnome-session-3.14.0-r1.ebuild:
x86 stable, bug 534012
diff --git a/gnome-base/gnome-session/files/90-xcursor-theme-gnome b/gnome-base/gnome-session/files/90-xcursor-theme-gnome
new file mode 100644
index 000000000000..13bc453c7854
--- /dev/null
+++ b/gnome-base/gnome-session/files/90-xcursor-theme-gnome
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+if [ "$DESKTOP_SESSION" = "gnome" -o "$DESKTOP_SESSION" = "cinnamon" ]; then
+ XCURSOR_THEME=`dconf read /org/gnome/desktop/interface/cursor-theme` 2> /dev/null
+ if [ x"$XCURSOR_THEME" = "x" ]; then
+ export XCURSOR_THEME="Adwaita"
+ else
+ # 'dconf read' wraps string output in single quotes
+ eval export "XCURSOR_THEME=$XCURSOR_THEME"
+ fi
+fi
diff --git a/gnome-base/gnome-session/gnome-session-3.14.0-r2.ebuild b/gnome-base/gnome-session/gnome-session-3.14.0-r2.ebuild
new file mode 100644
index 000000000000..f9ba1c4f62a9
--- /dev/null
+++ b/gnome-base/gnome-session/gnome-session-3.14.0-r2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-session/gnome-session-3.14.0-r2.ebuild,v 1.1 2015/03/22 17:50:31 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Gnome session manager"
+HOMEPAGE="https://git.gnome.org/browse/gnome-session"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc elibc_FreeBSD gconf ipv6 systemd"
+
+# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
+# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
+# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).
+# gdk-pixbuf used in the inhibit dialog
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40.0:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.90.7:3
+ >=dev-libs/json-glib-0.10
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gnome-desktop-3.9.91:3=
+ elibc_FreeBSD? ( dev-libs/libexecinfo )
+
+ virtual/opengl
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-misc/xdg-user-dirs
+ x11-misc/xdg-user-dirs-gtk
+ x11-apps/xdpyinfo
+
+ gconf? ( >=gnome-base/gconf-2:2 )
+ systemd? ( >=sys-apps/systemd-183:0= )
+"
+# Pure-runtime deps from the session files should *NOT* be added here
+# Otherwise, things like gdm pull in gnome-shell
+# gnome-themes-standard is needed for the failwhale dialog themeing
+# sys-apps/dbus[X] is needed for session management
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gnome-settings-daemon
+ >=gnome-base/gsettings-desktop-schemas-0.1.7
+ >=x11-themes/gnome-themes-standard-2.91.92
+ sys-apps/dbus[X]
+ !systemd? ( sys-auth/consolekit )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=sys-devel/gettext-0.10.40
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40.6
+ virtual/pkgconfig
+ !<gnome-base/gdm-2.20.4
+ doc? (
+ app-text/xmlto
+ dev-libs/libxslt )
+"
+# gnome-common needed for eautoreconf
+# gnome-base/gdm does not provide gnome.desktop anymore
+
+src_prepare() {
+ # Validate autostart condition gsettings key (from '3.14')
+ epatch "${FILESDIR}"/${P}-validate-autostart.patch
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # 1. Avoid automagic on old upower releases
+ # 2. xsltproc is always checked due to man configure
+ # switch, even if USE=-doc
+ gnome2_src_configure \
+ --disable-deprecation-flags \
+ --enable-session-selector \
+ $(use_enable doc docbook-docs) \
+ $(use_enable gconf) \
+ $(use_enable ipv6) \
+ $(use_enable systemd) \
+ UPOWER_CFLAGS="" \
+ UPOWER_LIBS=""
+ # gnome-session-selector pre-generated man page is missing
+ #$(usex !doc XSLTPROC=$(type -P true))
+}
+
+src_install() {
+ gnome2_src_install
+
+ dodir /etc/X11/Sessions
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/Gnome"
+
+ insinto /usr/share/applications
+ newins "${FILESDIR}/defaults.list-r3" gnome-mimeapps.list
+
+ dodir /etc/X11/xinit/xinitrc.d/
+ exeinto /etc/X11/xinit/xinitrc.d/
+ newexe "${FILESDIR}/15-xdg-data-gnome-r1" 15-xdg-data-gnome
+
+ # This should be done here as discussed in bug #270852
+ newexe "${FILESDIR}/10-user-dirs-update-gnome-r1" 10-user-dirs-update-gnome
+
+ # Set XCURSOR_THEME from current dconf setting instead of installing
+ # default cursor symlink globally and affecting other DEs (bug #543488)
+ # https://bugzilla.gnome.org/show_bug.cgi?id=711703
+ newexe "${FILESDIR}/90-xcursor-theme-gnome" 90-xcursor-theme-gnome
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version gnome-base/gdm && ! has_version kde-base/kdm; then
+ ewarn "If you use a custom .xinitrc for your X session,"
+ ewarn "make sure that the commands in the xinitrc.d scripts are run."
+ fi
+}