summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-03-07 14:40:02 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-03-07 14:40:02 +0000
commit71e1a1f19ccd2703833713a22c80d29f4b8a0a0c (patch)
treed2c3adcdc599d3a703d38617b7a8b2ae0527ac0c /gnome-base/gdm
parentUses com.sun classes so depend on java-virtuals/jdk-with-com-sun. Fixes bug #... (diff)
downloadgentoo-2-71e1a1f19ccd2703833713a22c80d29f4b8a0a0c.tar.gz
gentoo-2-71e1a1f19ccd2703833713a22c80d29f4b8a0a0c.tar.bz2
gentoo-2-71e1a1f19ccd2703833713a22c80d29f4b8a0a0c.zip
Remove all traces of HAL from gdm and remove the HAL dep, fixes bug 295206
(Portage version: 2.1.8.1/cvs/Linux i686)
Diffstat (limited to 'gnome-base/gdm')
-rw-r--r--gnome-base/gdm/ChangeLog8
-rw-r--r--gnome-base/gdm/files/gdm-2.28.2-remove-hal.patch194
-rw-r--r--gnome-base/gdm/gdm-2.28.2-r1.ebuild205
3 files changed, 406 insertions, 1 deletions
diff --git a/gnome-base/gdm/ChangeLog b/gnome-base/gdm/ChangeLog
index e49a45c91444..6890fd205f37 100644
--- a/gnome-base/gdm/ChangeLog
+++ b/gnome-base/gdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gdm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/ChangeLog,v 1.316 2010/03/05 10:27:08 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/ChangeLog,v 1.317 2010/03/07 14:40:01 nirbheek Exp $
+
+*gdm-2.28.2-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +gdm-2.28.2-r1.ebuild,
+ +files/gdm-2.28.2-remove-hal.patch:
+ Remove all traces of HAL from gdm and remove the HAL dep, fixes bug 295206
05 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> gdm-2.28.2.ebuild:
Add dep on xdg-utils, fixes bug 302135
diff --git a/gnome-base/gdm/files/gdm-2.28.2-remove-hal.patch b/gnome-base/gdm/files/gdm-2.28.2-remove-hal.patch
new file mode 100644
index 000000000000..e72a30f84bae
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-2.28.2-remove-hal.patch
@@ -0,0 +1,194 @@
+Remove all traces of HAL. The last hunk which removes test-hal-seats.c has been
+deleted to save space; the file is manually removed instead.
+
+http://bugs.gentoo.org/show_bug.cgi?id=295206
+---
+From 3daaac264df2f5a587c35cd8e41ecf18900fa9c9 Mon Sep 17 00:00:00 2001
+From: Martin Pitt <martin.pitt@ubuntu.com>
+Date: Thu, 21 Jan 2010 00:00:02 +0100
+Subject: [PATCH] remove remaining traces of Hal
+
+The code which used the Hal connection already was disabled, so gdm connected
+to Hal in vain (which just triggered Hal startup when using D-Bus activation).
+Remove all remaining traces of hal now.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=593787
+---
+ daemon/Makefile.am | 9 --
+ daemon/gdm-local-display-factory.c | 110 -----------------------
+ daemon/test-hal-seats.c | 173 ------------------------------------
+ 3 files changed, 0 insertions(+), 293 deletions(-)
+ delete mode 100644 daemon/test-hal-seats.c
+
+diff --git a/daemon/Makefile.am b/daemon/Makefile.am
+index a122a15..79bb63e 100644
+--- a/daemon/Makefile.am
++++ b/daemon/Makefile.am
+@@ -75,18 +75,9 @@ gdm-product-display-glue.h: gdm-product-display.xml Makefile.am
+ dbus-binding-tool --prefix=gdm_product_display --mode=glib-server --output=gdm-product-display-glue.h $(srcdir)/gdm-product-display.xml
+
+ noinst_PROGRAMS = \
+- test-hal-seats \
+ test-session \
+ $(NULL)
+
+-test_hal_seats_SOURCES = \
+- test-hal-seats.c \
+- $(NULL)
+-
+-test_hal_seats_LDADD = \
+- $(DAEMON_LIBS) \
+- $(NULL)
+-
+ test_session_SOURCES = \
+ test-session.c \
+ gdm-session.c \
+diff --git a/daemon/gdm-local-display-factory.c b/daemon/gdm-local-display-factory.c
+index 3984ada..69daf9e 100644
+--- a/daemon/gdm-local-display-factory.c
++++ b/daemon/gdm-local-display-factory.c
+@@ -45,12 +45,6 @@
+ #define GDM_LOCAL_DISPLAY_FACTORY_DBUS_PATH GDM_DBUS_PATH "/LocalDisplayFactory"
+ #define GDM_MANAGER_DBUS_NAME "org.gnome.DisplayManager.LocalDisplayFactory"
+
+-#define HAL_DBUS_NAME "org.freedesktop.Hal"
+-#define HAL_DBUS_MANAGER_PATH "/org/freedesktop/Hal/Manager"
+-#define HAL_DBUS_MANAGER_INTERFACE "org.freedesktop.Hal.Manager"
+-#define HAL_DBUS_DEVICE_INTERFACE "org.freedesktop.Hal.Device"
+-#define SEAT_PCI_DEVICE_CLASS 3
+-
+ #define MAX_DISPLAY_FAILURES 5
+
+ struct GdmLocalDisplayFactoryPrivate
+@@ -372,83 +366,6 @@ create_display (GdmLocalDisplayFactory *factory)
+ return display;
+ }
+
+-#if 0
+-static void
+-create_display_for_device (GdmLocalDisplayFactory *factory,
+- DBusGProxy *device_proxy)
+-{
+- create_display (factory);
+-}
+-
+-static void
+-create_displays_for_pci_devices (GdmLocalDisplayFactory *factory)
+-{
+- char **devices;
+- const char *key;
+- const char *value;
+- GError *error;
+- gboolean res;
+- int i;
+-
+- g_debug ("GdmLocalDisplayFactory: Getting PCI seat devices");
+-
+- key = "info.bus";
+- value = "pci";
+-
+- devices = NULL;
+- error = NULL;
+- res = dbus_g_proxy_call (factory->priv->proxy,
+- "FindDeviceStringMatch",
+- &error,
+- G_TYPE_STRING, key,
+- G_TYPE_STRING, value,
+- G_TYPE_INVALID,
+- G_TYPE_STRV, &devices,
+- G_TYPE_INVALID);
+- if (! res) {
+- g_warning ("Unable to query HAL: %s", error->message);
+- g_error_free (error);
+- }
+-
+- /* now look for pci class 3 */
+- key = "pci.device_class";
+- for (i = 0; devices [i] != NULL; i++) {
+- DBusGProxy *device_proxy;
+- int class_val;
+-
+- device_proxy = dbus_g_proxy_new_for_name (factory->priv->connection,
+- HAL_DBUS_NAME,
+- devices [i],
+- HAL_DBUS_DEVICE_INTERFACE);
+- if (device_proxy == NULL) {
+- continue;
+- }
+-
+- error = NULL;
+- res = dbus_g_proxy_call (device_proxy,
+- "GetPropertyInteger",
+- &error,
+- G_TYPE_STRING, key,
+- G_TYPE_INVALID,
+- G_TYPE_INT, &class_val,
+- G_TYPE_INVALID);
+- if (! res) {
+- g_warning ("Unable to query HAL: %s", error->message);
+- g_error_free (error);
+- }
+-
+- if (class_val == SEAT_PCI_DEVICE_CLASS) {
+- g_debug ("GdmLocalDisplayFactory: Found device: %s", devices [i]);
+- create_display_for_device (factory, device_proxy);
+- }
+-
+- g_object_unref (device_proxy);
+- }
+-
+- g_strfreev (devices);
+-}
+-#endif
+-
+ static gboolean
+ gdm_local_display_factory_start (GdmDisplayFactory *base_factory)
+ {
+@@ -525,29 +442,6 @@ register_factory (GdmLocalDisplayFactory *factory)
+ return TRUE;
+ }
+
+-static gboolean
+-connect_to_hal (GdmLocalDisplayFactory *factory)
+-{
+- factory->priv->proxy = dbus_g_proxy_new_for_name (factory->priv->connection,
+- HAL_DBUS_NAME,
+- HAL_DBUS_MANAGER_PATH,
+- HAL_DBUS_MANAGER_INTERFACE);
+- if (factory->priv->proxy == NULL) {
+- g_warning ("Couldn't create proxy for HAL Manager");
+- return FALSE;
+- }
+-
+- return TRUE;
+-}
+-
+-static void
+-disconnect_from_hal (GdmLocalDisplayFactory *factory)
+-{
+- if (factory->priv->proxy == NULL) {
+- g_object_unref (factory->priv->proxy);
+- }
+-}
+-
+ static GObject *
+ gdm_local_display_factory_constructor (GType type,
+ guint n_construct_properties,
+@@ -565,8 +459,6 @@ gdm_local_display_factory_constructor (GType type,
+ g_warning ("Unable to register local display factory with system bus");
+ }
+
+- connect_to_hal (factory);
+-
+ return G_OBJECT (factory);
+ }
+
+@@ -611,8 +503,6 @@ gdm_local_display_factory_finalize (GObject *object)
+
+ g_hash_table_destroy (factory->priv->displays);
+
+- disconnect_from_hal (factory);
+-
+ G_OBJECT_CLASS (gdm_local_display_factory_parent_class)->finalize (object);
+ }
+
diff --git a/gnome-base/gdm/gdm-2.28.2-r1.ebuild b/gnome-base/gdm/gdm-2.28.2-r1.ebuild
new file mode 100644
index 000000000000..fef18fad3cea
--- /dev/null
+++ b/gnome-base/gdm/gdm-2.28.2-r1.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/gdm-2.28.2-r1.ebuild,v 1.1 2010/03/07 14:40:01 nirbheek Exp $
+
+EAPI="2"
+
+inherit eutils pam gnome2 autotools
+
+DESCRIPTION="GNOME Display Manager"
+HOMEPAGE="http://www.gnome.org/projects/gdm/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE_LIBC="elibc_glibc"
+IUSE="accessibility +consolekit debug ipv6 gnome-keyring selinux tcpd test xinerama +xklavier $IUSE_LIBC"
+
+# Name of the tarball with gentoo specific files
+GDM_EXTRA="${PN}-2.20.9-gentoo-files-r1"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-2.26-gentoo-patches.tar.bz2
+ mirror://gentoo/${GDM_EXTRA}.tar.bz2"
+
+# FIXME: gdm has a strange behaviour on reboot (from runlevel), especially when xdm tries to stop it (its blocks).
+# NOTE: x11-base/xorg-server dep is for X_SERVER_PATH etc, bug 295686
+RDEPEND=">=sys-apps/devicekit-power-008
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.15.4
+ >=x11-libs/gtk+-2.10.0
+ >=x11-libs/pango-1.3
+ >=media-libs/libcanberra-0.4[gtk]
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2.6.1
+ >=gnome-base/gnome-panel-2
+ >=x11-misc/xdg-utils-1.0.2-r3
+
+ app-text/iso-codes
+
+ x11-base/xorg-server
+ x11-libs/libXi
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-apps/sessreg
+
+ virtual/pam
+ consolekit? ( sys-auth/consolekit )
+
+ accessibility? ( x11-libs/libXevie )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22[pam] )
+ selinux? ( sys-libs/libselinux )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ xinerama? ( x11-libs/libXinerama )
+ xklavier? ( >=x11-libs/libxklavier-4 )
+
+ !gnome-extra/fast-user-switch-applet"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.9.4 )
+ xinerama? ( x11-proto/xineramaproto )
+ sys-devel/gettext
+ x11-proto/inputproto
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ >=app-text/scrollkeeper-0.1.4
+ >=app-text/gnome-doc-utils-0.3.2"
+PDEPEND=">=sys-auth/pambase-20090430[consolekit=,gnome-keyring=]"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ # PAM is the only auth scheme supported
+ # even though configure lists shadow and crypt
+ # they don't have any corresponding code
+ G2CONF="${G2CONF}
+ --disable-schemas-install
+ --localstatedir=/var
+ --with-xdmcp=yes
+ --enable-authentication-scheme=pam
+ --with-pam-prefix=/etc
+ SOUND_PROGRAM=/usr/bin/gdmplay
+ $(use_with accessibility xevie)
+ $(use_enable debug)
+ $(use_enable ipv6)
+ $(use_enable xklavier libxklavier)
+ $(use_with consolekit console-kit)
+ $(use_with selinux)
+ $(use_with tcpd tcp-wrappers)
+ $(use_with xinerama)"
+
+ enewgroup gdm
+ enewuser gdm -1 -1 /var/lib/gdm gdm
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # remove unneeded linker directive for selinux (#41022)
+ epatch "${WORKDIR}/${PN}-2.26.1-selinux-remove-attr.patch"
+
+ # Make it daemonize so that the boot process can continue (#236701)
+ epatch "${WORKDIR}/${PN}-2.26.1-fix-daemonize-regression.patch"
+
+ # Fix VT grab problem causing GDM to grab VT2 instead of 7 (#261339)
+ epatch "${WORKDIR}/${PN}-2.26.1-broken-VT-detection.patch"
+
+ # Make custom session work, bug #.
+ epatch "${WORKDIR}/${PN}-2.26.1-custom-session.patch"
+
+ # ssh-agent handling must be done at xinitrc.d
+ epatch "${WORKDIR}/${PN}-2.26.1-xinitrc-ssh-agent.patch"
+
+ # Fix libxklavier automagic support
+ epatch "${WORKDIR}/${PN}-2.26.1-automagic-libxklavier-support.patch"
+
+ # Remove all traces of HAL
+ epatch "${FILESDIR}/${P}-remove-hal.patch"
+ rm -vf "${S}/daemon/test-hal-seats.c"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ local gentoodir="${WORKDIR}/${GDM_EXTRA}"
+
+ # gdm-binary should be gdm to work with our init (#5598)
+ rm -f "${D}/usr/sbin/gdm"
+ dosym /usr/sbin/gdm-binary /usr/sbin/gdm
+
+ # our x11's scripts point to /usr/bin/gdm
+ dosym /usr/sbin/gdm-binary /usr/bin/gdm
+
+ # log, etc.
+ keepdir /var/log/gdm
+ keepdir /var/gdm
+
+ fowners root:gdm /var/gdm
+ fperms 1770 /var/gdm
+
+ # add a custom xsession .desktop by default (#44537)
+ exeinto /etc/X11/dm/Sessions
+ doexe "${gentoodir}/custom.desktop" || die "doexe 1 failed"
+
+ # add xinitrc.d scripts
+ exeinto /etc/X11/xinit/xinitrc.d
+ doexe "${FILESDIR}/49-keychain" || die "doexe 2 failed"
+ doexe "${FILESDIR}/50-ssh-agent" || die "doexe 3 failed"
+
+ # install XDG_DATA_DIRS gdm changes
+ echo 'XDG_DATA_DIRS="/usr/share/gdm"' > 99xdg-gdm
+ doenvd 99xdg-gdm || die "doenvd failed"
+
+ # add a custom sound playing script (#248253)
+ dobin "${gentoodir}/gdmplay"
+
+ # avoid file collision, bug #213118
+ rm -f "${D}/usr/share/xsessions/gnome.desktop"
+
+ # We replace the pam stuff by our own
+ rm -rf "${D}/etc/pam.d"
+
+ use gnome-keyring && sed -i "s:#Keyring=::g" "${gentoodir}"/pam.d/*
+
+ dopamd "${gentoodir}"/pam.d/*
+ dopamsecurity console.apps "${gentoodir}/security/console.apps/gdmsetup"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ewarn
+ ewarn "This is an EXPERIMENTAL release, please bear with its bugs and"
+ ewarn "visit us on #gentoo-desktop if you have problems."
+ ewarn
+
+ elog "To make GDM start at boot, edit /etc/conf.d/xdm"
+ elog "and then execute 'rc-update add xdm default'."
+ elog "If you already have GDM running, you will need to restart it."
+
+ if use gnome-keyring; then
+ elog "For autologin to unlock your keyring, you need to set an empty"
+ elog "password on your keyring. Use app-crypt/seahorse for that."
+ fi
+
+ if [ -f "/etc/X11/gdm/gdm.conf" ]; then
+ elog "You had /etc/X11/gdm/gdm.conf which is the old configuration"
+ elog "file. It has been moved to /etc/X11/gdm/gdm-pre-gnome-2.16"
+ mv /etc/X11/gdm/gdm.conf /etc/X11/gdm/gdm-pre-gnome-2.16
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if [[ "$(rc-config list default | grep xdm)" != "" ]] ; then
+ elog "To remove GDM from startup please execute"
+ elog "'rc-update del xdm default'"
+ fi
+}