summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-05 09:59:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-05 09:59:11 +0000
commit5c8e774ae70052e9362f920b1d35816250ca5ad6 (patch)
tree1315395f27c9b0b8f0f1314e1a9a08d54947ad0c /games-util
parentClean up patch (maybe bug #538906). (diff)
downloadgentoo-2-5c8e774ae70052e9362f920b1d35816250ca5ad6.tar.gz
gentoo-2-5c8e774ae70052e9362f920b1d35816250ca5ad6.tar.bz2
gentoo-2-5c8e774ae70052e9362f920b1d35816250ca5ad6.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/joystick/ChangeLog10
-rw-r--r--games-util/joystick/files/joystick-1.4.8-build.patch39
-rw-r--r--games-util/joystick/joystick-1.4.8.ebuild29
3 files changed, 76 insertions, 2 deletions
diff --git a/games-util/joystick/ChangeLog b/games-util/joystick/ChangeLog
index 6cd695096a0f..9ed36e71c193 100644
--- a/games-util/joystick/ChangeLog
+++ b/games-util/joystick/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/joystick
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.25 2014/07/16 01:19:15 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.26 2015/02/05 09:59:11 mr_bones_ Exp $
+
+*joystick-1.4.8 (05 Feb 2015)
+
+ 05 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/joystick-1.4.8-build.patch, +joystick-1.4.8.ebuild:
+ version bump
*joystick-1.4.7 (16 Jul 2014)
diff --git a/games-util/joystick/files/joystick-1.4.8-build.patch b/games-util/joystick/files/joystick-1.4.8-build.patch
new file mode 100644
index 000000000000..f888ccd18812
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.4.8-build.patch
@@ -0,0 +1,39 @@
+--- linuxconsoletools-1.4.4.orig/docs/Makefile
++++ linuxconsoletools-1.4.4/docs/Makefile
+@@ -20,13 +20,17 @@
+ # 02110-1301 USA.
+
+ MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
+- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
++ ffset.1 ffcfstress.1 jscal-store.1 \
+ jscal-restore.1
+
++ifneq ($(USE_SDL),no)
++MANPAGES += ffmvforce.1
++endif
++
+ PREFIX ?= /usr/local
+
+ install:
+ install -d $(DESTDIR)$(PREFIX)/share/man/man1
+- install $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
++ install -m 644 $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
+
+ .PHONY: install
+--- linuxconsoletools-1.4.4.orig/utils/Makefile
++++ linuxconsoletools-1.4.4/utils/Makefile
+@@ -27,9 +27,13 @@
+
+ CFLAGS ?= -g -O2 -Wall
+
+-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
++PROGRAMS = inputattach jstest jscal fftest ffset \
+ ffcfstress jscal-restore jscal-store
+
++ifneq ($(USE_SDL),no)
++PROGRAMS += ffmvforce
++endif
++
+ PREFIX ?= /usr/local
+
+ compile: $(PROGRAMS)
diff --git a/games-util/joystick/joystick-1.4.8.ebuild b/games-util/joystick/joystick-1.4.8.ebuild
new file mode 100644
index 000000000000..c5f8d6f4ff65
--- /dev/null
+++ b/games-util/joystick/joystick-1.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-1.4.8.ebuild,v 1.1 2015/02/05 09:59:11 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="http://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="sdl"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}