summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-24 00:00:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-24 00:00:45 +0000
commit24246ec99b9ff059980d15b8e24a9e6215383ae2 (patch)
tree5dbddbc775c68a9c2084237bcceb88c77140ebf3 /games-util
parentEXTRA_ECONF -> RUBY_ECONF (Manifest recommit) (diff)
downloadgentoo-2-24246ec99b9ff059980d15b8e24a9e6215383ae2.tar.gz
gentoo-2-24246ec99b9ff059980d15b8e24a9e6215383ae2.tar.bz2
gentoo-2-24246ec99b9ff059980d15b8e24a9e6215383ae2.zip
clean up ugly ebuild
Diffstat (limited to 'games-util')
-rw-r--r--games-util/loki_patch/loki_patch-20040916.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/games-util/loki_patch/loki_patch-20040916.ebuild b/games-util/loki_patch/loki_patch-20040916.ebuild
index 618f1f33076d..ff5a5aa94b8c 100644
--- a/games-util/loki_patch/loki_patch-20040916.ebuild
+++ b/games-util/loki_patch/loki_patch-20040916.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20040916.ebuild,v 1.1 2004/09/21 22:40:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20040916.ebuild,v 1.2 2004/09/24 00:00:45 vapier Exp $
inherit eutils
@@ -11,26 +11,25 @@ SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-RESTRICT=""
IUSE=""
DEPEND="dev-util/xdelta
- dev-libs/libxml
- games-util/loki_setupdb"
+ dev-libs/libxml
+ games-util/loki_setupdb"
src_compile() {
./autogen.sh || die "autogen failed."
- EXTRA_ECONF="--with-setupdb=/usr/share/loki_setupdb"
- econf || die "econf failed."
- sed -i -e 's/\.\.\/loki_setupdb/\/usr\/share\/loki_setupdb/' \
- -e -e 's/-I$(SETUPDB)/-I$(SETUPDB)\/include/' Makefile
+ econf \
+ --with-setupdb=/usr/share/loki_setupdb \
+ || die "econf failed."
+ sed -i \
+ -e 's/\.\.\/loki_setupdb/\/usr\/share\/loki_setupdb/' \
+ -e 's/-I$(SETUPDB)/-I$(SETUPDB)\/include/' \
+ Makefile
emake || die "emake failed"
}
src_install() {
- # no DESTDIR-support in Makefile
- dodir /usr/bin
- exeinto /usr/bin
- doexe loki_patch make_patch || die "doexe failed."
- dodoc CHANGES NOTES README TODO || die "dodoc failed."
+ dobin loki_patch make_patch || die "doexe failed"
+ dodoc CHANGES NOTES README TODO
}