summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-28 20:40:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-28 20:40:27 +0000
commitf05644fb60923f517c4107ab67da64490b42108d (patch)
tree0e455e60ddb971ee723d167690e37070fa3b6661 /games-strategy
parent (Manifest recommit) (diff)
downloadgentoo-2-f05644fb60923f517c4107ab67da64490b42108d.tar.gz
gentoo-2-f05644fb60923f517c4107ab67da64490b42108d.tar.bz2
gentoo-2-f05644fb60923f517c4107ab67da64490b42108d.zip
version bump
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest10
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.111
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.11.ebuild41
4 files changed, 54 insertions, 5 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index d6759c8f92c3..27710e247f41 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.30 2004/06/24 23:30:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.31 2004/06/28 20:40:27 mr_bones_ Exp $
+
+*wesnoth-0.7.11 (28 Jun 2004)
+
+ 28 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> +wesnoth-0.7.11.ebuild:
+ version bump
*wesnoth-0.7.10 (21 Jun 2004)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 5a96876e9a88..e9cd4dd7d2e9 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,8 +1,10 @@
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 a681d96cc999f0e63d76d5f1cd158da2 ChangeLog 4138
+MD5 41bfdd1479b5d399a972f286b3bb60ee wesnoth-0.7.8.ebuild 1113
MD5 50f01032645d4069e44f399496e973cd wesnoth-0.7.9.ebuild 1116
MD5 47e46af1d44b08c673f97459ddbeb781 wesnoth-0.7.10.ebuild 1117
-MD5 41bfdd1479b5d399a972f286b3bb60ee wesnoth-0.7.8.ebuild 1113
-MD5 a681d96cc999f0e63d76d5f1cd158da2 ChangeLog 4138
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 8caf74723a1c656cc112cdd5d41dc196 files/digest-wesnoth-0.7.10 68
+MD5 47e46af1d44b08c673f97459ddbeb781 wesnoth-0.7.11.ebuild 1117
MD5 2cd6699b20930421a34650e4a1c03b83 files/digest-wesnoth-0.7.8 67
MD5 412612ed1704ad03f84dc127a5bb9045 files/digest-wesnoth-0.7.9 67
+MD5 8caf74723a1c656cc112cdd5d41dc196 files/digest-wesnoth-0.7.10 68
+MD5 92b397687e822d731d31d5a8371891ad files/digest-wesnoth-0.7.11 68
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.11 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.11
new file mode 100644
index 000000000000..129fe96778e4
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.11
@@ -0,0 +1 @@
+MD5 6eee8a3495aec8d5e509f15bdb7790db wesnoth-0.7.11.tar.gz 22050142
diff --git a/games-strategy/wesnoth/wesnoth-0.7.11.ebuild b/games-strategy/wesnoth/wesnoth-0.7.11.ebuild
new file mode 100644
index 000000000000..9a3f37d8a31b
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.11.ebuild,v 1.1 2004/06/28 20:40:27 mr_bones_ Exp $
+
+inherit flag-o-matic gcc games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ [ "$(gcc-fullversion)" == "3.4.0" ] && filter-flags -ftracer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable gnome) \
+ $(use_enable kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/icons" "${D}/usr/share/"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}